Basic ospf configuration isn't working

AlteredLainAlteredLain Registered Users Posts: 2 ■□□□□□□□□□
Okay i'm having troubles for hours now, can't make basic ospf work on cisco packet tracer :

in R1 :
int gi0/0
ip addr 192.168.1.1 255.255.255.0
no shut
int seri0/3/0
ip addr 192.168.2.1 255.255.255.0
no shut
in R2 :
int gi0/0
ip addr 192.168.3.1 255.255.255.0
no shut
int seri0/3/0
ip addr 192.168.2.2 255.255.255.0
no shut
in both :
route ospf 1
network 192.168.2.0 0.0.0.255 area 0
And then all i get when i go "debug ip ospf events" is :
00:08:26: OSPF: Rcv hello from 192.168.2.1 area 0 from Serial0/3/0 192.168.2.1

00:08:26: OSPF: End of hello processing
in my route i only got in R1 :
192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.1.0/24 is directly connected, GigabitEthernet0/0
L       192.168.1.1/32 is directly connected, GigabitEthernet0/0
     192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.2.0/24 is directly connected, Serial0/3/0
L       192.168.2.1/32 is directly connected, Serial0/3/0


and in R2
192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.2.0/24 is directly connected, Serial0/3/0
L       192.168.2.2/32 is directly connected, Serial0/3/0
     192.168.3.0/24 is variably subnetted, 2 subnets, 2 masks
C       192.168.3.0/24 is directly connected, GigabitEthernet0/0
L       192.168.3.1/32 is directly connected, GigabitEthernet0/0
for sho ip ospf datab in R1
Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.2.1     192.168.2.1     658         0x80000002 0x00ffa7 2
192.168.3.1     192.168.3.1     658         0x80000002 0x00f2b2 2
and in R2
Link ID         ADV Router      Age         Seq#       Checksum Link count
192.168.3.1     192.168.3.1     661         0x80000002 0x00f2b2 2
192.168.2.1     192.168.2.1     661         0x80000002 0x00ffa7 2
I have no idea why this doesn't work, i did exactly what the dude from Cbt nuggets and everyone on the internet is doing but ospf won't work for me...

Comments

  • tecnodog7tecnodog7 Member Posts: 129
    So here is the thing.
    192.168.2.0 network in on your serial network right. So you should be able to ping them without having to configure anything since they already know about each other(directly connected. The use of routing is of the network they don't know.
    You're not advertising int gi0/0 and gi 0/0.

    What you should do is,
    In R1
    route ospf 1
    network 192.168.1.0 0.0.0.255 area 0
    R2
    router ospf 1
    network 192.168.3.0 0.0.0.255 area 0

    This command will do two things
    1) Send hello packets on those interface as well
    2) Also advertise them.

    I did the lab too and it's working.

    Output from R1
    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/0
    ip address 192.168.2.1 255.255.255.0
    clock rate 2000000
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.1.0 0.0.0.255 area 0
    network 192.168.2.0 0.0.0.255 area 0

    output from R2

    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial0/0
    ip address 192.168.2.1 255.255.255.0
    clock rate 2000000
    !
    router ospf 1
    log-adjacency-changes
    network 192.168.1.0 0.0.0.255 area 0
    network 192.168.2.0 0.0.0.255 area 0


    R1#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route


    Gateway of last resort is not set


    C 192.168.1.0/24 is directly connected, FastEthernet0/0
    C 192.168.2.0/24 is directly connected, Serial0/0
    O 192.168.3.0/24 [110/65] via 192.168.2.2, 00:03:00, Serial0/0



    R2#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
    * - candidate default, U - per-user static route, o - ODR
    P - periodic downloaded static route


    Gateway of last resort is not set


    O 192.168.1.0/24 [110/65] via 192.168.2.1, 00:06:03, Serial0/0
    C 192.168.2.0/24 is directly connected, Serial0/0
    C 192.168.3.0/24 is directly connected, FastEthernet0/0


    --Hope this helps
  • AlteredLainAlteredLain Registered Users Posts: 2 ■□□□□□□□□□
    Oh god thank you so much technodog7, i thought the network command purpose was only to connect router by sending hello packets, not to advertise the network you input too.

    What a noob mistake, again thank you very much.
Sign In or Register to comment.