Options

Dhcp snooping error

FadakartelFadakartel Member Posts: 144
Good Day,

Currently im trying to set up dhcp snooping in packet tracer but it seems I ran into some issues that I have never gotten before, switchport fa0/1 is my trunk link to the dhcp server (router).

My dhcp was working fine prior to me setting up snooping on the switch here is a output from the switch:

Switch#show running-config
Building configuration...


Current configuration : 1119 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
ip dhcp snooping vlan 2,5
ip dhcp snooping
!
spanning-tree mode pvst
!
interface FastEthernet0/1
ip dhcp snooping trust
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 2
!
interface FastEthernet0/3
switchport access vlan 5
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
no ip address
shutdown
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end






And the output from the router:


Router#show running-config
Building configuration...


Current configuration : 844 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
ip dhcp pool Accounts
network 192.168.1.0 255.255.255.224
ip dhcp pool users
network 192.168.1.32 255.255.255.224
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.1.1 255.255.255.224
!
interface FastEthernet0/0.5
encapsulation dot1Q 5
ip address 192.168.1.62 255.255.255.224
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Thanks in advance.

Comments

  • Options
    HondabuffHondabuff Member Posts: 667 ■■■□□□□□□□
    Might be a bug in packet tracer. If you enable it globally then you don't have to assign it to the Vlans also. Usually one or the other.
    “The problem with quotes on the Internet is that you can’t always be sure of their authenticity.” ~Abraham Lincoln
Sign In or Register to comment.