Odd. or I am wrong.

satishtechsatishtech Posts: 243Member
Assigned an IP address to a 2901 Interface in packet tracer, unable to ping it unless I connect to another router. ping loopback works fine. seems odd to me.

Comments

  • SimridSimrid Posts: 327Member
    If you do a show ip int brief - Does it say down at all? Have you issued a no shutdown onto the interface? Is it a directly connected interface?
    Network Engineer | London, UK | Currently working on: CCIE Routing & Switching

    sriddle.co.uk
    uk.linkedin.com/in/simonriddle
  • MooseboostMooseboost Senior Member Posts: 767Member ■■■■□□□□□□
    Look at the show commands. Is the interface admin up? Is the line protocol up? Since you can successfully ping the loopback, compare the interface to the loopback to see the difference. You should be able to find the answer from that.
    2019 Certification Goals: OSCE OSWE
    Blog: https://hackfox.net
  • pevangelpevangel Posts: 342Member
    It doesn't go into the routing table unless the link is up. That's why it works when you connect another router because you just brought the link up.
  • satishtechsatishtech Posts: 243Member
    Router(config)#int g0/0
    Router(config-if)#ip address 192.168.1.1 255.255.255.0
    Router(config-if)#no shut Router#

    ping 192.168.1.1 Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds: ..... Success rate is 0 percent (0/5)

    It works when I connect the interface to another router and enable
    the other interface, no need to assign an IP to the other interface,
    just enable. Ping works.

    Pevangel Is this how it is supposed to be ?

    Simrid:
    Before connecting to the other Router:
    Router#sh ip int brief
    Interface IP-Address OK? Method Status Protocol

    GigabitEthernet0/0 192.168.1.1 YES manual up down

    After connecting to other Router:
    Router#sh ip int brief
    Interface IP-Address OK? Method Status Protocol

    GigabitEthernet0/0 192.168.1.1 YES manual up up

    Mooseboost:
    Router#sh int g0/0
    GigabitEthernet0/0 is up, line protocol is down (disabled)

    after connecting to the other interface I get this.
    Router#sh int g0/0
    GigabitEthernet0/0 is up, line protocol is up (connected)
  • santaownssantaowns Posts: 366Member
    The interface needs to be up up to work. Line protocol down means the link is down. When it is up up it will enable the interface and allow it to ping regardless if the other side is able to communicate with it. Layer 1 and 2 being up will enable router to begin layer 3. Hope that helps, this is the kind of stuff you troubleshoot in a NOC position fyi.
  • satishtechsatishtech Posts: 243Member
    Router(config-if)#
    %LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
    ip address 192.168.1.1 255.255.255.0
    Router(config-if)#no shut
    Router#show int g0/0
    GigabitEthernet0/0 is up, line protocol is down (disabled)

    so I can ping a Router interface only when that interface is connected
    to another interface.when keepalives start traversing the cable
    am I correct ?

    How can I Ping my own Router Interface assigned with an IP ?
  • HP_GuyHP_Guy Posts: 77Member ■■■□□□□□□□
    As an aside and somebody correct me if I am wrong...

    For labbing purposes (and not so much in PT as you can just add another router!) you can type 'keepalive 0' in the interface config to keep it up.
  • satishtechsatishtech Posts: 243Member
    cannot find keepalive command in interface configuration
    in packet tracer ? supposed to be under service command
    in configuration mode.
  • HP_GuyHP_Guy Posts: 77Member ■■■□□□□□□□
    hmmm.... not sure. I'm only on ICND1, but I had to look in my ICND2 book to find it (remembered seeing it on a video somewhere)! It's still configured on one of my lab routers at home. I'll have a look later.
  • santaownssantaowns Posts: 366Member
    Loopback ups come up automatically, interfaces such as serial Ethernet etc that have an ip set need the link to be up. You will see this sometimes when a t1 is down fyi.
  • pevangelpevangel Posts: 342Member
    Do show ip route and you'll notice that 192.168.1.0/24 doesn't show up in your routing table unless the link is up. That's why you can't ping it without connecting the other device.
  • Danielh22185Danielh22185 Posts: 1,195Member
    As stated you need a line protocol up to the IP address you are trying to ping, even if you are pinging the local interface. The only exception would be a logical interface such as a loop back that is not bound to line protocol status-states and comes up the moment you create them. Also you should be able to ping at the time of adding an IP address to a loopback.
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
  • satishtechsatishtech Posts: 243Member
    I am unable to ping , tried so many ways , default route,null route, static route
    between a loopback and connected interface.RIP , OSPF , ect
    As of now no way to ping an interface unless the interface is
    connected to something.I connected the interface to a switch
    and hub , now ping on router works.I guess keepalives are needed,
    atleast for packet tracer.I hope I am thinking correct.
Sign In or Register to comment.