Frame Relay 3 routers and 1 nm-4a/s - failed

BroadcastStormBroadcastStorm Posts: 496Member
I am currently trying to configure a Frame Relay using a nm-4a/s as my frame-relay cloud, line protocol on 3 routers stays shut.

Screenshots from 3 routers:

R1(config-if)#do show run
Building configuration...
Current configuration : 1137 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$9W3b$qfqEmdUZYmqMk2tkpWaTP/
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
ip audit po max-events 100
!
!
!
!
!
!
!
!
!
!
!
!
username R2 password 0 ccna
!
!
!
!
!
!
!
interface Ethernet0/0
ip address 172.23.23.1 255.255.255.0
full-duplex
!
interface Serial0/0
ip address 172.23.24.1 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay map ip 172.23.24.2 112
frame-relay map ip 172.23.24.3 113
no frame-relay inverse-arp
!
interface BRI0/0
no ip address
encapsulation hdlc
shutdown
!
interface Ethernet0/1
no ip address
shutdown
half-duplex
!
interface Serial1/0
no ip address
!
interface Serial1/1
no ip address
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
ip default-gateway 172.23.23.1
ip http server
no ip http secure-server
ip classless
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
password ccna
login
!
!
end

R2(config-if)#do show run
Building configuration...
Current configuration : 1177 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$wewb$82MtX9GU6BofPfVhnhxXu/
!
!
resource policy
!
no aaa new-model
memory-size iomem 10
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
!
!
no ip dhcp use vrf connected
!
!
ip cef
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username R1 password 0 ccna
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.23.23.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.23.24.2 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay map ip 172.12.123.1 221
frame-relay map ip 172.12.123.3 221
no frame-relay inverse-arp
!
interface BRI0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip default-gateway 172.23.23.2
ip classless
!
!
ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
password ccna
login
!
!
end
R3(config-if)#do show run
Building configuration...
Current configuration : 2892 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable password 7 0508050A2F58
!
!
resource policy
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip subnet-zero
!
!
no ip dhcp use vrf connected
!
!
ip cef
ip domain name maxlink.com
no ip ips deny-action ips-interface
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-1900805352
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1900805352
revocation-check none
rsakeypair TP-self-signed-1900805352
!
!
crypto pki certificate chain TP-self-signed-1900805352
certificate self-signed 01
30820246 308201AF A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 31393030 38303533 3532301E 170D3032 30333032 30333432
34335A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 39303038
30353335 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100CF86 50FC332F 68AC90D7 006DEBCB D5544A22 EEA73256 E638E357 A4AADA46
EE8C9B79 97C45886 7F3766F0 E03416FB DDF109F9 ECDECCF4 E4B09D82 425BBCA9
7A71A42B AD15C4AF 2CE835EE B5E557E4 1BC9CDEE 3077B591 E8B5F93A CCAB4508
0243B1A9 0C78BD56 409A88E1 4957C06F 09D23492 2516F8F4 62511E1D 09B746C9
E6490203 010001A3 6E306C30 0F060355 1D130101 FF040530 030101FF 30190603
551D1104 12301082 0E52332E 6D61786C 696E6B2E 636F6D30 1F060355 1D230418
30168014 26C697AF 48DE5B91 2DD7C588 A583525D E2288C1C 301D0603 551D0E04
16041426 C697AF48 DE5B912D D7C588A5 83525DE2 288C1C30 0D06092A 864886F7
0D010104 05000381 81009675 8545F9B6 66B2992D 0368A00E 0DDAF7DE EA6B82D0
71F16664 D7A05FFB 6968EF1F F4CEACC9 E0E8F531 21A63F31 4CD5A929 5D96CB47
870A6DDE F80BC0B4 009617A8 1174D26E F48E2420 FFE18C00 46B5430B 8B4EC536
E721649D 295E5BA1 013E99E4 D04DE71E 32E7914A 66651A1C 674529F2 AA26B5F3
E5D26D7A 08C6A512 2F1D
quit
username ajwaltz password 7 020507550A
!
!
!
!
!
!
interface FastEthernet0/0
ip address 172.23.23.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 172.23.24.3 255.255.255.0
encapsulation frame-relay
no fair-queue
frame-relay map ip 172.23.24.1 321
frame-relay map ip 172.23.24.2 321
no frame-relay inverse-arp
!
interface BRI0/0
no ip address
shutdown
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip default-gateway 172.23.23.1
ip classless
!
!
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 0 0
privilege level 15
password 7 000710030A4F
login local
transport input all
!
!
end

Comments

  • mikej412mikej412 Posts: 10,090Member
    What's your configuration for the router with the NM-4A/S acting as the frame relay switch?
    :mike: Cisco Certifications -- Collect the Entire Set!
  • BroadcastStormBroadcastStorm Posts: 496Member
    mikej412 wrote: »
    What's your configuration for the router with the NM-4A/S acting as the frame relay switch?

    None if you look at the 1st show run, this is where the nm-4a/s is plugged.

    On router 1

    interface Serial1/0
    no ip address
    !
    interface Serial1/1
    no ip address
    !
    interface Serial1/2
    no ip address
    shutdown
    !
    interface Serial1/3
    no ip address
    shutdown
  • blackninjablackninja Posts: 385Member
    Here's the config for my 2521 FrameSwitch to give you a head start:

    Current configuration:
    !
    version 11.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname FrameSwitch
    !
    enable secret 5 xxxxxxxxxxxxxxxxxxxxxxxxx
    !
    no ip domain-lookup
    frame-relay switching
    !
    !
    !
    interface Serial0
    description FRAME LINK TO R4 S0
    no ip address
    encapsulation frame-relay
    no ip mroute-cache
    no fair-queue
    clockrate 64000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 400 interface Serial1 104
    !
    interface Serial1
    description FRAME LINK TO R1 TO S0/0
    no ip address
    encapsulation frame-relay
    clockrate 64000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 102 interface Serial2 200
    frame-relay route 103 interface Serial3 300
    frame-relay route 104 interface Serial0 400
    !
    interface Serial2
    description FRAME LINK TO R2 - S0/1
    no ip address
    encapsulation frame-relay
    clockrate 64000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 200 interface Serial1 102
    !
    interface Serial3
    description FRAME LINK TO R3 - S0/0
    no ip address
    encapsulation frame-relay
    clockrate 64000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 300 interface Serial1 103
    !
    interface TokenRing0
    no ip address
    shutdown
    !
    interface BRI0
    no ip address
    shutdown
    !
    ip classless
    !
    !
    line con 0
    password xxxx
    logging synchronous
    login
    line aux 0
    line vty 0 4
    privilege level 15
    password xxxx
    logging synchronous
    login
    !
    end
    Currently studying:
    CCIE R&S - using INE workbooks & videos

    Currently reading:
    Everything. Twice ;)
  • tim100tim100 Posts: 162Member
    You cannot interconnect the 3 routers and have 1 act as a frame-relay switch at the same time if you want to simulate a frame-relay cloud with all the routers on the same subnet in a full mesh or hub and spoke configuration. If you want to interconnect the 3 routers then you would need a 4th router acting as a dedicated frame-relay switch.
  • BroadcastStormBroadcastStorm Posts: 496Member
    Let me just try to clearly understand this, since I had it working with this configured.

    On the Frame-Relay Switch a "Frame-Relay Route" has to be configured on the serial interfaces.

    On the non Frame-Relay Switch "Frame-Relay Map IP" has to be configured for static DLCI mapping.

    Frame Switch:

    interface Serial1/0
    no ip address
    encapsulation frame-relay
    clock rate 32000
    frame-relay intf-type dce
    frame-relay route 102 interface Serial1/1 201
    frame-relay route 103 interface Serial1/2 301
    !
    interface Serial1/1
    no ip address
    encapsulation frame-relay
    clock rate 32000
    frame-relay intf-type dce
    frame-relay route 201 interface Serial1/0 102
    frame-relay route 203 interface Serial1/2 302
    !
    interface Serial1/2
    no ip address
    encapsulation frame-relay
    clock rate 32000
    frame-relay intf-type dce
    frame-relay route 301 interface Serial1/0 103
    frame-relay route 302 interface Serial1/1 203
    !
    Hub
    interface Serial0/0
    ip address 172.23.24.2 255.255.255.0
    encapsulation frame-relay
    no fair-queue
    frame-relay map ip 172.23.24.3 102 broadcast
    frame-relay map ip 172.23.24.4 103 broadcast
    no frame-relay inverse-arp

    Spoke 1
    interface Serial0/0
    ip address 172.23.24.3 255.255.255.0
    encapsulation frame-relay
    no fair-queue
    frame-relay map ip 172.23.24.2 201 broadcast
    frame-relay map ip 172.23.24.4 301 broadcast
    no frame-relay inverse-arp

    Spoke 2
    interface Serial0/0
    ip address 172.23.24.4 255.255.255.0
    encapsulation frame-relay
    frame-relay map ip 172.23.24.2 301 broadcast
    frame-relay map ip 172.23.24.3 302 broadcast
    no frame-relay inverse-arp
  • blackninjablackninja Posts: 385Member
    Your seems config OK as long as the DLCI mapping is pointing to the right places

    or you can use:

    interface Serial0/0.200 point-to-point
    ip address 172.23.24.3 255.255.255.0
    frame-relay interface-dlci 102


    This is a must better way of setting up FR ( I think anyway) as RIP works fine on it.
    Using the physical interfaces you will run into split horizon problems.
    Currently studying:
    CCIE R&S - using INE workbooks & videos

    Currently reading:
    Everything. Twice ;)
  • kryollakryolla Posts: 785Member
    your config looke good I would like at the command reference to get more familair with what your doing.
    Studying for CCIE and drinking Home Brew
  • nevolvednevolved Posts: 131Member
    You might want to use the broadcast keyword on your map commands. Otherwise routing protocols cannot work.
  • miller811miller811 Posts: 897Member
    Although I no longer have my 3640 with the same card, here are the notes I had from the config I used.

    hope it helps


    conf t
    int s1/0
    no encap
    shut
    int s1/1
    no encap
    int s1/2
    no encap
    int 1/3
    no encap
    interface Serial1/1
    no ip address
    no ip directed-broadcast
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    clockrate 56000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 122 interface Serial1/2 221
    frame-relay route 123 interface Serial1/3 321
    interface Serial1/2
    no ip address
    no ip directed-broadcast
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    clockrate 56000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 221 interface Serial1/1 122
    interface Serial1/3
    no ip address
    no ip directed-broadcast
    encapsulation frame-relay
    logging event subif-link-status
    logging event dlci-status-change
    clockrate 56000
    no frame-relay inverse-arp
    frame-relay intf-type dce
    frame-relay route 321 interface Serial1/1 123


    R1 Hub
    conf t
    int s0/0
    no encap
    ip address 172.12.123.1 255.255.255.0
    no ip directed-broadcast
    encapsulation frame-relay
    no ip mroute-cache
    logging event subif-link-status
    logging event dlci-status-change
    frame-relay map ip 172.12.123.2 122 broadcast
    frame-relay map ip 172.12.123.3 123 broadcast

    R2 spoke
    ip address 172.12.123.2 255.255.255.0
    no ip directed-broadcast
    encapsulation frame-relay
    no ip mroute-cache
    logging event subif-link-status
    logging event dlci-status-change
    frame-relay map ip 172.12.123.1 221 broadcast

    R3 spoke
    ip address 172.12.123.3 255.255.255.0
    no ip directed-broadcast
    encapsulation frame-relay
    no ip mroute-cache
    logging event subif-link-status
    logging event dlci-status-change
    frame-relay map ip 172.12.123.1 321 broadcast
    I don't claim to be an expert, but I sure would like to become one someday.

    Quest for 11K pages read in 2011
    Page Count total to date - 1283
  • BroadcastStormBroadcastStorm Posts: 496Member
    Let me just try to clearly understand this, since I had it working with this configured.

    On the Frame-Relay Switch a "Frame-Relay Route" has to be configured on the serial interfaces.

    On the non Frame-Relay Switch "Frame-Relay Map IP" has to be configured for static DLCI mapping.

    Frame Switch:

    interface Serial1/0
    no ip address
    encapsulation frame-relay
    clock rate 32000
    frame-relay intf-type dce
    frame-relay route 102 interface Serial1/1 201
    frame-relay route 103 interface Serial1/2 301
    !
    interface Serial1/1
    no ip address
    encapsulation frame-relay
    clock rate 32000
    frame-relay intf-type dce
    frame-relay route 201 interface Serial1/0 102
    frame-relay route 203 interface Serial1/2 302
    !
    interface Serial1/2
    no ip address
    encapsulation frame-relay
    clock rate 32000
    frame-relay intf-type dce
    frame-relay route 301 interface Serial1/0 103
    frame-relay route 302 interface Serial1/1 203
    !
    Hub
    interface Serial0/0
    ip address 172.23.24.2 255.255.255.0
    encapsulation frame-relay
    no fair-queue
    frame-relay map ip 172.23.24.3 102 broadcast
    frame-relay map ip 172.23.24.4 103 broadcast
    no frame-relay inverse-arp

    Spoke 1
    interface Serial0/0
    ip address 172.23.24.3 255.255.255.0
    encapsulation frame-relay
    no fair-queue
    frame-relay map ip 172.23.24.2 201 broadcast
    frame-relay map ip 172.23.24.4 301 broadcast
    no frame-relay inverse-arp

    Spoke 2
    interface Serial0/0
    ip address 172.23.24.4 255.255.255.0
    encapsulation frame-relay
    frame-relay map ip 172.23.24.2 301 broadcast
    frame-relay map ip 172.23.24.3 302 broadcast
    no frame-relay inverse-arp


    Hey guys I am following Chris Bryant's video and I was at the RIP part testing if other RIP routers is receiving network broadcast, but it doesn't look like it's working, can someone please point me to the correct direction, my Frame Relay configuration is showned above.
  • BroadcastStormBroadcastStorm Posts: 496Member
    kryolla wrote: »
    your config looke good I would like at the command reference to get more familair with what your doing.


    Where am I missing this broadcast command is it on the frame-relay switch the route won't accept a broadcast command, please advise thanks.
  • blackninjablackninja Posts: 385Member
    Hey guys I am following Chris Bryant's video and I was at the RIP part testing if other RIP routers is receiving network broadcast, but it doesn't look like it's working, can someone please point me to the correct direction, my Frame Relay configuration is showned above.

    Your config looks fine: are you able to ping through your FR network?

    If so have you turned Split Horizon off on R1? If not the RIP updates will not be to go back out of the serial to the other spoke.
    Currently studying:
    CCIE R&S - using INE workbooks & videos

    Currently reading:
    Everything. Twice ;)
  • blackninjablackninja Posts: 385Member
    Where am I missing this broadcast command is it on the frame-relay switch the route won't accept a broadcast command, please advise thanks.

    You are not missing any broadcast statments ( only really need them on R1 anyway), I think kryolla just meant to check with the Command Guide as you go so you understand what you are typing.
    Currently studying:
    CCIE R&S - using INE workbooks & videos

    Currently reading:
    Everything. Twice ;)
  • BroadcastStormBroadcastStorm Posts: 496Member
    blackninja wrote: »
    Your config looks fine: are you able to ping through your FR network?

    If so have you turned Split Horizon off on R1? If not the RIP updates will not be to go back out of the serial to the other spoke.

    Everything is pingable, I am still new to split-horizon, but regardless if RIP is set to Router 2 or 3 Router 1 should receive something from one of the two Router 2/3 which is not able to.
  • blackninjablackninja Posts: 385Member
    Everything is pingable, I am still new to split-horizon, but regardless if RIP is set to Router 2 or 3 Router 1 should receive something from one of the two Router 2/3 which is not able to.

    As long as your network statments are corect, then turn split horizon off and wait a mintue. All should be OK.

    P.S. this is a bad way of using FR using RIP, normaly would use sub-interfaces to avoid split horizon issues.
    Currently studying:
    CCIE R&S - using INE workbooks & videos

    Currently reading:
    Everything. Twice ;)
  • BroadcastStormBroadcastStorm Posts: 496Member
    R1 - Frame-Relay Switch

    R4#ping 172.23.24.255
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.23.24.255, timeout is 2 seconds:
    Reply to request 0 from 172.23.24.3, 181 ms
    Reply to request 0 from 172.23.24.2, 209 ms
    Reply to request 1 from 172.23.24.3, 205 ms
    Reply to request 1 from 172.23.24.2, 233 ms
    Reply to request 2 from 172.23.24.3, 128 ms
    Reply to request 2 from 172.23.24.2, 156 ms
    Reply to request 3 from 172.23.24.3, 148 ms
    Reply to request 3 from 172.23.24.2, 176 ms
    Reply to request 4 from 172.23.24.3, 168 ms
    Reply to request 4 from 172.23.24.2, 196 ms
    R4#

    R3#ping 172.23.24.255
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.23.24.255, timeout is 2 seconds:
    Reply to request 0 from 172.23.24.4, 172 ms
    Reply to request 0 from 172.23.24.2, 200 ms
    Reply to request 1 from 172.23.24.4, 208 ms
    Reply to request 1 from 172.23.24.2, 236 ms
    Reply to request 2 from 172.23.24.4, 129 ms
    Reply to request 2 from 172.23.24.2, 157 ms
    Reply to request 3 from 172.23.24.4, 128 ms
    Reply to request 3 from 172.23.24.2, 156 ms
    Reply to request 4 from 172.23.24.4, 160 ms
    Reply to request 4 from 172.23.24.2, 188 ms
  • BroadcastStormBroadcastStorm Posts: 496Member
    It's working now, the only change I made was disable the inverse-arp on the frame-relay switch.

    R2#show ip route rip
    1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    R 1.0.0.0/8 is possibly down,
    routing via 172.23.24.4, Serial0/0
    R 2.0.0.0/8 [120/1] via 172.23.24.3, 00:00:04, Serial0/0
    [120/1] via 172.23.23.3, 00:00:25, FastEthernet0/0
    R 3.0.0.0/8 [120/1] via 172.23.24.4, 00:00:16, Serial0/0
    [120/1] via 172.23.23.4, 00:00:16, FastEthernet0/0

    R3#
    router rip
    network 2.0.0.0
    network 172.23.0.0
    no auto-summary
    R4#
    router rip
    network 3.0.0.0
    network 172.23.0.0
    no auto-summary

    It's converged :P if that's the correct term.

    It looks like the only time my RIP network gets broadcast is if I configure a loopback interface (I gotta still read more about loopback)
  • BroadcastStormBroadcastStorm Posts: 496Member
    Weird dynamic behaviour on my frame relay I turned off inverse-arp but still gets the following mapping on the Hub.

    Serial0/0 (up): ip 0.0.0.0 dlci 103(0x67,0x1870)
    broadcast,
    CISCO, status defined, active
    Serial0/0 (up): ip 0.0.0.0 dlci 102(0x66,0x1860)
    broadcast,
    CISCO, status defined, active
    Serial0/0 (up): ip 172.23.24.2 dlci 102(0x66,0x1860), static,
    broadcast,
    CISCO, status defined, active
    Serial0/0 (up): ip 172.23.24.3 dlci 103(0x67,0x1870), static,
    broadcast,
    CISCO, status defined, active
  • BroadcastStormBroadcastStorm Posts: 496Member
    Am I loosing my mind here I thought I have a partial mesh Frame Relay.

    But why is router 3 (spoke) getting RIP loopback broadcast from router 2 (spoke), split-horizon is not disabled on router 1 (hub)

    R3#show ip route rip
    R 2.0.0.0/8 [120/1] via 172.23.24.2, 00:00:12, Serial0/0
    [120/1] via 172.23.23.2, 00:00:20, FastEthernet0/0

    how am I going to play with split-horizon, multi point/point to point subinterfaces now.
  • blackninjablackninja Posts: 385Member
    Weird dynamic behaviour on my frame relay I turned off inverse-arp but still gets the following mapping on the Hub.

    Serial0/0 (up): ip 0.0.0.0 dlci 103(0x67,0x1870)
    broadcast,
    CISCO, status defined, active
    Serial0/0 (up): ip 0.0.0.0 dlci 102(0x66,0x1860)
    broadcast,
    CISCO, status defined, active
    Serial0/0 (up): ip 172.23.24.2 dlci 102(0x66,0x1860), static,
    broadcast,
    CISCO, status defined, active
    Serial0/0 (up): ip 172.23.24.3 dlci 103(0x67,0x1870), static,
    broadcast,
    CISCO, status defined, active

    I have found the only way to get rid of those 0.0.0.0 from inverse arp is a re-load.
    Currently studying:
    CCIE R&S - using INE workbooks & videos

    Currently reading:
    Everything. Twice ;)
  • mikej412mikej412 Posts: 10,090Member
    I turned off inverse-arp but still gets the following mapping on the Hub.

    Serial0/0 (up): ip 0.0.0.0 dlci 103(0x67,0x1870)
    broadcast,
    CISCO, status defined, active
    Serial0/0 (up): ip 0.0.0.0 dlci 102(0x66,0x1860)
    broadcast,
    If you shut down the ports before you configure frame relay, you can avoid those (and the need to reload the router to get rid of those 0.0.0.0 entries).
    :mike: Cisco Certifications -- Collect the Entire Set!
  • kryollakryolla Posts: 785Member
    What does split horizon do? It prevents a routing update from being sent back out the interface in which it arrived at, so since you have a full mesh just like an ethernet segment split horizon should be enabled. So you need a hub and spoke to play with split horizon and no point to point sub-interfaces just set it up on the main interface or multipoint sub-interface. I dont think you understand the FR map statement. For ethernet you need to send a packet to an IP address that is local to your segment but it cant encapsulate it in an ethernet frame without a mac address. So the router will arp for the mac and now it can send a packet . For FR you have layer 2 address the DLCI via the LMI from FR switch but no IP address so inverse arp will resolve the DLCI to an IP address but ony for directly connected neighbor due to it being non-broadcast the hub cant forward broadcast between spokes. So now you know how to send traffic from spoke to hub but not spoke to spoke so you need a map statement which is a static statement saying to reach this OTHER IP address I have to use the same DLCI going to the hub and the hub will send it to the other spoke. Ping the hub and then the spoke and you will notice spoke to spoke will be twice as long to get the packet. Now you know that for spoke to spoke it comes into the hub and leaves out the same interface thus you need to disable split horizon manually or auto.

    FR map ip 1.1.11 101 broadcast

    Your FR switch config is a full mesh the route statement says I am receiving this dlci route it out this interface and this dlci so you have 2 route statement to reach 2 other routers, if you only have 3 routers then this is a full mesh, all 3 routers can talk to each other directly. Just because you have full mesh fr switch config you can modify the routers to only use certain DLCI and make them partial mesh or hub and spoke by map statements. If you were using inverse arp then it would be full mesh as you have the FR Switch setup as full mesh.

    frame-relay route 201 interface Serial1/0 102
    frame-relay route 203 interface Serial1/2 302

    Hope this helps

    yeah the 0.0.0.0 is part of the autoinstall process when the router does not have a start-up config, just save your config and reload like everyone has suggested.

    EDIT: Look to see if split horizon is enabled for the main interface or sub-interface by default
    Studying for CCIE and drinking Home Brew
  • BroadcastStormBroadcastStorm Posts: 496Member
    kryolla wrote: »
    What does split horizon do? It prevents a routing update from being sent back out the interface in which it arrived at, so since you have a full mesh just like an ethernet segment split horizon is enabled. So you need a hub and spoke to play with split horizon and no point to point sub-interfaces just set it up on the main interface or multipoint sub-interface. I dont think you understand the FR map statement. For ethernet you need to send a packet to an IP address that is local to your segment but it cant encapsulate it in an ethernet frame without a mac address. So the router will arp for the mac and now it can send a packet . For FR you have layer 2 address the DLCI via the LMI from FR switch but no IP address so inverse arp will resolve the DLCI to an IP address but ony for directly connected neighbor due to it being non-broadcast the hub cant forward broadcast between spokes. So now you know how to send traffic from spoke to hub but not spoke to spoke so you need a map statement which is a static statement saying to reach this OTHER IP address I have to use the same DLCI going to the hub and the hub will send it to the other spoke. Ping the hub and then the spoke and you will notice spoke to spoke will be twice as long to get the packet. Now you know that for spoke to spoke it comes into the hub and leaves out the same interface thus you need to disable split horizon manually or auto.

    FR map ip 1.1.11 101 broadcast

    Your FR switch config is a full mesh the route statement says I am receiving this dlci route it out this interface and this dlci so you have 2 route statement to reach 2 other routers, if you only have 3 routers then this is a full mesh, all 3 routers can talk to each other directly. Just because you have full mesh fr switch config you can modify the routers to only use certain DLCI and make them partial mesh or hub and spoke by map statements. If you were using inverse arp then it would be full mesh as you have the FR Switch setup as full mesh.

    frame-relay route 201 interface Serial1/0 102
    frame-relay route 203 interface Serial1/2 302

    Hope this helps

    yeah the 0.0.0.0 is part of the autoinstall process when the router does not have a start-up config, just save your config and reload like everyone has suggested.

    Thanks for taking time to explain this, I do indeed have a full-mesh frame-relay configured on the switch and the spokes, but anyway all the video I watched from Chris and Jeremy did not showed the frame-relay route configuration on the frame-relay switch itself.

    I am going to move forward to my lab I cannot seem to get frame-relay route and map on the switch/hub/spoke/spoke after spending reasonable amount of time, anyway my only goal was to simulate split horizon not sending route broadcast out the same interface it learned something on a hub/spoke topology, the concept and how to enable/disable it is simple, so I will move forward, and re-visit later.

    I am continuing with point-to-point and multi-point, this gives me a chance to delete the map statement and start fresh with the sub-interfaces, and yes I changed my frame-relay route/map statement but unable to get connectivity from the two spoke.

    I guess to say the very least is I have a pretty good configuration of a full-mesh topology :P my question is why all the video I watched did not show the part where they configure the Frame-Relay Switch serial interface frame-relay route, they just configure the routers and bam everything works fine with hubs and spokes, do I have a different device than what they have? I have an nm-4a/s running on a 2611 router which is acting as my frame-relay switch.

    Thanks :)
  • kryollakryolla Posts: 785Member
    your FR switch config looks good as a full mesh so dont change it. What issue are you having. Also are you doing your sh commands

    sh frame map
    sh frame pvc

    Take it 1 step at a time
    1)put an ip address on the interface and encap frame relay no shut
    2) sh frame lmi and see if you are exchanging lmi with the fr switch
    3) sh frame pvc and look for pvc status = active
    4) let inverse arp do its job
    5) sh frame map and look for (up) and active
    6) test reach ability to directly connected neighbors
    7) put map statements on spoke routers to reach other spoke routers, don't touch the hub router
    8 test reach ability spoke to spoke

    I modified your config so this should work for hub and spoke

    Hub
    interface Serial0/0
    ip address 172.23.24.2 255.255.255.0
    encapsulation frame-relay
    no fair-queue

    Spoke 1
    interface Serial0/0
    ip address 172.23.24.3 255.255.255.0
    encapsulation frame-relay
    no fair-queue
    frame-relay map ip 172.23.24.4 201
    no frame-relay inverse-arp ip 301

    Spoke 2
    interface Serial0/0
    ip address 172.23.24.4 255.255.255.0
    encapsulation frame-relay
    frame-relay map ip 172.23.24.3 301
    no frame-relay inverse-arp ip 302

    EDIT: Once you have you FR switch set up you dont have to change anything unless you are adding more circuits. I hardly touch my FR switch now most of the config changes are on the DTE Device depending on your config i.e main interface or sub-interface
    Studying for CCIE and drinking Home Brew
  • BroadcastStormBroadcastStorm Posts: 496Member
    Thank you sir! I'll test this tonite :) bowing.gif
  • BroadcastStormBroadcastStorm Posts: 496Member
    It's working thanks so much Kryoll, ping from hub and spoke has different time response which is a good indication, you are indeed correct I was better off leaving the FR switch route statement configuration and just messing with spoke map statements configuration. I should be good now knowing my map statement with partial/full/hub & spoke.

    R2#show run int serial 0/0
    Building configuration...
    Current configuration : 249 bytes
    !
    interface Serial0/0
    description Connected to FRSW-Serial 1/1
    ip address 172.23.24.2 255.255.255.0
    encapsulation frame-relay
    no fair-queue
    frame-relay map ip 172.23.24.1 201
    frame-relay map ip 172.23.24.3 201
    no frame-relay inverse-arp
    end
    R2#ping 172.23.24.1
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.23.24.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 112/113/117 ms
    R2#ping 172.23.24.3
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.23.24.3, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 224/224/225 ms

    R3#show run interface serial 0/0
    Building configuration...
    Current configuration : 207 bytes
    !
    interface Serial0/0
    ip address 172.23.24.3 255.255.255.0
    encapsulation frame-relay
    no fair-queue
    frame-relay map ip 172.23.24.1 301
    frame-relay map ip 172.23.24.2 301
    no frame-relay inverse-arp
    end
    R3#ping 172.23.24.1
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.23.24.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 112/112/113 ms
    R3#ping 172.23.24.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.23.24.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 224/225/229 ms


    R2#show frame map
    Serial0/0 (up): ip 172.23.24.1 dlci 201(0xC9,0x3090), static,
    CISCO, status defined, active
    Serial0/0 (up): ip 172.23.24.3 dlci 201(0xC9,0x3090), static,
    CISCO, status defined, active

    R3#show frame-relay map
    Serial0/0 (up): ip 172.23.24.1 dlci 301(0x12D,0x48D0), static,
    CISCO, status defined, active
    Serial0/0 (up): ip 172.23.24.2 dlci 301(0x12D,0x48D0), static,
    CISCO, status defined, active

    It's still full mesh on the cloud FR switch

    FR-SW#show frame-relay route
    Input Intf Input Dlci Output Intf Output Dlci Status
    Serial1/0 102 Serial1/1 201 active
    Serial1/0 103 Serial1/2 301 active
    Serial1/1 201 Serial1/0 102 active
    Serial1/1 203 Serial1/0 103 active
    Serial1/2 301 Serial1/0 103 active
    Serial1/2 302 Serial1/1 203 active
  • kryollakryolla Posts: 785Member
    congrats but you are missing a key word on your map statements if you want this type of traffic to go through. For some reason frame relay is my favorite layer 2 protocol
    Studying for CCIE and drinking Home Brew
  • BroadcastStormBroadcastStorm Posts: 496Member
    Ahhh isn't there always something I forgot to put my name on the map lol, it was screaming at me I have the dumbz :P
Sign In or Register to comment.