Options

No connection to PC after setting up native vlan

wroblo5wroblo5 Registered Users Posts: 1 ■□□□□□□□□□
Hi,
I am new to networking and It may be simple solution for my problem. Although I read a lot of articles about native Vlan I still struggle to understand my problem for quiet a long time. I made this simple scenario in Packet Tracer. I have 2 PC-s connected to one switch, and switch connected over trunk port to router. PC1 is connected to Vlan10, PC2 is not associated with any Vlan. At the beginning both of ports are accossiated with default native Vlan 1 - connection between both PCs and router is established. My problem starts when I want to change native Vlan1 to Vlan 20. After changing native vlan, PC1 is still successfully send packets to router (tagged packets) but PC2 don't. My question is: does PC2 should not use native vlan to send untagged/native packets to router ? Did I miss any config ?


My config:


Router:
Building configuration...


Current configuration : 831 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524PDIT
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet0/0.20
encapsulation dot1Q 20 native
ip address 192.168.20.1 255.255.255.0
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Vlan1
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end


Switch


Building configuration...


Current configuration : 1185 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
!
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/2
!
interface FastEthernet0/3
switchport trunk native vlan 20
switchport mode trunk
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
ip default-gateway 192.168.1.1
!
!
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
!
end


VLAN Name Status Ports
----


1 default active Fa0/2, Fa0/4, Fa0/5, Fa0/6
Fa0/7, Fa0/8, Fa0/9, Fa0/10
Fa0/11, Fa0/12, Fa0/13, Fa0/14
Fa0/15, Fa0/16, Fa0/17, Fa0/18
Fa0/19, Fa0/20, Fa0/21, Fa0/22
Fa0/23, Fa0/24, Gig0/1, Gig0/2
10 VLAN0010 active Fa0/1
20 native active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active


VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
----





----


1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0


Remote SPAN VLANs


Primary Secondary Type Ports









Thank you for your help


Michal

Comments

  • Options
    UsualSuspect7UsualSuspect7 Member Posts: 97 ■■■□□□□□□□
    I think the Native Vlan is meant for untagged traffic, like Cisco Discovery Protocol. I'm not sure myself, but I find it extremely interesting. I think Native Vlan doesn't require to be encapsulated.
    CISSP, CCENT, CCNA R/S, CCNA Cyber OPs, Security+, CySA+, PenTest+, Network+, Microsoft AZ-900, InsightVM CA
  • Options
    QueueQueue Member Posts: 174 ■■■□□□□□□□
    !
    interface GigabitEthernet0/0.20
    encapsulation dot1Q 20 native
    ip address 192.168.20.1 255.255.255.0
    shutdown
    !
    Your interface is shutdown.
  • Options
    CryptoQueCryptoQue Member Posts: 204 ■■■□□□□□□□
    What Queue said. Run the "Show ip interface brief" command to verify the up/down status of your interface VLANs. This will is an easy way to verify this type of error versus spotting it in your "show running-configuration" output.
    Queue wrote: »
    !
    interface GigabitEthernet0/0.20
    encapsulation dot1Q 20 native
    ip address 192.168.20.1 255.255.255.0
    shutdown
    !
    Your interface is shutdown.
Sign In or Register to comment.