Options

Dot1q trunking between Router(VG) and Switch

moreland11moreland11 Member Posts: 24 ■□□□□□□□□□
I was looking for the correct way to configure this setup with link redundancy, dynamic routing, and end to end Qos. I was hoping someone could help me out with tagging/trunk the router interface/sub-interface going to the switch.

Router#
!
int Loopback 0
ip address 10.0.0.10 255.255.255.255
H323-Gateway voip Bind srcaddr 10.0.0.10
!
int Gi0/1
ip address 10.0.1.8 255.255.255.0
!
int Gi0/2
ip address 10.0.2.8 255.255.255.0


Gi0/1 goes to switch A Gi0/1
Gi0/2 goes to switch B Gi0/1

I would like to use dot1q trunking to set the cos value for Qos going out to each switch but I'm not exactly sure how.

Is this correct?
!
interface GigabitEthernet0/2
ip address 10.0.2.8 255.255.255.0
duplex auto
speed auto
vlan-id dot1q 10
exit-vlan-config
!

Or is one sub interface the correct chose?
!
interface GigabitEthernet0/2
no ip address
duplex auto
speed auto
end
!
interface GigabitEthernet0/2.10
encapsulation dot1Q 10
ip address 10.0.2.8 255.255.255.0
end


I have multiple Voice Gateways. Each VG has an interface that advertises the looback network via EIGRP back to our cor switch. The core is also trunked to each switch.


Any ideas thoughts? I haven't posted in quite some time and I feel lost without a whiteboard :/

Comments

  • Options
    Dieg0MDieg0M Member Posts: 861
    Use the sub-interfaces. There will only be cos marking field when there is a dot1q or ISL frame:
    interface GigabitEthernet0/2.10
    encapsulation dot1Q 10
    ip address 10.0.2.8 255.255.255.0
    end

    And on your switch, trunk the port connecting to your dot1q: On SwA
    int Gi0/1
    swi mode tru
    swi encap dot1q
    swi trunk allowed 10
    no shut
    exit
    Trust the interfaces on your host/phone ports as usual.
    Follow my CCDE journey at www.routingnull0.com
  • Options
    moreland11moreland11 Member Posts: 24 ■□□□□□□□□□
    Dieg0M wrote: »
    Use the sub-interfaces. There will only be cos marking field when there is a dot1q or ISL frame:
    interface GigabitEthernet0/2.10
    encapsulation dot1Q 10
    ip address 10.0.2.8 255.255.255.0
    end

    And on your switch, trunk the port connecting to your dot1q: On SwA
    int Gi0/1
    swi mode tru
    swi encap dot1q
    swi trunk allowed 10
    no shut
    exit
    Trust the interfaces on your host/phone ports as usual.

    Awesome. Thank! That's exactly how I configured it.
Sign In or Register to comment.