Need help solving this routing issue (labbing for ccent)

jahazieljahaziel Member Posts: 175 ■■■□□□□□□□
Hey Guys, Decided to study for the ccent by creating my own network. Unfortunately I got stuck with pinging a different subnet with a switch.

Basically my HS-SW can ping 10.121.128.1 but can't ping the 10.0.20.0 network side
Here are my running config for all my devices
hostname HS-SW!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/13
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 128
switchport mode access
!
interface FastEthernet0/24
switchport access vlan 128
switchport mode access
!
interface GigabitEthernet1/1
switchport access vlan 128
switchport mode access
!
interface GigabitEthernet1/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan128
ip address 10.121.128.2 255.255.255.0
!
!
line con 0
!
line vty 0 4
login
line vty 5 15
login
!
!
end

hostname CIHS-CORE
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet2/0
ip address 10.0.20.1 255.255.255.0
!
interface GigabitEthernet9/0
ip address 10.121.128.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.121.128.0 0.0.0.255 area 0
network 10.0.20.0 0.0.0.255 area 0
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

hostname Mulvey-Core
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet1/0
ip address 10.0.20.2 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 10.0.20.0 0.0.0.255 area 0
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Comments

  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Since HS-SW is not running ospf, it doesn't have a route to 10.0.20.0, it can ping 10.121.128.1 because it knows that network 10.121.128.0/24 is connected to the local interface vlan 128. If you do "show ip route" will will see there is no route to 10.0.20.0 so how is the switch supposed to know where to send the ping?
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • jahazieljahaziel Member Posts: 175 ■■■□□□□□□□
    sorry been trying to upload the diagram. HS-SW is a switch. Layer 2 Switch. (Future router on a stick Lab)
  • EdTheLadEdTheLad Member Posts: 2,111 ■■■■□□□□□□
    Ask yourself what is the difference between a router and a switch. What can a router do that a switch cant do?
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • jahazieljahaziel Member Posts: 175 ■■■□□□□□□□
    yeah I understand what you mean. I was actually able to connect a host and ping all the way through.
  • GngoghGngogh Member Posts: 165 ■■■□□□□□□□
    Hi, correct me if im wrong, your switch can only ping 10.121.128.1 because of interface Vlan128 which is 10.121.128.2, your switch doesnt know where to send packets with other network address, because there are no route's in the switch, i would config a default gateway on the switch:

    Switch(config)#ip default-gateway 10.121.128.1

    I think after you do this, you should be able to ping other address's from the switch, as this address is part of the ospf proccess on the router
  • jahazieljahaziel Member Posts: 175 ■■■□□□□□□□
    Gngogh wrote: »
    Hi, correct me if im wrong, your switch can only ping 10.121.128.1 because of interface Vlan128 which is 10.121.128.2, your switch doesnt know where to send packets with other network address, because there are no route's in the switch, i would config a default gateway on the switch:

    Switch(config)#ip default-gateway 10.121.128.1
    Thank you. Finally was able to ping using the switch. Never understood why till you told me. Thank you
    I think after you do this, you should be able to ping other address's from the switch
    Thank you. Finally was able to ping using the switch. Never understood why till you told me. Thank you
  • CoolAsAFanCoolAsAFan Member Posts: 239
    jahaziel wrote: »
    sorry been trying to upload the diagram. HS-SW is a switch. Layer 2 Switch. (Future router on a stick Lab)

    I thought you needed a Layer 3 switch for ros?
    IvyTech - AS CINS (Completed: May, 2013)
    WGU Indiana - BS IT Security
    (Started: August 1st, 2013)

    Transferred: AGC1 CDP1 BVC1 CLC1 CVV1 DHV1 DJV1 GAC1 CIC1 CDC1 UBT1 IWC1 IWT1 TCP1 TJP1 TJC1 EBV1 WFV1 EUP1 EUC1 CJC1 UBC1 TBP1
    Completed: CUV1 BOV1 DRV1 DSV1 CTV1 CJV1 COV1 CQV1 CNV1 TPV1 MGC1 TXC1 TXP1 BNC1 TYP1 TYC1
    Required:
    SBT1 RGT1 RIT1
  • jahazieljahaziel Member Posts: 175 ■■■□□□□□□□
    CoolAsAFan wrote: »
    I thought you needed a Layer 3 switch for ros?

    I might be wrong but router on a stick is used to allow multiple vlans on a sing interface because it doesn't know how to handle them. With layer 3 switching it can handle routes and able to forward the vlans properly
  • GngoghGngogh Member Posts: 165 ■■■□□□□□□□
    you can use a router with subinterfaces if there's no layer 3 switch.
  • GngoghGngogh Member Posts: 165 ■■■□□□□□□□
    jahaziel tell me why then, what is the default-gateway doing???
  • jahazieljahaziel Member Posts: 175 ■■■□□□□□□□
    Gives it the default route to send its packets.
  • GngoghGngogh Member Posts: 165 ■■■□□□□□□□
    that's it... im glad you understand it.
Sign In or Register to comment.