Options

Need some routing help

Commguy23Commguy23 Member Posts: 55 ■■■□□□□□□□
I know this is a cert forum, but I figured it would be the best place to ask for some help!

I have a fairly complex Cisco network, I am pretty rusty on my Cisco routing skills and need some help setting up a route. I have Site one router with interface 10.161.1.254, site 2 on 10.161.1.11, and site 3 (which is managed by another company) at 10.161.56.250. I need to get to an IP of 10.1.1.63 which is routed through the 10.161.56.0 router. On site 2, I can ping 10.1.1.63. The routing tables are set up as follows.


router ospf 33
router-id 10.161.1.11
log-adjacency-changes
area 1 authentication message-digest
passive-interface default
network 10.161.1.0 0.0.0.255 area 1
network 10.161.16.0 0.0.0.255 area 1
network 10.161.48.0 0.0.0.255 area 1
network 10.161.56.0 0.0.0.255 area 1
network 10.161.58.0 0.0.0.255 area 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.161.56.250
ip route 10.0.0.0 255.0.0.0 10.161.1.254
ip route 10.1.1.63 255.255.255.255 10.161.56.250
ip route 10.13.37.0 255.255.255.0 10.161.56.250
ip http server
ip http authentication local
no ip http secure-server
!


I do not believe the OSPF plays any role, as there are static routes set up. You can see there is a static route to 10.1.1.63 via 10.161.56.250. From this site, site 2, I can ping 10.161.56.250 and 10.1.1.63.


Site 1 I have added a static route to the 10.161.56.0 network via Site 2 interface - 10.161.1.11. After adding this route, I am able to ping 10.161.56.250. I then added a static route for 10.1.1.63 via 10.161.56.250, just as it is configured in Site 2 routing table. However, I still can not ping 10.1.1.63 from Site 1. Site 1 routing table is as follows:


router ospf 33
log-adjacency-changes
auto-cost reference-bandwidth 10000
area 1 authentication message-digest
passive-interface default
network 10.161.0.0 0.0.255.255 area 1
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.161.1.11
ip route 10.0.0.0 255.0.0.0 10.244.244.1
ip route 10.1.1.63 255.255.255.255 10.161.56.250
ip route 10.161.48.0 255.255.255.0 10.161.1.11
ip route 10.161.49.0 255.255.255.0 10.161.1.12
ip route 10.161.50.0 255.255.255.0 10.161.1.15
ip route 10.161.56.0 255.255.255.0 10.161.1.11
ip route 10.161.59.0 255.255.255.0 10.161.1.12
ip route 10.161.60.0 255.255.255.0 10.161.1.15
ip http server
ip http authentication local
ip http secure-server
!


What am I missing here? Thanks in advance!

Comments

  • Options
    RouteMyPacketRouteMyPacket Member Posts: 1,104
    Commguy23 wrote: »
    I know this is a cert forum, but I figured it would be the best place to ask for some help!

    I have a fairly complex Cisco network, I am pretty rusty on my Cisco routing skills and need some help setting up a route. I have Site one router with interface 10.161.1.254, site 2 on 10.161.1.11, and site 3 (which is managed by another company) at 10.161.56.250. I need to get to an IP of 10.1.1.63 which is routed through the 10.161.56.0 router. On site 2, I can ping 10.1.1.63. The routing tables are set up as follows.


    router ospf 33
    router-id 10.161.1.11
    log-adjacency-changes
    area 1 authentication message-digest
    passive-interface default
    network 10.161.1.0 0.0.0.255 area 1
    network 10.161.16.0 0.0.0.255 area 1
    network 10.161.48.0 0.0.0.255 area 1
    network 10.161.56.0 0.0.0.255 area 1
    network 10.161.58.0 0.0.0.255 area 1
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.161.56.250
    ip route 10.0.0.0 255.0.0.0 10.161.1.254
    ip route 10.1.1.63 255.255.255.255 10.161.56.250
    ip route 10.13.37.0 255.255.255.0 10.161.56.250
    ip http server
    ip http authentication local
    no ip http secure-server
    !


    I do not believe the OSPF plays any role, as there are static routes set up. You can see there is a static route to 10.1.1.63 via 10.161.56.250. From this site, site 2, I can ping 10.161.56.250 and 10.1.1.63.


    Site 1 I have added a static route to the 10.161.56.0 network via Site 2 interface - 10.161.1.11. After adding this route, I am able to ping 10.161.56.250. I then added a static route for 10.1.1.63 via 10.161.56.250, just as it is configured in Site 2 routing table. However, I still can not ping 10.1.1.63 from Site 1. Site 1 routing table is as follows:


    router ospf 33
    log-adjacency-changes
    auto-cost reference-bandwidth 10000
    area 1 authentication message-digest
    passive-interface default
    network 10.161.0.0 0.0.255.255 area 1
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.161.1.11
    ip route 10.0.0.0 255.0.0.0 10.244.244.1
    ip route 10.1.1.63 255.255.255.255 10.161.56.250
    ip route 10.161.48.0 255.255.255.0 10.161.1.11
    ip route 10.161.49.0 255.255.255.0 10.161.1.12
    ip route 10.161.50.0 255.255.255.0 10.161.1.15
    ip route 10.161.56.0 255.255.255.0 10.161.1.11
    ip route 10.161.59.0 255.255.255.0 10.161.1.12
    ip route 10.161.60.0 255.255.255.0 10.161.1.15
    ip http server
    ip http authentication local
    ip http secure-server
    !


    What am I missing here? Thanks in advance!

    To be honest with you, you do not lay this out in an easily readable manner. A network diagram would come in handy or at the very least notate what we are looking at. Also, you mention routing tables but I don't see any routing table posted, you show the OSPF process sure but besides ping, what else should you try? traceroute perhaps? Is the route in the table? Does 10.1.1.63 know how to reach the network you sit on? It would need a route back

    Follow the packet...where does it stop?
    Modularity and Design Simplicity:

    Think of the 2:00 a.m. test—if you were awakened in the
    middle of the night because of a network problem and had to figure out the
    traffic flows in your network while you were half asleep, could you do it?
  • Options
    Commguy23Commguy23 Member Posts: 55 ■■■□□□□□□□
    I apologize, I forgot to include the routing tables in my post :/ it was late and my brain was shot. This did eventually work though and it's all set now, thank you!
Sign In or Register to comment.