Issues upgrading vmware-tools on a 32-bit machine with 64-bit vSphere/vCenter

JockVSJockJockVSJock Member Posts: 1,118
The previous sys admin for some reason has a mix of 32-bit and 64-bit RedHat Linux machines in VMWare vSphere. I'm not sure the reason why behind this.

I want to upgrade the VMWare-Tools in our dev environments before moving on to the Prod env. I'm having issues with one of the 32-bit machines in the upgrade process. I've right clicked on the guest > Install VMWare Tools > Mounted the CDRom > Copied .tgz file to /tmp >

Before doing this I ran under /usr/bin/

And then I go thru the script from and this is where I run into the issue.

Setup is unable to find the "ldd" program on your machine. Please make sure it is installed. Do you want to specify the location of this program by hand?

I point this to /usr/bin/ldd

and then I'm getting

The answer "/user/bin/ldd" is invalid. It must be the complete name of a binary file

I'm at a loss on what to do or where to go next here. I'm guessing there is a 32-bit/64-bit conflict here?
***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

"Its easier to deceive the masses then to convince the masses that they have been deceived."


Sign In or Register to comment.