Huge headaches with CCP....

hikerguyhikerguy Member Posts: 8 ■□□□□□□□□□
I'm having all kinds of problems making this $#@* CCP software work. Here's what I have:

Windows 7 | 64-bit
Downgraded from IE11 to IE9 (I've added the loopback - 127.0.0.1)
Java 1.6.0_21 (also tried Java 1.7.x)

I have tried running both IE9 and CCP as admin and as regular user with no change. Right now, when I start CCP,
I get this error message:



Some posts said to verify that "Scripting of Java applets" in IE's Internet options needs to be enabled. Did that. No change.
This has been the worst experience with software I've ever had. And to think this is a HUGE part of the security exam when it's this difficult to install is shocking.

I think now part of my problem is that Java somehow isn't set up correctly in IE, because when I go to the Oracle website to test Java, I get this:



This is the URL I was using to test from:

Verify Java Version

Any help with this is GREATLY appreciated. I have to get this going to start my studies.

Thanks,

Andy

Comments

  • Todd BurrellTodd Burrell Member Posts: 280
    I also struggled a lot to get CCP going. I know I had to add the loopback address and also run the software as an administrator, but those were my main 2 issues. This sounds like you have some sort of Java issue - have you tried right clicking on the icon for CCP and changing the Target field to point to the different releases of JRE? I know I had to do this with the ASDM software to get it to work properly and I think I used the latest 1.6.x version of JRE for that? I'd also recommend just searching on the web for these issues with CCP - that's how I fixed my problem. Good luck!
  • HondabuffHondabuff Member Posts: 667 ■■■□□□□□□□
    Uninstall all of your newer Java installs. Install Java 6.24 and it will run just fine. I'm running Windows 7 64 bit/IE10 and also added the loopback. I have all kind of issues with the newer Java versions. We have found at work that 6.24 runs all of our Cisco web pages with out a hitch despite the security hole.
    “The problem with quotes on the Internet is that you can’t always be sure of their authenticity.” ~Abraham Lincoln
  • GeeGeez0rzGeeGeez0rz Member Posts: 14 ■■■□□□□□□□
    I found Version 6 Update 17 as a stable build for Java. CCP is an absolute dog due to the Java.
    I've used this version on Win7, Win8 and Server 2012.
  • KrusaderKrusader Member Posts: 109
    I'm using Win7 x64, CCP 2.8 & JRE 7u67 and I have no issues. Just need to Run As Administrator
    Also make sure you have 32bit Java installed

    Found this on Cisco site, might be helpful
    JRE settings for Cisco CP

    The following JRE settings are needed for Cisco CP to function properly:
    1. Go to Start > Control Panel > Java.
    2. Click View under Java Applet Runtime Settings.
    3. Select your JRE in use.
    4. Set the "Java runtime parameters" with the value "-Xmx256m -Dsun.java2d.d3d=false".
    In addition, if JRE is upgraded to versions 1.6.0_11 or above, the following settings are needed after installing Cisco CP:
    1. Go to Start > Control Panel > Java > Advance.
    2. Select "Java Plug-in" tree.
    3. Uncheck the check box for Enable next-generation Java Plug-in.
    4. Restart Cisco CP.
    2018 Goals
    AWS & Linux Knowledge
  • hikerguyhikerguy Member Posts: 8 ■□□□□□□□□□
    Thanks to all those who replied. I tried the suggestions and got close with Java 1.6.0_11 and IE9. I was at the point where I could discover a device with CCP, but when I went to configure it, it gave me the blasted Java error message again!

    What I eneded up doing was upgrading to IE11 and CCP 2.8 and now it's all good. I'm dumbfounded how Cisco could put out specs for their software, we follow those specs, but it still doesn't work. it should have worked with IE9 and Java 6. It almost did. Why it's working now with IE11 and CCP v2.8 (with the same version of Java) is beyond me. I'm also amazed why Cisco is using Java for this app when so many people comment what a security risk Java is. Why not use HTML5????? OK, off my soapbox.

    Thanks again to all the suggestions and help. Hope others have an easier time than I did. Time to start studying.
  • TremiataTremiata Member Posts: 30 ■■□□□□□□□□
    I'm also on win 8.1 IE11 and use 2.8 no issues. But I had issues getting going. ASDM I have to run in a vm with XP.
  • ande0255ande0255 Banned Posts: 1,178
    Is this any easier with actual cisco hardware routers? I haven't started my official study grind yet, but I was toying with GNS3 and CCP a bit, and it seems it may be easiest just to break out a few physical routers from the home lab and run CCP from my laptop.

    Anyone know if its any less of a headache?
  • hikerguyhikerguy Member Posts: 8 ■□□□□□□□□□
    ande0255, I don't see how that would be any easier, as you will still have to get CCP running. From all that I've read, CCP is a HUGE part of this exam. If you can acquire the IOS, I'd choose GNS3 and save yourself some money.
  • ande0255ande0255 Banned Posts: 1,178
    I already actually have a ton of routers and switches from my r/s and voice studies, and I've already gotten CCP running on my laptops, so those two things aren't the issue - It seems to be this MS adapter is giving me every problem possible trying to get traffic between the network that my pc is on and the network set up in GNS3.

    I have the router linked to a cloud / client (tried both), with the MS Loopback configured with an IP on the same subnet as the router its hooked to in GNS3, but that router cannot ping the IP of the cloud / ms loopback interface - The gateway is set to the same IP as the router.

    However, my laptop can ping the MS loopback interface without an issue, but not the next hop router beyond it in GNS3. I've gotten all this working before, and it not working now is driving me frickin nuts :)
  • hikerguyhikerguy Member Posts: 8 ■□□□□□□□□□
    Can you provide a pic of your GNS3 setup (showing the IP addresses), as well as a snapshot of the MS loopback settings? Have you tried deleting and rebuilding the MS loopback?
  • hurricane1091hurricane1091 Member Posts: 918 ■■■■□□□□□□
    I was considering starting to study this as I just passed my CCNA R&S. I used packet tracer for all my lab studies, but I do have Cisco routers and switches. Is it really that difficult to get this thing going?
Sign In or Register to comment.