IPv6 OSPF link local addressing

CoolhandlukeCoolhandluke Member Posts: 118
Hi,

I'm just wondering if someone can verify if my logic is flawed or if its a lab problem....

I created an ethernet network with 3 nodes, i addressed the nodes as follows: R1 (fe80::1), R2 (fe80::2), R3 (fe80::3). I enabled OSPFv3 on the interfaces and all worked well ....

I added a new node to extend the network into a new area (Area 1) using a s0/0 from R2. I then assigned s0/0 on R2 the link-local address fe80::1 with the new router (R4) being fe80::2

R2 dropped its existing link to R1 (timed out) until i re-assigned new link-local addresses (fe80::4 -> fe80::5) which subsequently worked fine.

I was under the impression that as link-local addresses were indeed link local that the same address could be used on different network segments. Clearly this is not the case and i'm not sure as to why, can anyone provide any insight ?

Thanks in advance
[CCENT]->[CCNA]->[CCNP-ROUTE]->COLOR=#0000ff]CCNP SWITCH[/COLOR->[CCNP-TSHOOT]

Comments

  • DCDDCD Member Posts: 458 ■■■□□□□□□□
    R2 see fe80::1 coming in on one of the other interfaces and see it as connected to it s0/0 interface.
  • fredrikjjfredrikjj Member Posts: 879
    You can use the same link local address on different interfaces and have ospfv3 neighbors on both. You probably have some other issue.

    IOSv2#show ipv6 interface brief
    GigabitEthernet0/0.10 [up/up]
    FE80::2
    GigabitEthernet0/0.20 [up/up]
    FE80::2


    IOSv2#show ospfv3 inter brief
    Interface PID Area AF Cost State Nbrs F/C
    Gi0/0.10 1 0 ipv6 1 DR 1/1
    Gi0/0.20 1 0 ipv6 1 BDR 1/1
  • late_collisionlate_collision Member Posts: 146
    This is what I thought too, Fredrik. Link Local addresses are supposed to be tracked by interface identifier. However, when I built the lab described above, I was able to reproduce the same results.

    4 routers connected in a hub and spoke network. Routers A, B, and C are spokes and Z is the hub. Each link is configured as FE80::2 <-> FE80::1, with the FE80::2's all being on the hub (Z). This works as expected.

    Now, choose any 1 link and swap the addresses, OSPF neighbors start dropping.

    I don't quite understand it.

    Edit: I should point out, I am using GNS3 to lab it. Could be one of those GNS3 things or could be my images. My physical gear is inaccessible at the moment,
  • Danielh22185Danielh22185 Member Posts: 1,195 ■■■■□□□□□□
    That is interesting. It should work fine. What version of code are you running on these routers? When I was studying route I found some things didn't work right on some code version within GNS3. I then found 2621XM on code version 12.4.14T14 worked great and there wasn't anything I could not do on that code version.
    Currently Studying: IE Stuff...kinda...for now...
    My ultimate career goal: To climb to the top of the computer network industry food chain.
    "Winning means you're willing to go longer, work harder, and give more than anyone else." - Vince Lombardi
Sign In or Register to comment.