OSPF ABR Default route generation

tomtom1tomtom1 Member Posts: 375
Hi,Doing some labbing but I can't seem to get my config right. 2 routers which have an OSPF adjacency in OSPF area 1. OSPF area 0 is configured on one of the routers and the loopback (lo0.0) interface is in it. I'm trying to have the ABR generate a default route into stub area 1, but I can't seem to get the router in area 1 to see the default route:Config R1 (ABR)
[email protected]> show configuration protocols ospf area 0.0.0.0 {    interface lo0.0 {        passive;    }}area 0.0.0.1 {    stub default-metric 10;    interface em1.0;}
Config R2 (router in area 1)
traceoptions {    file ospf-log.log;    flag all;}area 0.0.0.1 {    stub;    interface em1.0;}
The routers have established a full adjacency over area 1. Even more interesting is that the route to the loopback of R1 appears as a OSPF intra area route (LSA type 3) in the routing table of R2. It should do this, seeing as area 1 is a stub and not a totally stub area. But why doesn't the default route show up at R2?
[email protected]> show ospf neighbor detail Address          Interface              State     ID               Pri  Dead172.12.12.1      em1.0                  Full      1.1.1.1          128    33  Area 0.0.0.1, opt 0x50, DR 172.12.12.2, BDR 172.12.12.1  Up 00:07:03, adjacent 00:07:03
[email protected]> show route protocol ospf inet.0: 11 destinations, 11 routes (11 active, 0 holddown, 0 hidden)+ = Active Route, - = Last Active, * = Both1.1.1.1/32         *[OSPF/10] 00:10:47, metric 1                    > to 172.12.12.1 via em1.0224.0.0.5/32       *[OSPF/10] 23:03:20, metric 1                      MultiRecv
[email protected]> show ospf database | match 0.0.0.0/0 [email protected]>
I've also check the martians, 0.0.0.0/0 exact is allowed. What else could be wrong here. R1 (ABR) does not have a default route itself, but this shouldn't be a requirement as far as I know (at least not in Cisco).

Comments

  • zoidbergzoidberg Member Posts: 365 ■■■■□□□□□□
    I believe it's because you essentially have nothing in your area 0. Other than a passive loopback interface, you have no interfaces or neighbors in your area 0. Junos uses active backbone detection to make sure your area 0 router is actually connected to the backbone and can route traffic somewhere. In your case, it isn't, so it doesn't advertise the default to the stub in hopes that the stub is connected to another ABR that is connected to the backbone.

    1) You can disable this check. Hidden command: set protocols ospf no-active-backbone

    or

    2) Actually create an area 0 that is connected to something
  • tomtom1tomtom1 Member Posts: 375
    Thanks, that fixed it! Makes sense though, but definitely something to remember in a lab:

    From the JunOS documentation:
    The JUNOS software supports active backbone detection. Active backbone detection is implemented to verify that area border routers are connected to the backbone. If the connection to the backbone area is lost, then the router’s default metric is not advertised, effectively rerouting traffic through another area border router with a valid connection to the backbone.
    Active backbone detection enables transit through an area border router with no active backbone connection. An area border router advertises to other routers that it is an area border router even if the connection to the backbone is down, so that the neighbors can consider it for interarea routes.
Sign In or Register to comment.