Options

Cotinue to get either Bad Masks Errors or Overlaps With Internfaces

JockVSJockJockVSJock Member Posts: 1,118
Using Packet Tracer 6.1 and built a simple topology with three routers to bone up on static ip routes.

However I continue to get either Bad Masks Errors of Overlaps With Interfaces and can't ping across serial interfaces, even with static route in place. I've also placed pcs attached to each router and can't ping either one of these either.

I know this is a subnetting issue, however how do I avoid getting these errors and get better at this?

I'm posting a pic of my topolgy and configs below:
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname router001
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.10 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 172.16.10.4 255.255.255.248
 clock rate 2000000
!
interface Serial0/0/1
 ip address 192.168.100.1 255.255.255.252
 clock rate 2000000
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.1.0 255.255.255.0 192.168.100.2 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname router002
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.20 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 172.16.10.2 255.255.255.252
!
interface Serial0/0/1
 ip address 192.168.100.2 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 192.168.1.0 255.255.255.0 172.16.10.5 
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname router003
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.30 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/0/0
 ip address 172.16.10.1 255.255.255.252
 clock rate 128000
!
interface Serial0/0/1
 ip address 172.16.10.5 255.255.255.252
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end




***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

"Its easier to deceive the masses then to convince the masses that they have been deceived."
-unknown

Comments

  • Options
    mikeybinecmikeybinec Member Posts: 484 ■■■□□□□□□□
    change the networks your laptops are in.. Make one the x.x.1.0 /24, the other one x.x.2.0/24 and then the last x.x.3.0/24.. You cant have the laptops in the same network (which you do now) but not physically in the same LAN/ethernet. then change your static routes or use dynamic. that'll fix it fast.. also, in your running config you have the your ip addresses wrong. One is a 1.10 when it should be a 1.101. etc etc (compared to your pictorial)
    Cisco NetAcad Cuyamaca College
    A.S. LAN Management 2010 Grossmont College
    B.S. I.T. Management 2013 National University
  • Options
    Nightflier101BLNightflier101BL Member Posts: 134 ■■■□□□□□□□
    I don't see your config for router 3, but you should make sure your serial interfaces on R3 are configured in the correct subnets. As stated above, your PC's are configured in the same network. You'll have to change your fa int config as well. The static route on R2 looks to be incorrect as I don't see where the 172.16.10.5 can be configured.
  • Options
    JockVSJockJockVSJock Member Posts: 1,118
    I don't see your config for router 3, but you should make sure your serial interfaces on R3 are configured in the correct subnets. As stated above, your PC's are configured in the same network. You'll have to change your fa int config as well. The static route on R2 looks to be incorrect as I don't see where the 172.16.10.5 can be configured.

    Sorry about that, I've corrected it so that r3 running-config is now displaying.
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • Options
    Nightflier101BLNightflier101BL Member Posts: 134 ■■■□□□□□□□
    Have another look at your IP configuration between R1 and R3. I believe you have a misconfigured mask.
  • Options
    JockVSJockJockVSJock Member Posts: 1,118
    Ok, so I now have correct static routes across all three routers and I can ping each router successfully and vice versa.

    The only issue now that my laptops cannot ping across the network and the only thing I can ping with the laptops are the FA interfaces that they are directly attached to. I'm not sure how to troubleshoot, I would think that since I have the static routes setup it would be no problem, however I can't even ping the serial interfaces on the router that the laptop is attached to.
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • Options
    DCDDCD Member Posts: 473 ■■■■□□□□□□
    Do you have default gateway on your PC do you have the correct subnet mask on them do you have static route back to the pc networks?
  • Options
    JockVSJockJockVSJock Member Posts: 1,118
    It was something simple, the default gateways for the laptops were not set correctly.

    I will do more troubleshooting later tonight, however things are getting better.


    thanks
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • Options
    JockVSJockJockVSJock Member Posts: 1,118
    I added the static routes and I can pretty much ping across the network ok, with the exception of the following:

    Router 1 can't ping 192.168.3.103 (laptop) attached to Router 3

    Router 2 can't ping 172.16.10.4 (s0/0/0) attached to Router 1

    Router 3 can't ping 172.16.10.4 (s0/0/0) attached to Router 1

    I will attach the static routes from each router
    router001#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
            E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
            i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
            * - candidate default, U - per-user static route, o - ODR
            P - periodic downloaded static route
     
    
     Gateway of last resort is not set
     
    
          172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
     C       172.16.10.0/29 is directly connected, Serial0/0/0
     S       172.16.10.0/30 [1/0] via 192.168.100.2
     C    192.168.1.0/24 is directly connected, FastEthernet0/0
     S    192.168.2.0/24 [1/0] via 192.168.100.2
     S    192.168.3.0/24 [1/0] via 172.16.10.5
          192.168.100.0/30 is subnetted, 1 subnets
     C       192.168.100.0 is directly connected, Serial0/0/1
     router001#
    
    
    

    router002#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
            E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
            i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
            * - candidate default, U - per-user static route, o - ODR
            P - periodic downloaded static route
     
    
     Gateway of last resort is not set
     
    
          172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
     S       172.16.0.0/29 [1/0] via 192.168.100.1
     C       172.16.10.0/30 is directly connected, Serial0/0/0
     S    192.168.1.0/24 [1/0] via 192.168.100.1
     C    192.168.2.0/24 is directly connected, FastEthernet0/0
     S    192.168.3.0/24 [1/0] via 172.16.10.1
          192.168.100.0/30 is subnetted, 1 subnets
     C       192.168.100.0 is directly connected, Serial0/0/1
    
    
    
    router003#show ip route Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
            D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
            N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
            E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
            i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
            * - candidate default, U - per-user static route, o - ODR
            P - periodic downloaded static route
     
    
     Gateway of last resort is not set
     
    
          172.16.0.0/30 is subnetted, 2 subnets
     C       172.16.10.0 is directly connected, Serial0/0/0
     C       172.16.10.4 is directly connected, Serial0/0/1
     S    192.168.1.0/24 [1/0] via 172.16.10.4
     S    192.168.2.0/24 [1/0] via 172.16.10.2
     C    192.168.3.0/24 is directly connected, FastEthernet0/0
     S    192.168.100.0/24 [1/0] via 172.16.10.2
                           [1/0] via 172.16.10.4
    
    
    

    I think there is something wrong with the route coming off of 172.16.10.4. .
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • Options
    CCIE Wanna BeCCIE Wanna Be Member Posts: 95 ■■□□□□□□□□
    If the original configurations you posted are the same, it appears there is address overlap on some of your serial links (each serial link should have its own subnet), I would look at router001 to router003 and router002 to router003. Again, assuming that this hasn't been fixed already.
    In Progress:
    WGU B.S. - I.T. - Security (and all the certs that come with it)
  • Options
    DCDDCD Member Posts: 473 ■■■■□□□□□□
    You need a return static route on those routes. This is the problem with static routes multiply path.
  • Options
    _Gonzalo__Gonzalo_ Member Posts: 113
    You have a fine mess there! :)

    I´d advise to start over, using new networks for everything. Best if you get all documented first and then get to configuration. I´d do it like this:

    Use 192.168.0.0/24 for serial point to point links. You need three /30 subnets, so you´ll have more than enough!

    Use 172.16.0.0/16 for the networks that your laptops are in. Feel free to split that /16 in whatever pieces you want, but I´d advise to get three /24 subnets and work with them. Another tip is using 172.16.1.0 for router 1, 172.16.2.0 for router 2...

    Order is important, as it is always good not to need your documentation in order to know where is what.

    Then, think about how many static routes you need. As total networks are 6 and every router has 3 connected, you´ll need at least 3 static routes configured on every router. At this point you might consider to implement a dynamic routing protocol icon_wink.gif

    When everything is set, ping (from each host):
    Host´s default gateway (checks host IP config or router interface´s)
    All three remote networks (your routing option will be the cause here)
    Use traceroute if you need more info (but this command would be more useful for path selection, in this case)

    This is a very simple case, so troubleshooting should be over with these steps (even with only the first two)

    Good luck!
  • Options
    JockVSJockJockVSJock Member Posts: 1,118
    _Gonzalo_ wrote: »

    Use 192.168.0.0/24 for serial point to point links. You need three /30 subnets, so you´ll have more than enough!

    Use 172.16.0.0/16 for the networks that your laptops are in. Feel free to split that /16 in whatever pieces you want, but I´d advise to get three /24 subnets and work with them. Another tip is using 172.16.1.0 for router 1, 172.16.2.0 for router 2...

    I still don't understand how to break apart or split /16.

    I know how to subnet on paper, yet, I don't know how to implement it, or subnet it.
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • Options
    _Gonzalo__Gonzalo_ Member Posts: 113
    JockVSJock wrote: »
    I know how to subnet on paper, yet, I don't know how to implement it, or subnet it.

    Well, that´s the vital point, then. You first have to know how many hosts you need. Then, take the minimum number of bits that will allow that number of hosts. You have a total of 32 bits and you will define that minimum for hosts and the rest will define your network:

    50 hosts

    2*2=4
    ...
    2*2*2*2*2=32
    2*2*2*2*2*2=64

    You´ll need the first address for your network address and the last for it´s broadcast address.

    64-2=62

    So, the last 6 of your 32 bits will be identifying your hosts. You´ll have a mask of 32-6= /26

    And your networks will go:
    172.16.0.0/26
    172.16.0.64/26
    172.16.0.128/26
    172.16.0.192/26
    172.16.1.0/26
    and so on...

    As for splitting it and knowing how many networks you´ll have: If your original network was 172.16.0.0/16, you would originally start with 16 bits already defined (172.16.). As, per the example, your network is /26, you would have 26-16= 10 bits assigned for your network part.

    I always advise to aim thinking binary. There are a few key values that you will eventually know and that will help you do subnetting with no need of paper.

    These are all:

    2*2=4
    2*2*2=8
    2*2*2*2=16
    2*2*2*2*2=32
    2*2*2*2*2*2=64
    2*2*2*2*2*2*2=128
    2*2*2*2*2*2*2*2=256
    2*2*2*2*2*2*2*2*2*2=1024

    So, 10 bits is 1024, which is the number of equal sized (/26) networks that a /16 can give you. And this is important because those are the networks, and no others. Therefore, you cannot have a 172.16.0.32/26, because it is not one of the pieces you created.

    Hope it helped!
Sign In or Register to comment.