Can't make incoming call to FXS card

erdenesukherdenesukh Posts: 1Registered Users ■□□□□□□□□□
Hello guys;

I am having problem which means my router can make call for outgoing, but incoming call is not working. Please help me

The config is:



! Last configuration change at 11:23:44 GMT Tue Dec 9 2014 by cisco
version 15.1
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router_Slave
!
boot-start-marker
boot-end-marker
!
!
card type e1 0 3
logging buffered 51200 warnings
enable secret 5 $1$71MK$YyEhYWvkwhJ6ttX3zW/2n.
enable password 7 14141B180F0B
!
no aaa new-model
clock timezone GMT 8 0
no network-clock-participate wic 3
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
!
no ip domain lookup
ip host china 2131 1.1.1.1
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
!
!
trunk group 1
!
!
!
!
!
!
!
voice-card 0
dspfarm
!
crypto pki token default removal timeout 0
!
crypto pki trustpoint TP-self-signed-3724511457
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-3724511457
revocation-check none
rsakeypair TP-self-signed-3724511457
!
!
!
!
license udi pid CISCO2851 sn FHK1353F23G
archive
log config
hidekeys
username cisco password 7 0311595904052F
!
!
controller E1 0/3/0
framing NO-CRC4
channel-group 0 timeslots 14
!
!
!
!
!
!
interface Loopback0
ip address 192.168.3.3 255.0.0.0
!
interface GigabitEthernet0/0
ip address 10.10.10.1 255.255.255.248
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/2/0
ip address 2.2.2.3 255.0.0.0
encapsulation ppp
serial restart-delay 0
clock rate 125000
!
interface Serial0/3/0:0
ip address 172.16.3.1 255.255.255.0
encapsulation ppp
!
interface Serial0/2/1
physical-layer async
no ip address
encapsulation slip
!
ip forward-protocol nd
!
no ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 1.0.0.0 255.0.0.0 2.2.2.2 2
ip route 1.0.0.0 255.0.0.0 172.16.3.2 3
ip route 3.0.0.0 255.0.0.0 2.2.2.2 2
ip route 3.0.0.0 255.0.0.0 172.16.3.2 3
ip route 11.0.0.0 255.0.0.0 2.2.2.2 2
ip route 11.0.0.0 255.0.0.0 172.16.3.2 3
!
busy-message china ^CCCC^C
!
!
!
control-plane
!
!
voice-port 0/0/0
compand-type a-law
!
voice-port 0/0/1
!
voice-port 0/0/2
!
voice-port 0/0/3
!
voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!
!
!
mgcp profile default
!
!
dial-peer voice 1 pots
destination-pattern 833
port 0/0/0
forward-digits all
!
dial-peer voice 2 voip
destination-pattern ...
session target ipv4:1.1.1.1
dtmf-relay h245-alphanumeric
!
dial-peer voice 3 voip
destination-pattern 771
session target ipv4:3.3.3.3
dtmf-relay h245-alphanumeric
!
!
!
!
line con 0
password 7 071A231E4C0317
login local
stopbits 1
line aux 0
no motd-banner
no exec-banner
exec-timeout 0 0
no flush-at-activation
no vacant-message
no activation-character
special-character-bits 8
escape-character BREAK
stopbits 1
speed 4800
line 0/2/1
no exec-banner
exec-timeout 0 0
buffer-length 1536
no vacant-message
autocommand telnet china 2131
no activation-character
special-character-bits 8
transport input telnet
transport output all
escape-character BREAK
stopbits 1
speed 4800
line vty 0 4
access-class 23 in
password 7 01060456590108
login
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
end

Comments

  • azaghulazaghul Posts: 569Member ■■■■□□□□□□
    I usually skip inbound dial-peers for FXO lines, and configure it all under the FXO voice-port.
    [FONT=courier new]voice-port 0/1/0
     description FXO: +61-2-MY-LINE-NUMBER
     trunk-group PSTN-BOTHWAY
     signal groundStart 
     compand-type a-law
     cptone AU
     timeouts call-disconnect 3
     timeouts wait-release 3
     [B]connection plar opx 101[/B]
     impedance complex1
     caller-id enable
     supervisory disconnect dualtone mid-call
     pre-dial-delay 0
     no vad
     exit[/FONT]
    

    connection plar opx 101 does all the magic, sending the answered call to DN 101, be it a button on a phone or an auto-attendant. The voice-port is the first point of ingress, processing the call here means less steps to troubleshoot later:)
Sign In or Register to comment.