Options

Cisco 877W - no wireless connection

Marek607Marek607 Registered Users Posts: 3 ■□□□□□□□□□
Hi,
I'm just beginning the adventure with cisco - I bought a 877W, I configured, the internet works but only after the cable - wifi connection is detected by the laptop, but can not connect (yellow triangle)
I tried several configurations but none was positive.

my sh run:
[COLOR=#333333][FONT=Arial]version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname cisco
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$eCNp$rWuBfZ/cexnwnkm7L447s.
!
aaa new-model
!
!
!
!
aaa session-id common
!
!
dot11 syslog
!
dot11 ssid ciscowifi
   vlan 1
   authentication open
   authentication key-management wpa
   guest-mode
   wpa-psk ascii 0 password
!
no ip source-route
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.56.1
!
ip dhcp pool CLIENT
   import all
   network 192.168.56.0 255.255.255.0
   default-router 192.168.56.1
   dns-server 8.8.8.8 194.204.159.1 194.204.152.34
   lease 0 2
!
!
no ip domain lookup
!
!
!
username marek password 0 password
!
!
archive
 log config
  hidekeys
!
!
ip tcp path-mtu-discovery
!
!
!
interface ATM0
 description Polaczenie ADSL do ISP
 no ip address
 no atm ilmi-keepalive
 pvc 0/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl operating-mode auto
 hold-queue 224 in
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 no ip address
 no ip redirects
 ip local-proxy-arp
 ip nat inside
 ip virtual-reassembly
 no dot11 extension aironet
 !
 encryption vlan 1 mode ciphers tkip
 !
 encryption mode ciphers aes-ccm tkip
 !
 broadcast-key change 3600
 !
 !
 ssid ciscowifi
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 world-mode dot11d country AU indoor
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.1
 description ciscowifi
 encapsulation dot1Q 1 native
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 description Polaczenie dla sieci LAN
 ip address 192.168.56.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface Dialer0
 description Interfejs dzwoniacy
 ip address negotiated
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp chap hostname ..............@neostrada.pl
 ppp chap password 0 .................
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
ip nat inside source list 100 interface Dialer0 overload
!
access-list 100 permit ip 192.168.56.0 0.0.0.255 any
access-list 100 deny   ip any any
no cdp run
!
!
!
control-plane
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 transport preferred ssh
 transport input ssh
!
scheduler max-task-time 5000
end[/FONT][/COLOR]

Can anybody help me?
Thanks in advance

Comments

  • Options
    WhiteLineWhiteLine Registered Users Posts: 3 ■□□□□□□□□□
    Hi Marek,

    In your config, I see "no ip routing" can you turn on "ip routing" and test again?
    Also, starting IOS 15, you need to have correct license to enable certain features.

    WL
  • Options
    Marek607Marek607 Registered Users Posts: 3 ■□□□□□□□□□
    Hi,
    Unfortunately, it did not help - now I have a connection status as "limited access" and still no connection
  • Options
    aquillaaquilla Member Posts: 148 ■■■□□□□□□□
    Hi Marek607,

    I've taken a look at the configuration and made some changes to your configuration. Please apply the configuration below and let me know if it works.

    I've removed the Dot11Radio0 subinterface as this was not needed as everything is running VLAN1. You also did not have Bridging & Routing turned on yet had the commands under the Dot11Radio0 interface (bridge-group 1). I have therefore enabled this, added the same to your VLAN1 interface and created a Bridged Virtual Interface (BVI1).

    
    
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime
    service timestamps log datetime msec localtime
    no service password-encryption
    !
    hostname cisco
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$eCNp$rWuBfZ/cexnwnkm7L447s.
    !
    aaa new-model
    !
    !
    !
    !
    aaa session-id common
    !
    !
    dot11 syslog
    !
    dot11 ssid ciscowifi
       authentication open
       authentication key-management wpa
       guest-mode
       infrastructure-ssid
       wpa-psk ascii 0 password
    !
    no ip source-route
    ip cef
    no ip dhcp use vrf connected
    ip dhcp excluded-address 192.168.56.1
    !
    ip dhcp pool CLIENT
       import all
       network 192.168.56.0 255.255.255.0
       default-router 192.168.56.1
       dns-server 8.8.8.8 194.204.159.1 194.204.152.34
       lease 0 2
    !
    !
    no ip domain lookup
    !
    !
    !
    username marek password 0 password
    !
    bridge irb
    !
    archive
     log config
      hidekeys
    !
    !
    ip tcp path-mtu-discovery
    !
    !
    !
    interface ATM0
     description Polaczenie ADSL do ISP
     no ip address
     no atm ilmi-keepalive
     pvc 0/35
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
     dsl operating-mode auto
     hold-queue 224 in
    !
    interface FastEthernet0
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface Dot11Radio0
     no ip address
     !
     encryption mode ciphers aes-ccm
     !
     broadcast-key change 3600
     !
     !
     ssid ciscowifi
     !
     speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
     channel 2437
     station-role root
     world-mode dot11d country AU indoor
     no cdp enable
     bridge-group 1
     bridge-group 1 subscriber-loop-control
     bridge-group 1 spanning-disabled
     bridge-group 1 block-unknown-source
     no bridge-group 1 source-learning
     no bridge-group 1 unicast-flooding
    !
    !
    interface Vlan1
     no ip address
     bridge-group 1
     bridge-group 1 spanning-disabled
    !
    interface BVI1
     description Polaczenie dla sieci LAN
     ip address 192.168.56.1 255.255.255.0
     ip nat inside
     ip virtual-reassembly
    !
    interface Dialer0
     description Interfejs dzwoniacy
     ip address negotiated
     ip nat outside
     ip virtual-reassembly
     encapsulation ppp
     dialer pool 1
     dialer-group 1
     ppp chap hostname ..............@neostrada.pl
     ppp chap password 0 .................
    !
    ip forward-protocol nd
    ip route 0.0.0.0 0.0.0.0 Dialer0
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list 100 interface Dialer0 overload
    !
    access-list 100 permit ip 192.168.56.0 0.0.0.255 any
    access-list 100 deny   ip any any
    no cdp run
    !
    !
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    !
    line con 0
     no modem enable
    line aux 0
    line vty 0 4
     transport preferred ssh
     transport input ssh
    !
    scheduler max-task-time 5000
    end
    

    Regards,

    CCNA R&S; CCNP R&S
  • Options
    Marek607Marek607 Registered Users Posts: 3 ■□□□□□□□□□
    Hi,


    yes, thanks for reply - problem solved :)/
Sign In or Register to comment.