Options

dsadd group problem

I'm one of those GUI admins. I very rarely use powershell or the command prompt to create users, groups, etc. so I'm really trying to get comfortable using those tools because they will probably be questions on the exam about them.

So, I'm at the Group Administration section of the 70-640 MS Press book which is describing using dsadd to create groups and the three ways you can add more than one at a time. So I try the following:
dsadd group -secgrp yes -scope g
cn=Purchasing,ou=groups,dc=contoso,dc=com
cn=AccountsPayable,ou=groups,dc=contoso,dc=com
cn=NewMedia,ou=groups,dc=contoso,dc=com
ctrl+Z and enter
And I get the following error: dsadd failed:'cn=AccountsPayable,ou=groups,dc=contoso,dc=com' is an unknown parameter. Type dsadd /? for help.

I verified that this should work but every time I try to add more than one group, this error always comes up referencing the second group. I even tried the following (which according to the documentation should work) and got the exact same error message.
dsadd group cn=Purchasing,ou=groups,dc=contoso,dc=com cn=AccountsPayable,ou=groups,dc=contoso,dc=com -secgrp yes -scope g

The first code block does work with dsmod when changing attributes for multiple objects but I can't get it to work with dsadd.

Has anyone else experienced this?

Comments

  • Options
    j-manj-man Member Posts: 143
    I've tried it again with a Server 2008 R2 Enterprise install with all updates installed and I get the same error so I know there isn't a problem with the version of Server.

    Can someone out there try "dsadd group" to add more than one group?
Sign In or Register to comment.