Tftping to a router

WullieWullie Posts: 7Member ■□□□□□□□□□
Hi,

I am having trouble tftp'ing an IOS image to a router from my PC. I can tftp from the router to the PC, but not the other way around, which leads me to believe that it is probably the naming convention that I am using when specifying the destination.

I have tried flash:<filename> and just <filename>.

It picks up the image from the PC (have tried to alter the source image name and it says it can't find it then, so that's not the problem).

I am using a 2500 router, with console cable to PC and also Ethernet (through transceiver) to NIC in PC.

Any advice would be useful

Thanks

Comments

  • wastedtimewastedtime Posts: 586Member
    Try going into your router and doing a copy tftp: flash:. That should get a file from the computer to your router's flash.
  • wildfirewildfire Posts: 654Member
    I normally find writting it all out doesnt work,

    so I often do

    copy tftp flash

    it then runs through a series of prompts, I also remane flash file to something simple like 2500.bin otheriwise hyperterminal doesnt seem happy.
    Looking for CCIE lab study partnerts, in the UK or Online.
  • forbeslforbesl Posts: 454Member
    Let me add that you need to ensure that the IOS (.bin) file is in the TFTP root directory on your computer.
  • WullieWullie Posts: 7Member ■□□□□□□□□□
    Think I found my main problem - 16M image file, only 4M flash (total) icon_rolleyes.gif

    I would have thought it would have come up with an error though, something like "Not enough space to copy file"

    Cheers all for the help anyway icon_thumright.gif
  • porengoporengo Posts: 343Member
    This is a perfect example of how you can learn more from real equipment than from a SIM. I bet you'll never forget to check your memory size from now on. icon_wink.gif
  • suprchgtntsuprchgtnt Posts: 12Member ■□□□□□□□□□
    Cisoc has a free tftp server as does solarwinds- thats what i use
Sign In or Register to comment.