Running multiple CIPCs in Linux

davenulldavenull Member Posts: 173 ■■■□□□□□□□
I tried running multiple instances of Cisco IP Communicators in Linux and it turned out to be a decent solution for voice labs.

First, install a Linux distro that preferably works out of the box. I used an older laptop and Mint 17.1 Mate (either 32 or 64 bit will work). Make sure pulseaudio is installed.

Install PlayOnLinux and winetricks (wine will be pulled as a dependency). When PlayOnLinux is run for the first time it will refresh/update - you won't see an option to Install a non-listed program until it's finished updating.

When prompted to install Wine Mono Installer and Wine Gecko Installer, cancel both of them. When asked to browse to the install file, point to CiscoIPCommunicatorSetup.exe. When asked to create a shortcut, point to communicatork9.exe. When Audio Tuning Wizard pops up, cancel it, it doesn't seem to do anything. The CIPC will complain on startup that it can't find a tftp server. You'll have to point it manually to your CUCM regardless of whether you have option 150 specified or not. Also, change its MAC address to something unique in the Use this Device Name field.

The CIPC should be functional now. Test it out by getting it to auto-register with your CME/CUCM. Install as many CIPCs as you like.

Glitches and workarounds:

CIPC v7 (cipc-Admin-fmr.7-0-6-0) will say "Installation was interrupted ..." and it will roll back the installation if you click Finish. To prevent it from doing that, open a terminal and kill the install process by typing killall MSIEXEC.EXE instead. This is not needed for CIPC v8 (cipc-admin-fmr.8-6-4-0).

Dragging a CIPC window with your mouse may cause it to disappear. As a workaround, use Alt + Left Mouse to drag them. It probably has something to do with a window manager.

When you click New Call or try to dial something, the sound may be crackling. It seems like it's a common issue when using pulseaudio with programs running in wine. I couldn't completely resolve the problem but somehow performing the following sequence of steps seems to alleviate the issue:

1. In terminal, type winetricks sound=alsa. Don't use sudo.
2. Start up your CIPCs (they will sound bad)
3. In PlayOnLinux window right-click on any CIPC > Open the application's directory
4. Right-click the executable (communicatork9.exe) > Open with > Wine Windows Program Loader
5. Cancel the wizard. Click ok for the 'There are no compatible sound devices installed ... ' error.
6. Now try New Call from the CIPC already running - it should sound much better.

Note that if at this point you exit all of your CIPCs and start them again, they may sound horrible until your repeat steps 3-5.

Other things I've tried to fix the sound:

Adding tsched=0 to load-module module-udev-detect in /etc/pulse/ While it fixes the sound beautifully, CIPC crashes when establishing a call.

Tweaking multiple settings in /etc/pulse/daemon.conf didn't produce any noticeable results.

There are no sound issues when using plain alsa without pulseaudio; however, I could run only one instance of CIPC and, often, only once (closing CIPC and running it again results in 'There are no compatible sound devices installed ...' error).

The CIPC farm is very functional as it is, but I'd love to be able to resolve sound issues completely.
Sign In or Register to comment.