Line protocol down

Duane-o-lanternDuane-o-lantern Member Posts: 2 ■□□□□□□□□□
Alright, so I'm like n00btacular at cisco, I've been taking a class in at my highschool for about three weeks. At the current point in the curriculum, we set up an interface E0. The problem with this is that we cannot ping between router and workstation, though the routers can ping each other. when show int e0 is run it displays:
Ethernet0 is up, line protocol is down
  Hardware is Lance, address is 0050.736c.1d62 (bia 0050.736c.1d62)
  Internet address is
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 128/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:09, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     16856 packets output, 1012842 bytes, 0 underruns
     16856 output errors, 0 collisions, 11 interface resets
     0 babbles, 0 late collision, 0 deferred
     16856 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

Now, how in the hell do I set line protcool to be up, or is the problem in pinging between workstation and router due to something else in the configuration?


  • gojericho0gojericho0 Member Posts: 1,059 ■■■□□□□□□□
    Whats your workstation IP/subnet/gateway?
  • Did you remember no shutdown to bring up the line and the protocol?
  • forbeslforbesl Member Posts: 454
    If his interface was shutdown, it would show up as administratively down. It's not, so it isn't.

    If his workstation IP/subnet/gateway was wrong, the router interface doesn't care. As long as he has a good connection, the router interface and line protocol will both be up. He just won't be able to pass traffic.


    If you're connecting your computer directly to your router, instead of through a switch or a hub, make sure you are using an ethernet crossover cable.
  • Duane-o-lanternDuane-o-lantern Member Posts: 2 ■□□□□□□□□□
    A crossover cable is being used, and the IP is an internal IP; the routers are simply here for the class to learn on, so I would assume the information is irrelevenat. It is all correctly entered though.

    What would be the command to set the line protocol to up?
  • forbeslforbesl Member Posts: 454

    What would be the command to set the line protocol to up?
    There is no command to set your line protocol to "up". Your line protocol will go up only when you have a good connection and your router has the ability to talk to your computer and vice-versa. Check to ensure your crossover cable is good (that is, if you are connecting directly from computer to router). If you're connecting from a switch or a hub, make sure you are using a straight through cable and that it is good.

    You can "force" your line protocol up by typing in "no keepalive" in interface configuration mode. This will force your line protocol up; however, if your connectivity is not good your router will still not have the ability to talk to your computer. The only way your line protocol will be truly up is if you meet the above requirements.

    One more thing to check: Change the speed setting on your computer NIC to 10MB. Your router interface is not a fastethernet interface and therefore only operates at 10MB. Even though your computer should detect it if it's set to auto, sometimes it doesn't happen that way.
Sign In or Register to comment.