what am i doing wrong with dual ISP connection routers

itdaddyitdaddy Senior MemberMember Posts: 2,089 ■■■■□□□□□□
what am I doing wrong. it wont fail back unless I get out of gns3 and back in lab.
it works manually removing static route on router a but not with sla and shutting don interface.
the 192.168.5.2 is on the router a.



======ROuter A config primary ISP www connection======

router bgp 65002
network 0.0.0.0
network 3.3.3.3 mask 255.255.255.255
neighbor 192.168.1.1 remote-as 65001
neighbor 192.168.1.1 default-originate
!
ip route 0.0.0.0 0.0.0.0 192.168.5.1 track 1
!
track 1 ip sla 1

ip sla 1
icmp-echo 192.168.5.2
timeout 3000
threshold 3000
frequency 5
ip sla schedule 1 life forever start-time now


=======Router B config for ISP2 secondary www connection=========
router bgp 65000
network 2.2.2.2 mask 255.255.255.255
neighbor 192.168.2.1 remote-as 65001
neighbor 192.168.2.1 next-hop-self
neighbor 192.168.2.1 route-map PREPEND out
!
!
ip route 0.0.0.0 0.0.0.0 192.168.4.1 250
!

Comments

  • PristonPriston Guest Member Posts: 999 ■■■■□□□□□□
    Your two ISP are not the same ISP are they? If they are different that would mean they are both completely different autonomous system right? Your local autonomous system should be the same though.

    https://manilageek.files.wordpress.com/2012/04/bgp.jpg
    A.A.S. in Networking Technologies
    A+, Network+, CCNA
  • itdaddyitdaddy Senior Member Member Posts: 2,089 ■■■■□□□□□□
    Hi Priston,
    thank you for replying to my question. It is a MPLS cloud AS say 65000 and the other branch sites are in this vpn cloud mpls type and each router is its own seperate AS say 4 branches in 1 vpn cloud all different AS
    65000 pass through.
    and 65001, 65002, 65003, 65004 routers and 65001 and 65002 have a ISP router.
    just one hop past itself. No dynamic routing between them just static routing.
    I have BGP running on all 4 routers well and an IP SLA running a ping command to the 1st ISP interface and if it dies it swings it default route over to the 2nd ISP. and that works well i am using AS-path prend on the 2nd ISP to make it a less perferred route when the ip sla ping to the isp is successful. again,
    the router with 65001 has 1 hop to he ISP1 and the 65001 router is running ip sla ping the isp1 router if it dies it takes out default oooo route and the whole bgp system swings to router 65002. that works. and fails back well.
    my problem is my router 65002 keeps using its default route and never uses the ISP1 route I cant seem to get the static default route out of the route table of router 65002 so it chooses the ISP1 route for a default 0.0.0.0 but all the other routers failover and failback fine just the ISP2 gateway router will keep using its default static route. I have tried to make it a floating route, it doesnt work. That is my onlly proble is i cant make the router for isp2 branch use the ISP1 default route even though all the other router do just fine. Get it.
    how can i make my router for isp2 65002 take the bgp route over the static default 0.0.0.0 route?
  • PristonPriston Guest Member Posts: 999 ■■■■□□□□□□
    Is one of them working and not the other or are they both not working?
    A.A.S. in Networking Technologies
    A+, Network+, CCNA
  • atorvenatorven Senior Member Member Posts: 319
    If you've configured it as a floating static route and it's still not showing up in the routing table then I'm guessing that the router itself is unable to reach the nex hop, can you try and ping the next hop for that default route?
  • itdaddyitdaddy Senior Member Member Posts: 2,089 ■■■■□□□□□□
    BETTER FULL Explanation I think guys sorry for the incomprehensible first one.

    this is what the problem is my rambling was just dumb and too much for even me to follow. The WAN works with the as-prepend but the 2nd ISP router still uses the secondary ISP no matter if the primary ISP router adds or removed its static route dependent on the ip sla pinging the ISP1 gateway successfully. So the entire WAN of 4 routers swings back and for to ISP1 and or ISP2 depending on the IP Sla on the primary ISP1 router, the problem is the secondary ISP router is being used all the time because the static floating route will not be removed and let BGP take over. If I remove the static route manually with a NO ip route 0.0.0.0 etc... then BGP takes over and that 4th branch router which is the ISP2 pre gateway route then uses the ISp1 for the 4 router. each route is a branch route with its own LAN and 2 of them have 1 extra hop that is a ISP gateway. Get it now sorry of the long stupid rambling. I just cant make the float route work with the BGP tohave BGP trump the static router for Primary ISP1 usage and then if need to go to the secondary ISP then use your static default route locally. I don't have command of BGP do make this transition work ?
  • fredrikjjfredrikjj Senior Member Member Posts: 879
    Can you draw the topology and what you are trying to do?
    my problem is my router 65002 keeps using its default route and never uses the ISP1 route I cant seem to get the static default route out of the route table of router 65002 so it chooses the ISP1 route for a default 0.0.0.0 but all the other routers failover and failback fine just the ISP2 gateway router will keep using its default static route.

    That's not how BGP works, basically. It seems to me like you have installed default static routes on two edge devices, and the next hop is an ISP router of some sort. Each edge device connects to a different ISP. They then both advertise a default route into BGP that the other edge devices gets?

    The edge devices will never install this route until their own BGP default route is withdrawn because the Weight of the locally generated one is 32,768. Their own default route will not be withdrawn until the tracking object makes the static route disappear. So when both tracking objects are up (both ISPs are working), each edge router will use its own ISP via the default static route.

    It looks like this:

    First edge device:
    #show ip bgp
    
    ....
    
         Network          Next Hop            Metric LocPrf Weight Path
     *>  0.0.0.0          10.1.13.3                0         32768 i
     *                    10.1.12.2                0             0 65002 i
    
    Second edge device:
         Network          Next Hop            Metric LocPrf Weight Path
     *   0.0.0.0          10.1.12.1                0             0 65001 i
     *>                   10.1.24.4                0         32768 i
    


    You see here how the Weight is higher on one of them, and it's the best path (the > symbol). This Weight modification is an automatic loop prevention mechanism for certain scenarios. I suppose then that if you really want to make it work, you need to modify the weight on the incoming default from the other router and also increase the AD of the static route to be higher than eBGP's 20. Note that modification of the weight is a really bad idea generally because when you combine it with a little bit of local preference modification and such you can get loops (pretty interesting though). It would probably be a lot easier to do this with for example OSPF.
  • itdaddyitdaddy Senior Member Member Posts: 2,089 ■■■■□□□□□□
    Fredrick you are dead on with what I want to do. You see the client has 2 ISPs one at each remote branch on the MPLS vpn cloud. They have 4 edge routers and it almost works but the ISP2 edge with the default route going out its Ethernet port still uses the ISP2 default since iit wont leave the route table. I am going to have to setup a tracking on ISP2 edge so it will leave the route table upon No IP SLA ping so it will remove from route table the default route. else it will stay there and branch 2 will never swing over to ISP1 in case of ISP2 failure. It wont be perfect which Erks me but I wish cisco had more automation built in. I guess I can do it this way. as long as they have an isp and 1 branch uses the ISP2 no big deal. But the as-prend works well and when I manually take out the route on ISP2 edge works great on all WAN routers but not on the ISP2 hahaha just sucks. THanks man for your help. I get it with the weight I saw and read that. But I wish I could trick it some how into swing over to primary isp1 but I don't know enough to do that safely. thank you for you help man!
Sign In or Register to comment.