bgp with loopback problem

zdczdc Member Posts: 15 ■□□□□□□□□□
I am trying to configure bgp with loopback in GNS3 and it just keeps showing it in IDLE state. Tried configuring with both ebgp and ibgp and it shows idle in both cases I dont know why. I am using the topology in link below. Please help.

bdw .. When i configure bgp without loopback it works fine and shows bgp in established state.

Sample Configuration for iBGP and eBGP With or Without a Loopback Address - Cisco


  • d4nz1gd4nz1g Member Posts: 464
    Can you ping in both ways?

    If yes, you may need to insert the command ebgp multihop on the neighbor configuration. <- For ebgp, ofc.

    Turn on the debugs and try to figure out what's going on with the adjacencies.
  • networker050184networker050184 Mod Posts: 11,962 Mod
    Update source configured? Route to remote loopback in routing table? For eBGP did you multihop it?
    An expert is a man who has made all the mistakes which can be made.
  • zdczdc Member Posts: 15 ■□□□□□□□□□
    ok problem solved . I was doing the most idiotic thing ever. I was using eigrp and forgot to put route in it. Now it is working.
Sign In or Register to comment.