Options

BGP Aggregation with Advertise map

FrankGuthrieFrankGuthrie Member Posts: 245
INE_OSPF.pngHi guys,


I was doing the BGP Aggregation - Advertise map task in the CCIE R&S workbook of INE:
  • Configure R2 with two new Loopback interfaces with the IPv4 addresses 222.22.0.1/24 and 222.22.1.1/24 and advertise them into BGP.
  • Configure R7 with a new Loopback interface with the IPv4 address 222.22.3.1/24 and advertise it into BGP.
  • Configure R4 and R6 to advertise the aggregate 222.22.0.0/22 into BGP:
    • Include as much of the original AS-Path information as possible while still allowing devices in AS 300 to install the aggregate in the BGP table.

The solution is this:
R2:
interface Loopback220
ip address 222.22.0.1 255.255.255.0
!
interface Loopback221
ip address 222.22.1.1 255.255.255.0
!
router bgp 200
network 222.22.0.0 mask 255.255.255.0
network 222.22.1.0 mask 255.255.255.0


R7:
interface Loopback 223
ip address 222.22.3.1 255.255.255.0
!
router bgp 300
network 222.22.3.0 mask 255.255.255.0


R4, R6:
ip prefix-list AS300_PREFIX permit 222.22.3.0/24
!
route-map ADVERTISE_MAP deny 10
match ip address prefix-list AS300_PREFIX
!
route-map ADVERTISE_MAP permit 100
!
router bgp 100
aggregate-address 222.22.0.0 255.255.252.0 summary-only as-set advertise-map ADVERTISE_MAP


Part of the explanation given is this:
In our scenario, the AS_SET attribute for the summary route should be composed of AS numbers 200, 254, and 300. However, by using the advertise-map parameter, we filter out prefix originated in AS 300 and thus end up with AS_SET of {200,254}. This allows AS 300 accepting back the summary prefix.


My question is about the advertise map:
1. The way they explain it, it look like you can filter AS'ses from the AS path with an advertise map, but basically what they do is filter the prefix from AS 300 by using a prefix-list..... So I want to filter all routes from AS 300, let say AS 300 advertises more routes, then filtering with an AS path ACL seems more logical, isn't it?
2. Also why do you want to send a aggregate for a network, which AS 300 already has.




Added the topology.
Sign In or Register to comment.