Subnetting Question

skywolaskywola Posts: 9Member ■□□□□□□□□□
Here is the diagram:


What I am trying to accomplish, is create a route to the network in the colored square from Router2.
On router 2, which I have telneted into, I am entering the following:


R2(config)#ip route 172.16.4.9 255.255.255.192 172.16.4.6
%Inconsistent address and mask

The routing table in R3 is as follows:
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.4.4/30 is directly connected, FastEthernet0/1
C 172.16.4.64/26 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 [1/0] via 172.16.4.5

I have entered :
R2(config)#ip classless
in both R2 and R3, so that cannot be the issue.
I am using 2811 routers, I'm not sure it that could be a factor or not.
Cisco IOS Software, 2800 Software (C2800NM-IPBASE-M), Version 12.3( 8 ) T5, RELEASE
Given that Router1 and Router2 are ok with the addresses subnetted using 255.255.255.252, it seems that
Router3 should be ok with 255.255.255.192 . . . . . . I tried 255.255.255.252 just to see what would happen
and got the same message. My quess is that it has something to do with the way R2 is subnetted . . . . but
why that would be an issue escapes me. It's likely either the router itself or a newby issue . . . icon_rolleyes.gif

I went back to R3, and found that the address on Fa0/1 was not listed correctly, so I did this:
R3(config-if)#int f0/1
R3(config-if)#ip address 172.16.4.6 255.255.255.252
R3(config-if)#no sh
R3(config-if)#int f0/0
R3(config-if)#ip address 172.16.4.9 255.255.255.192
% 172.16.4.0 overlaps with FastEthernet0/1

The network on Fa0/1 is 172.16.4.4, available addresses 172.16.4.5 and 172.16.4.6 with broadcast address
172.16.4.7.
The network for f0/0 should be 172.16.4.8, so I should be able to use 172.16.4.9 with the 255.255.255.192 mask I
would think!

Comments

  • skywolaskywola Posts: 9Member ■□□□□□□□□□
    I'm answering part of my own question . . . .

    R2(config)#ip route 172.16.4.9 255.255.255.192 172.16.4.6

    The problem appears to be that, when entering the ip route statement, it should be the network, not the actual
    address . . . . ip route 172.16.4.8 255.255.255.192 172.16.4.6;
    The easiest solution is to change the ip address for f0/0 to 172.16.2.2, then in the routing table in R2 use
    ip route 172.16.4.0 255.255.255.192 172.16.4.6
    although, to me, it seems like you would be able to do it the way I tried to do it.
    using 172.16.4.9 . . . . but anyway, using 172.16.2.2.
  • volfkhatvolfkhat Posts: 947Member ■■■■■■■□□□
    Im at work... so don't have the time to better study your pic.

    BUT what strikes me as ODD:

    Router 3's Internal Nic:
    172.16.4.9
    255.255.255.192

    But your Host is:
    172.16.3.4.10
    255.255.255.192

    So... not sure what address you are trying to go for...
    although assuming 172.16.4.10 ?
  • aldoilici1aldoilici1 CCNA R&S, CCNA Cyber Op, GSEC, GMON Posts: 9Member ■■□□□□□□□□
    you listed R3 routing table as:

    C 172.16.4.64/26 is directly connected, FastEthernet0/0

    It's a different network from what you have on diagram
    CCNA R&S, CCNA Cyber Ops, GSEC, GMON
  • DeathmageDeathmage Posts: 2,496Banned
    C 172.16.4.4/30 is your problem.

    172.16.4.4 in the network ID and your broadcast ID is 172.16.4.7, so your workable range is 172.16.4.5 to 172.16.4.6.

    Remember a /30 only has 2 workable addresses, one side for one router the other side for the remote connecting router.

    With that being said your 1st address is 172.16.4.9 which would be in the 2nd subnet of a /30, while your next hop is in the 1st subnet which is illegal.

    Also since it's a /30 your mask would be 255.255.255.252 not 255.255.255.192 that would be a /26 or subnets of 64.

    Might be a good idea to go on Google and search 'Subnetting Workbook', it will be the 1st result and print it out and work through them.

    It's just a mix up with subnetting bit it's very important to master.

    icon_thumright.gif

    Keep at it!
Sign In or Register to comment.