Options

Frame Relay frustrating!

Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
Hi, so I have put together a config in packet tracer and it's all working as far as the 3 interior networks go. When it gets to trying to get the 3 routers on wan links to speak using frame relay, it doesn't want to know.
They're all properly configured with the right sub interfaces and DLCI trust me I have re re re re checked it. The DLCI' are all mapped together on the cloud in packet tracer as well:

R1 to R2 using DLCI 102 for R1 and 201 for R2 etc... but none of them will talk or ping one another! Odd thing is I can't even ping them on the router they're configured on haha! Never see that before and yes they're all on! Basically.....its doing my head in  and i need some help with it fast.


Thanks for the help!

config :



ROUTER 1




Router#sho run
Building configuration...


Current configuration : 1480 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
ip dhcp excluded-address 10.10.0.0 10.10.0.9
!
ip dhcp pool VLAN10
network 10.10.0.0 255.255.255.0
default-router 10.10.0.1
!
!
!
ip cef
no ipv6 cef
!


interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description VLAN10
encapsulation dot1Q 10
ip address 10.10.0.1 255.255.255.0
ip nat inside
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
no ip address
encapsulation frame-relay
ip nat inside
!
interface Serial2/0.102 point-to-point
ip address 192.168.0.1 255.255.255.252
frame-relay interface-dlci 102
ip nat inside
!
interface Serial2/0.103 point-to-point
ip address 192.168.1.1 255.255.255.252
frame-relay interface-dlci 103
ip nat inside
!
interface Serial3/0
no ip address
shutdown
!
interface FastEthernet4/0
ip address 188.23.163.1 255.255.255.252
ip nat outside
!
interface FastEthernet5/0
no ip address
shutdown
!
ip nat pool OUT 188.23.163.1 188.23.163.1 netmask 255.255.255.252
ip nat inside source list 1 pool OUT overload
ip classless
ip route 0.0.0.0 0.0.0.0 188.23.163.2
!
ip flow-export version 9
!
!
access-list 1 permit 10.10.0.0 0.0.255.255
access-list 1 permit 192.168.0.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end










ROUTER 2


Current configuration : 1162 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router2
!
!
!
!
ip dhcp excluded-address 10.10.2.0 10.10.2.9
!
ip dhcp pool VLAN20
network 10.10.2.0 255.255.255.0
default-router 10.10.2.1
!
!
!
ip cef
no ipv6 cef
!
!
!


!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description VLAN20
encapsulation dot1Q 20
ip address 10.10.2.1 255.255.255.0
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
no ip address
encapsulation frame-relay
!
interface Serial2/0.201 point-to-point
ip address 192.168.2.1 255.255.255.252
frame-relay interface-dlci 201
!
interface Serial2/0.203 point-to-point
ip address 192.168.3.1 255.255.255.252
frame-relay interface-dlci 203
!
interface Serial3/0
no ip address
clock rate 2000000
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end












ROUTER 3


Router3#sho run
Building configuration...


Current configuration : 1149 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router3
!
!
!
!
ip dhcp excluded-address 10.10.3.0 10.10.3.9
!
ip dhcp pool VLAN30
network 10.10.3.0 255.255.255.0
default-router 10.10.3.1
!
!
!
ip cef
no ipv6 cef
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 30
ip address 10.10.3.1 255.255.255.0
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
no ip address
encapsulation frame-relay
!
interface Serial3/0
no ip address
encapsulation frame-relay
!
interface Serial3/0.301 point-to-point
ip address 192.168.4.1 255.255.255.252
frame-relay interface-dlci 301
!
interface Serial3/0.302 point-to-point
ip address 192.168.5.1 255.255.255.252
frame-relay interface-dlci 302
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Comments

  • Options
    shortstop20shortstop20 Member Posts: 161 ■■■□□□□□□□
    Can you post the config for each router?
    CCNA Security - 6/11/2018
    CCNP TShoot - 3/7/2018
    CCNP Route - 1/31/2018
    CCNP Switch - 12/10/2015
    CCNA R/S - 1/14/2015
  • Options
    MitechniqMitechniq Member Posts: 286 ■■■■□□□□□□
    Just a quick glance on my phone, your interfaces are not on the same subnets.

    192.168.1
    192.168.2
    192.168.3
    192.168.0

    Please make the subnets the same on connecting DLCIs.
  • Options
    shortstop20shortstop20 Member Posts: 161 ■■■□□□□□□□
    As was pointed out, your connections between routers are not in the same subnets.

    No offense, but I wouldn't suggest diving into things like Frame Relay if you're still learning IP addressing and such.
    CCNA Security - 6/11/2018
    CCNP TShoot - 3/7/2018
    CCNP Route - 1/31/2018
    CCNP Switch - 12/10/2015
    CCNA R/S - 1/14/2015
  • Options
    Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
    Wow i cannot believe i actually did that! I over thought it and didnt even see that! icon_surprised.gif

    Cheers
  • Options
    MitechniqMitechniq Member Posts: 286 ■■■■□□□□□□
    No worries, that's what we are here for..
  • Options
    Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
    R1, 2 and 3 aren't seeing each other at all as neighbours, the frame relay point to point connections are able to ping though! Very confusing!

    Router3#sho frame-relay map
    Serial3/0.301 (up): point-to-point dlci, dlci 301, broadcast, status defined, active
    Serial3/0.302 (up): point-to-point dlci, dlci 302, broadcast, status defined, active

    I have noticed that there are no dynamic addresses being formed as well. Why and could this be an issue?




    ROUTER 1






    Building configuration...


    Current configuration : 1506 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    !
    ip dhcp excluded-address 10.10.0.0 10.10.0.9
    !
    ip dhcp pool VLAN10
    network 10.10.0.0 255.255.255.0
    default-router 10.10.0.1
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.1
    description VLAN10
    encapsulation dot1Q 10
    ip address 10.10.0.1 255.255.255.0
    ip nat inside
    !
    interface FastEthernet1/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial2/0
    no ip address
    encapsulation frame-relay
    ip nat inside
    !
    interface Serial2/0.102 point-to-point
    ip address 192.168.0.1 255.255.255.252
    frame-relay interface-dlci 102
    no ip split-horizon
    ip nat inside
    !
    interface Serial2/0.103 point-to-point
    ip address 192.168.1.1 255.255.255.252
    frame-relay interface-dlci 103
    no ip split-horizon
    ip nat inside
    !
    interface Serial3/0
    no ip address
    shutdown
    !
    interface FastEthernet4/0
    ip address 188.23.163.1 255.255.255.252
    ip nat outside
    !
    interface FastEthernet5/0
    no ip address
    shutdown
    !
    router eigrp 1
    network 10.10.0.0 0.0.255.255
    no auto-summary
    !
    ip nat pool OUT 188.23.163.1 188.23.163.1 netmask 255.255.255.252
    ip nat inside source list 1 pool OUT overload
    ip classless
    !
    ip flow-export version 9
    !
    !
    access-list 1 permit 10.10.0.0 0.0.255.255
    access-list 1 permit 192.168.0.0 0.0.0.255
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
    login
    !
    !
    !
    end










    ROUTER 2


    Router2#sho run
    Building configuration...


    Current configuration : 1227 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router2
    !
    !
    !
    !
    ip dhcp excluded-address 10.10.2.0 10.10.2.9
    !
    ip dhcp pool VLAN20
    network 10.10.2.0 255.255.255.0
    default-router 10.10.2.1
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.1
    description VLAN20
    encapsulation dot1Q 20
    ip address 10.10.2.1 255.255.255.0
    !
    interface FastEthernet1/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial2/0
    no ip address
    encapsulation frame-relay
    !
    interface Serial2/0.201 point-to-point
    ip address 192.168.0.2 255.255.255.252
    no ip split-horizon
    frame-relay interface-dlci 201
    !
    interface Serial2/0.203 point-to-point
    ip address 192.168.3.1 255.255.255.252
    no ip split-horizon
    frame-relay interface-dlci 203
    !
    interface Serial3/0
    no ip address
    clock rate 2000000
    !
    interface FastEthernet4/0
    no ip address
    shutdown
    !
    interface FastEthernet5/0
    no ip address
    shutdown
    !
    router eigrp 1
    network 10.10.0.0 0.0.255.255
    no auto-summary
    !
    ip classless
    !
    ip flow-export version 9
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
    login
    !
    !
    !
    end












    ROUTER 3


    Router3#sho run
    Building configuration...


    Current configuration : 1214 bytes
    !
    version 12.2
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router3
    !
    !
    !
    !
    ip dhcp excluded-address 10.10.3.0 10.10.3.9
    !
    ip dhcp pool VLAN30
    network 10.10.3.0 255.255.255.0
    default-router 10.10.3.1
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.1
    encapsulation dot1Q 30
    ip address 10.10.3.1 255.255.255.0
    !
    interface FastEthernet1/0
    no ip address
    duplex auto
    speed auto
    shutdown
    !
    interface Serial2/0
    no ip address
    encapsulation frame-relay
    !
    interface Serial3/0
    no ip address
    encapsulation frame-relay
    !
    interface Serial3/0.301 point-to-point
    ip address 192.168.1.2 255.255.255.252
    no ip split-horizon
    frame-relay interface-dlci 301
    !
    interface Serial3/0.302 point-to-point
    ip address 192.168.3.2 255.255.255.252
    no ip split-horizon
    frame-relay interface-dlci 302
    !
    interface FastEthernet4/0
    no ip address
    shutdown
    !
    interface FastEthernet5/0
    no ip address
    shutdown
    !
    router eigrp 1
    network 10.10.0.0 0.0.255.255
    no auto-summary
    !
    ip classless
    !
    ip flow-export version 9
    !
    !
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
    login
    !
    !
    !
    end
  • Options
    shortstop20shortstop20 Member Posts: 161 ■■■□□□□□□□
    You don't have the frame relay links included in your EIGRP process.
    CCNA Security - 6/11/2018
    CCNP TShoot - 3/7/2018
    CCNP Route - 1/31/2018
    CCNP Switch - 12/10/2015
    CCNA R/S - 1/14/2015
  • Options
    Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
    Not quite sure what you mean? could you give me an example of what you're talking about?
  • Options
    DeathmageDeathmage Banned Posts: 2,496
    You probably need a FR switch, look at my post on this section on FR too and reverse engineer the config.

    I myself learn better but working in the CLi after watching videos, except I watched a CCNP video on FR on CBT Nuggets because my CCNA videos forgot to mention a FR switch, lol!!!!! :)
  • Options
    shortstop20shortstop20 Member Posts: 161 ■■■□□□□□□□
    Robbo777 wrote: »
    Not quite sure what you mean? could you give me an example of what you're talking about?

    You need to include network statements for the frame relay subnets under your eigrp process.
    CCNA Security - 6/11/2018
    CCNP TShoot - 3/7/2018
    CCNP Route - 1/31/2018
    CCNP Switch - 12/10/2015
    CCNA R/S - 1/14/2015
  • Options
    Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
    Wow worked perfectly after this! Thanks a lot man, well done
Sign In or Register to comment.