Options

Frame Relay EIGRP help???

Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
R1, 2 and 3 aren't seeing each other at all as neighbours, the frame relay point to point connections are able to ping though! Very confusing!

Router3#sho frame-relay map
Serial3/0.301 (up): point-to-point dlci, dlci 301, broadcast, status defined, active
Serial3/0.302 (up): point-to-point dlci, dlci 302, broadcast, status defined, active

I have noticed that there are no dynamic addresses being formed as well. Why and could this be an issue?




ROUTER 1






Building configuration...


Current configuration : 1506 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
ip dhcp excluded-address 10.10.0.0 10.10.0.9
!
ip dhcp pool VLAN10
network 10.10.0.0 255.255.255.0
default-router 10.10.0.1
!
!
!
ip cef
no ipv6 cef
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description VLAN10
encapsulation dot1Q 10
ip address 10.10.0.1 255.255.255.0
ip nat inside
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
no ip address
encapsulation frame-relay
ip nat inside
!
interface Serial2/0.102 point-to-point
ip address 192.168.0.1 255.255.255.252
frame-relay interface-dlci 102
no ip split-horizon
ip nat inside
!
interface Serial2/0.103 point-to-point
ip address 192.168.1.1 255.255.255.252
frame-relay interface-dlci 103
no ip split-horizon
ip nat inside
!
interface Serial3/0
no ip address
shutdown
!
interface FastEthernet4/0
ip address 188.23.163.1 255.255.255.252
ip nat outside
!
interface FastEthernet5/0
no ip address
shutdown
!
router eigrp 1
network 10.10.0.0 0.0.255.255
no auto-summary
!
ip nat pool OUT 188.23.163.1 188.23.163.1 netmask 255.255.255.252
ip nat inside source list 1 pool OUT overload
ip classless
!
ip flow-export version 9
!
!
access-list 1 permit 10.10.0.0 0.0.255.255
access-list 1 permit 192.168.0.0 0.0.0.255
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end










ROUTER 2


Router2#sho run
Building configuration...


Current configuration : 1227 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router2
!
!
!
!
ip dhcp excluded-address 10.10.2.0 10.10.2.9
!
ip dhcp pool VLAN20
network 10.10.2.0 255.255.255.0
default-router 10.10.2.1
!
!
!
ip cef
no ipv6 cef
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description VLAN20
encapsulation dot1Q 20
ip address 10.10.2.1 255.255.255.0
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
no ip address
encapsulation frame-relay
!
interface Serial2/0.201 point-to-point
ip address 192.168.0.2 255.255.255.252
no ip split-horizon
frame-relay interface-dlci 201
!
interface Serial2/0.203 point-to-point
ip address 192.168.3.1 255.255.255.252
no ip split-horizon
frame-relay interface-dlci 203
!
interface Serial3/0
no ip address
clock rate 2000000
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router eigrp 1
network 10.10.0.0 0.0.255.255
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end












ROUTER 3


Router3#sho run
Building configuration...


Current configuration : 1214 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router3
!
!
!
!
ip dhcp excluded-address 10.10.3.0 10.10.3.9
!
ip dhcp pool VLAN30
network 10.10.3.0 255.255.255.0
default-router 10.10.3.1
!
!
!
ip cef
no ipv6 cef
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 30
ip address 10.10.3.1 255.255.255.0
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
no ip address
encapsulation frame-relay
!
interface Serial3/0
no ip address
encapsulation frame-relay
!
interface Serial3/0.301 point-to-point
ip address 192.168.1.2 255.255.255.252
no ip split-horizon
frame-relay interface-dlci 301
!
interface Serial3/0.302 point-to-point
ip address 192.168.3.2 255.255.255.252
no ip split-horizon
frame-relay interface-dlci 302
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router eigrp 1
network 10.10.0.0 0.0.255.255
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Comments

  • Options
    SimridSimrid Member Posts: 327
    Try disabling inverse arp - no frame-relay inverse-arp. May do the trick.

    If not, could you post the configuration of your FR switch (if it's a router rather than the switch on GNS3) also make sure the interfaces on your FR router/switch is using the frame-relay intf-type dce command.
    Network Engineer | London, UK | Currently working on: CCIE Routing & Switching

    sriddle.co.uk
    uk.linkedin.com/in/simonriddle
  • Options
    Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
    Dont you need inverse arp though to make the DLCI's talk?

    Also, i cant post the config because its a frame relay cloud in packet tracer. But the DLCI's do communicate because i can ping between them:

    102 dlci can ping 201 etc...

    They aren't dynamic though which i cant think why! So strange, nothing is straight forward with frame relay haha
  • Options
    DeathmageDeathmage Banned Posts: 2,496
    I ran into the same problem last night then a quick search on Google showed I need a FR switch, but your config answered something that are confusing me about FR, so Koodos!

    They do say once you understand FR it's golden, it's just a matter of getting there that is the *****!!!!!
  • Options
    Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
    I have a "frame switch" in packet tracer albeit its not actually a frame switch but just a cloud with frame relay options on it. I wanted to get this working in packet tracer though instead of gns3! I s there any way i can do this or if someone can help me out??
  • Options
    DeathmageDeathmage Banned Posts: 2,496
    Robbo777 wrote: »
    I have a "frame switch" in packet tracer albeit its not actually a frame switch but just a cloud with frame relay options on it. I wanted to get this working in packet tracer though instead of gns3! I s there any way i can do this or if someone can help me out??


    I'm using physical hardware. Do you know your DCE/DTE's?

    also not sure but I think FR is a limitation in packet tracer.
  • Options
    Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
    Yeah all the DCE's are connected to the "cloud" in packet tracer and the DTE are connected to the routers. Everything SEEMS right! i honestly dont know why its not having it! So frustrating
  • Options
    MooseboostMooseboost Member Posts: 778 ■■■■□□□□□□
    Could you post your lab file?
  • Options
    james43026james43026 Member Posts: 303 ■■□□□□□□□□
    You don't have EIGRP advertising on your FR wan links. Include the FR interfaces in your EIGRP network statements. Also your frame-relay maps aren't showing an IP address because you have them configured as sub-interfaces in a point to point topology.
  • Options
    DeathmageDeathmage Banned Posts: 2,496
    I'll be labbing in FR tonight, once I get it working I'll post you the config and hopefully it helps you. :)
  • Options
    SimridSimrid Member Posts: 327
    You don't need inverse ARP as long as the static routes are configured correctly. Inverse arp allows the routes to be learned dynamically.
    Network Engineer | London, UK | Currently working on: CCIE Routing & Switching

    sriddle.co.uk
    uk.linkedin.com/in/simonriddle
  • Options
    DeathmageDeathmage Banned Posts: 2,496
    @Robo - here is the FR switch that was done in the home-lab I'm using, just modify to your needed. take note of the DCE-DTE ends of the serial connection, the DCE side will need a clock rate. :)

    This frame-switch config was for when I wasn't using OSPF.


    frame-switch#
    frame-switch#show runn
    frame-switch#show running-config
    Building configuration...

    Current configuration : 1570 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname frame-switch
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$.OGX$cbZCwMuiY5QPwTyO6aB1Y0
    enable password 7 030A541C1F003448470D101143464A
    !
    no aaa new-model
    !
    resource policy
    !
    no network-clock-participate slot 1
    no network-clock-participate wic 0
    ip cef
    !
    !
    !
    !
    !
    !
    frame-relay switching
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    username user privilege 15 password 7 02050D480809
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    ip address 192.168.115.33 255.255.255.192
    duplex auto
    speed auto
    !
    interface Serial0/0
    no ip address
    encapsulation frame-relay
    !
    interface Serial1/0
    no ip address
    encapsulation frame-relay
    clock rate 64000
    no frame-relay inverse-arp
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 140 interface Serial1/1 940
    !
    interface Serial1/1
    no ip address
    encapsulation frame-relay
    clock rate 64000
    no frame-relay inverse-arp
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 940 interface Serial1/0 140
    !
    interface Serial1/2
    no ip address
    encapsulation frame-relay
    clock rate 64000
    no frame-relay inverse-arp
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 130 interface Serial1/3 930
    !
    interface Serial1/3
    no ip address
    encapsulation frame-relay
    clock rate 64000
    no frame-relay inverse-arp
    frame-relay lmi-type ansi
    frame-relay intf-type dce
    frame-relay route 930 interface Serial1/2 130
    !
    !
    !
    ip http server
    no ip http secure-server
    !
    !
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    login local
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    logging synchronous
    login local
    line vty 5 15
    exec-timeout 0 0
    logging synchronous
    login local
    !
    !
    end

    frame-switch#
    frame-switch#





    Simrid wrote: »
    You don't need inverse ARP as long as the static routes are configured correctly. Inverse arp allows the routes to be learned dynamically.


    I'm using inverse ARP for the FR in the lab but I'm also using multi-area OSPF, I turned OSPF off and indeed inverse arp wasn't needed, so I can contest to this statement. inverse arp is on by default if I remember correctly.
  • Options
    NansNans Member Posts: 160
    Well with what I remember
    1. the reason why they can ping and cant see in neighboring is Frame relay is gonna put the other interface address in the routing table.
    2. You did everything but I think you forgot to mention few statements in the eigrp 1 and i guess thats the main problem
    router eigrp 1
    network 10.10.0.0 0.0.255.255
    no auto-summary [\Quote]

    **Remember you need to keep in mind why they can ping during troubleshoot if not you dont know why thats happening.

    Regards
    2016 Certification Goals: CCNP Route /COLOR][B][/B][I][B]X[/B][/I][COLOR=#008000-->Switch/COLOR]:study:[COLOR=#ff8c00-->TShoot[], CCDP []
Sign In or Register to comment.