IPv6 quirk and physical plug loopbacks

TWXTWX Posts: 275Member ■■■□□□□□□□
Got bit by this one today, figured that others might want to bear it in mind...

I've got four 2800-series routers as branch routers and an L3 switch as the backbone router. To save on heat generation in the lab, I unplugged the switches from the 2811 and 2801, and to re-light the interfaces I used little Cat5e loopback plugs that I had made. Basically these plugs trick the interface into thinking that there's something on the line, but it only works at 100BaseTX and below due to some hardware sanity checking done by 1000BaseT. since the 2801 and 2811 are Fast Ethernet I didn't think anything of it.

Fast forward to this morning. I decide to get fancy and play with OSPFv3 multiarea and route summarization (wanted to see if it worked like OSPFv2) and so went into the routers to change their lan-side interfaces from Area 0 to new areas. Removed Area 0, added Area 10 to one and 20 to the other on all of the relevant subinterfaces. Went to the 2821 and did not see the routes I expected. Went to the 2851, still no routes. Went to the L3 switch, no routes. Played with the configs back and forth on the 2811 and 2801, turned on debugging on them and on the L3 switch, nada. Weirder yet, the 2811 and 2801 see all of the routes advertised from the 2821 and 2851.

Finally I decided to try the OSPFv3 area changes on the 2821 and the 2851. Changed areas from 0 to 30 and 1, respectively. Works fine. Still can't see the 2811 and 2801. Realize that I am seeing the Lo0 on these though. Did a show ipv6 interface brief and the addresses are listed and the interfaces are up/up. Did a show ipv6 interface brief, same thing, addresses and up/up. Did a show ip route and see the interfaces listed as connected and local as expected. Did a show ipv6 route, and the connected and local routes are not there! That's when I remembered the Ethernet loopback plugs.

Got home, pulled out the loopbacks, plugged real switches in, and voila! The other switches receive LSAs and their local and connected routes are again showing up!

I have absolutely no idea why IPv4 would be fine in this circumstance but IPv6 would fail, but if you're playing with Ethernet Loopbacks to light-up interfaces that otherwise have nothing on them, be aware that they might not behave correctly and won't give you any error messages as to indicate why. Friggin' bizarre and very annoying.

Comments

  • EdTheLadEdTheLad Posts: 2,112Member ■■■■□□□□□□
    Poor explanation, you need to spend a lot more time on ospf. Try "no keepalive" on the ethernet port to force it up, no need for an rj45 loopback jack.
    All your show commands are looking at the interface & rib, since your dealing with ospf why don't you look at the ospf state.
    "sh ip ospf int brief"
    "show ip ospf neighbor"
    "show ip ospf database"
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • TWXTWX Posts: 275Member ■■■□□□□□□□
    It wasn't simply OSPF routes missing, it was connected and local routes for IPv6 addresses on those interfaces that were missing from the router's own table.

    The interfaces are actually passive, they only connect to switches and not to other routers when not using physical loopback plugs.
Sign In or Register to comment.