Kickstart Lab Not Working, Still Booting Off Of DVD Install

JockVSJockJockVSJock Censorship is Un-AmericanMember Posts: 1,118
I have two RHEL v6 machines that live as VMs in VirtualBox. One is a VSFTP Server (192.168.122.50) and serving up under /var/ftp/pub a kf.cfg file.

The ks.cfg has the following permissions
rw--r--r


From another new RHEL v6 VM, I boot off of the DVD install disc and from the Welcome to Red Hat Enterprise Linux 6.5, I select Install or Upgrade an existing system

Press Tab

Enter the following:
linux ks=ftp://192.168.122.50/pub/ks.cfg

I press enter, and it still boots off of the DVD install disc.

I've disabled IPTables on 192.168.122.50 and still no go.

For networking, I'm using Internal Networking and the name of the Network is rhel6, where all of the RHEL6 test vms live.

I don't have ksvalidator installed either, because I wanted to run a check against the ks.cfg file. I'm not sure where the package lives? Because I don't know if it is an issue with the ks.cfg file or a network issue?
***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

"Its easier to deceive the masses then to convince the masses that they have been deceived."
-unknown
«1

Comments

  • JockVSJockJockVSJock Censorship is Un-American Member Posts: 1,118
    Just remembered to try http with the following command:
    linux ks=http://192.168.122.50/inst/ks.cfg
    

    Again it goes to boot off of the RHEL ISO, I don't understand why. I really think it is something with the way the networking is setup in VirtualBox. I even tried to setup two NICs, one on the internal network and the other nic on NAT, so it would try to get some sort of IP Address.

    Still no go.
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • brombulecbrombulec Senior Member Member Posts: 186 ■■■□□□□□□□
    First of all: the kickstart is a config file, so the system will boot from another source (e.g. DVD) and then reads the configuration file. The system needs network interface (full TCP/IP stack), wget/curl command and a few other things.

    Additionally you can check the following stuff:
    1. Network connectivity (ping, telnet and so on)
    2. Web server configuration (service parameters, status - start/stop, httpd.conf, directory - not file - permissions for apache user)
    3. SELinux configuration (SELinux booleans, permissions for apache user) - you can use "Permissive mode" if you don't have experience with SELinux.

    If you want a FULL booot from network look for a PXE configuration examples - the system will boot from network and there will be no need to use DVD/ISO.
  • JockVSJockJockVSJock Censorship is Un-American Member Posts: 1,118
    I'm kind of getting it to work. If I use the following from the boot/prompt screen:
    vmlinuz initrd=initrd.img ks=http://192.168.122.50/pub/ks.cfg ksdevice=eth0
    

    At least now I'm getting a "Error Downloading kickstart file" which is progress.

    Unable to download the kickstart file. Please modify the kickstart parameter below or press Cancel to proceed as an interactive installation.

    Probably either SELinux or some sort of Apache permissions error from here.
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • VeritiesVerities Senior Member Member Posts: 1,162
    For your scenario with Virtual Box you need at least 1 NIC set to bridged. On both VMs do the following for your non NAT NIC:

    Open Virtual Box > Right Click VM >Settings > Network > Adapter 2 > Enable Network Adapter > Adapter 2 Bridged Adapter > Advanced > Promiscuous Mode: Allow VMs

    Once you have the NICs set to allow communication between the two VMs:

    1. Ensure FTP is added as allow to the firewall or turn off the firewall like you already did.
    2. Ensure SELinux boolean has been set to allow FTP or turn off SELinux.
    3. Run with 755 on the KS file.
    4. Test you can navigate to the kickstart file by entering the following the path to it in your internet browser.
    5. Start up your VM with the installer ISO, once the initial install screen pops up, hit tab, then type ks=ftp://locationofkickstartfile

    Kickstart is simply a config file that manages the entire setup/installation of the OS. You have to define the installation source, which is what Brombulec was trying to get at. Right now the installation source would be your ISO.
  • hiddenknight821hiddenknight821 The whole Shebang! Member Posts: 1,209 ■■■■■■□□□□
    You also may want to check out the Kickstart Configurator tool. It's basically a GUI that can help you customize your kickstart script. I use this to create a skeleton script to properly create many custom kickstart scripts.
  • JockVSJockJockVSJock Censorship is Un-American Member Posts: 1,118
    You also may want to check out the Kickstart Configurator tool. It's basically a GUI that can help you customize your kickstart script. I use this to create a skeleton script to properly create many custom kickstart scripts.

    Yes, I seen the command.
    system-config-kickstart
    

    I would prefer to work from the CLI at all times. I'm not sure what package covers that GUI, so I will have to look.

    I am more interested in all of the options for the ks.cfg file. Looking around online, I've seen quite a few and at work, we really don't use Kickstart. However say in a bigger company, say cloud service, I really could see the advantage of using Kickstart.

    thanks
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • varelgvarelg Objectives my friend! Banned Posts: 790
    And you are correct in sticking with command line when creating a Kickstart file. Combination of both GUI tool and CLI would be ideal. GUI of Kickstart creator doesn't let you configure few important things like LVM scheme, for example. So you'd use GUI for setting many other options and then manually edit the resulting file at the command line for the rest of the stuff you'd need done.
    Maybe fixing the vsftp config file where you listed vmlinuz might help, the "append" directive:
    append initrd=initrd.img ks=http://server.where.your.ks.resides
    and it's a given that you put the vmlinuz and its accompanying initrd image into the publicly available directory of the vsftpd.
    Error message about not being able to download the ks.cfg file may be an indicator for connectivity problems with the http server where you ks file resides or it may be that ks.cfg is not located at the document root of the server, hence it can't be downloaded.
    Also: you seems to offer the ks.cfg from an ftp server, yet are telling the target machine that ks file is to be downloaded via HTTP?
  • JockVSJockJockVSJock Censorship is Un-American Member Posts: 1,118
    varelg wrote: »
    GUI of Kickstart creator doesn't let you configure few important things like LVM scheme


    Word on the street is that for anything LVM, stick to the CLI.

    varelg wrote: »
    Also: you seems to offer the ks.cfg from an ftp server, yet are telling the target machine that ks file is to be downloaded via HTTP?

    I've tried both http and ftp in the troubleshooting process.
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • varelgvarelg Objectives my friend! Banned Posts: 790
    Which of your servers is delivering the boot image? The pxelinux.0 file...
  • varelgvarelg Objectives my friend! Banned Posts: 790
    Verities wrote: »
    For your scenario with Virtual Box you need at least 1 NIC set to bridged. On both VMs do the following for your non NAT NIC:
    No need for bridging, it works without it. Permissions and SELinux contexts do get in the way. At least what is given in the original post, permissions seem to be ok.
    @JockVSJock: Am I getting this right: you are starting network installation from DVD but would like to use a kickstart file to provide answers? For network install to work, you'll need to provide install files to the client, a boot image and the Kickstart file. So far, you have install files provided via the install DVD and the Kickstart file via your VSFTP. I think you are missing the boot image. Also, isn't VSFTP asking login and password? If so, that's a no go for network install. TFTP doesn't ask for login, so you might try that instead of VSFTP. And if you go down the TFTP path, both NICs need to be on the host-only network for the setup to work. TFTP is for local-only network. Basic network connectivity needs to be tested as well. It fails to download the ks file, so maybe network connectivity gets in the way.
    Check also the --baseurl= parameter in the ks.cfg file to see if it correctly points to the location of installation files.
    I dusted off my own VMs that I once used for network install and played a bit with them today. File anaconda-ks.cfg may help with syntax, although I'd love to have a man page with a list of Kickstart parameters...
  • varelgvarelg Objectives my friend! Banned Posts: 790
    brombulec wrote: »
    That isn't what I am searching for, I am sure Red Hat documented KickStart solidly, what I am looking for is a man page that would be available at exam time. Red Hat docs aren't available at the exam.
  • JockVSJockJockVSJock Censorship is Un-American Member Posts: 1,118
    Ok, so I'm still working at here and with no success.


    Just to back up and list out all of the details on what I have my settings set to:


    - RHEL 6 server that hosts the ks.cfg file under /var/www/html/ks/ks.cfg
    - iptables is off (want to make sure we can get a basic transfer going)
    - selinux is set to permissive (want to observe logging)
    - httpd is running
    - for http install, the ks.cfg is hosted under /var/www/html/ks and the ks directory has permissions of 0755
    - for the ks.cfg file, I have the following permissions: 0755


    As advised by brombulec, I'm watching from other ttys and here is what I'm seeing:


    Ctl+Alt+F3

    anaconda version 13.21.215 on x86_64 starting 
    FATAL:  Error inserting floppy (/lib/modules/2.6.32-431.el6.x86_64/kernel/drivers/block/floppy.ko.gz) no such device 
    trying to detect vendor driver discs 
    
    
    getting kickstart file 
    
    
    eth0 has link, using it 
    
    
    doing kickstart...settting it up 
    
    
    failed to configure network interface 
    
    
    unable to activate device eth0 
    
    
    file location:  http://192.168.122.50/pub/ks.cfg
    
    
    transferring http://192.168.122.50/pub/ks.cfg 
    
    
    Error downloading http://192.168.122.50/pub/ks.cfg:  Couldn't connect to server 
    
    
    failed to retrieve http://192.168.122.50/pub/ks.cfg 
    
    
    




    From ctl+alt+F4, this is what I'm seeing as well

    WARNING NetworkManager: <warn> (eth0): DHCPv4 request timed out.  
    INFO NetworkManager: <info> (eth0):  canceled DHCP transaction, DHCP client pid 4 69 
    


    With seeing the DHCP time out, I've installed xinetd and also tftp and tried to install the ks.cfg (I've modified the install line of the ks to reflect this)


    From clt+alt+F3

    file location:  ftp://192.168.122.50/var/lib/tftpboot/ks.cfg 
    
    transferring ftp://192.168.122.50/var/lib/tftpboot/ks.cfg 
    
    ERROR:  Error downloading ftp:192.168.122.50:/var/lib/tftpboot/ks.cfg:  Couldn't connect to server 
    
    ERROR:  failed to retrieve ftp://192.168.122.50:/var/lib/tftpboot/ks.cfg 
    
    


    clt+alt+F4
    WARNING NetworkManager:  <warn> error requesting auth for org.freedesktop.network-manager-settings.system.wifi.share.protected:  (26) Remote Exception invoking org.freedesktop.PolicyKit1.Authority.CheckAuthorization() on /org/freedesktop/PolicyKit1/Authority at name org.freedesktop.PolicyKit1:  org.freedesktop.DBus.Error.Spawn.ExecFailed:  Cannot launch daemon, file not found or permission invalid
    
    

    Haven't check what that means yet...yet still not getting this to go.

    I've also tried the nic settings in VirtualBox as recommended by Verities

    - Adapter 2
    - Enable Network Adapter
    - Attached To Bridged Adapter
    - Promiscuous Mode is set to Allow VMs

    The Adpater 1 is set to Internal Network which is what the server and client are on
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • JockVSJockJockVSJock Censorship is Un-American Member Posts: 1,118
    varelg wrote: »
    @JockVSJock: Am I getting this right: you are starting network installation from DVD but would like to use a kickstart file to provide answers?

    Correct. I don't have a pxe environment. And I think this is another way to install Kickstart files, correct? Again Jang doesn't go into too many details here.
    varelg wrote: »
    For network install to work, you'll need to provide install files to the client, a boot image and the Kickstart file. So far, you have install files provided via the install DVD and the Kickstart file via your VSFTP. I think you are missing the boot image.

    So Jang's book really isn't detailed about the install. So I'm going on what I'm finding online and my interaction here at techexams.net. For the client, all I'm doing is booting off of the RHEL install disc, press Tab and then enter the following:
    vmlinuz initrd=initrd.img ks=http://192.168.122.50/pub/ks.cfg ksdevice=eth0
    

    varelg wrote: »
    Also, isn't VSFTP asking login and password?

    No. Never once.
    varelg wrote: »
    And if you go down the TFTP path, both NICs need to be on the host-only network for the setup to work. TFTP is for local-only network.

    I'm using the latest and greatest VirtualBox. I have nics on the Server and client under Attached To set to Internal Network. Is this not correct? Or does it need to be adapter-only?
    varelg wrote: »
    Check also the --baseurl= parameter in the ks.cfg file to see if it correctly points to the location of installation files.

    This I don't know how to do, or wasn't aware that it could be done, so I will have to research it. If this is possible, it would be a great way to troubleshoot.
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • brombulecbrombulec Senior Member Member Posts: 186 ■■■□□□□□□□
    @varelg
    That's not true - you can have all the packages form official repo on exam. Including RedHat docs. On all of my RH exams I had documentation on my machine - even on last - EX236.
  • brombulecbrombulec Senior Member Member Posts: 186 ■■■□□□□□□□
    @JockVsJock:
    You have a problem with your DHCP server and client's IP address - there is no DHCP traffic between the virtual machine and DHCP server. Please look at the VirtualBox configuration :
    File/Preferences/Network/Host-only Networks/DHCP Server and set the required values.
    or if you have NATed network look for the option "Supports DHCP" so the client will as for DHCP from external server.
    I prefer host-only networks for installation and after installation I'm configuring networking on virtual machines.

    Or you can set the ip manually - look for the "ip section" on this link: https://www.kernel.org/doc/Documentation/filesystems/nfs/nfsroot.txt

    ip=<client-ip>:<server-ip>:<gw-ip>:<netmask>:<hostname>:<device>:<autoconf>: <dns0-ip>:<dns1-ip>
    This parameter tells the kernel how to configure IP addresses of devices and also how to set up the IP routing table. It was originally called `nfsaddrs', but now the boot-time IP configuration works independently of NFS, so it was renamed to `ip' and the old name remained as an alias for compatibility reasons.
    If this parameter is missing from the kernel command line, all fields are assumed to be empty, and the defaults mentioned below apply. In general this means that the kernel tries to configure everything using autoconfiguration.

    And another link: http://serverfault.com/questions/445296/is-there-a-linux-kernel-boot-parameter-to-configure-an-ipv6-address
  • varelgvarelg Objectives my friend! Banned Posts: 790
    @brombulec: Not the man pages, that of course is available but the Red Hat guides, like Kickstart part of their official Installation Guide or anything web based, that I don't think is available. I stumbled upon Pykickstart project and surprisingly some docs on PyKickStart did show up in /usr/share/doc. It looks promising and may be what I was looking for.
    @JockVSJock: so many error messages about failed downloads would point to basic connectivity issues. Can you ping each of the servers you are using?
    In my setup, both client and server are in a host-only network. Server has two NICs, one used to be on NAT but that was getting in the way so I got it also onto host-only. It then served as a pretend- gateway (to nowhere) for the network. As soon as I got it off of NAT, it all started connecting.
    Client has to boot off of SOME image, for network install to work client needs the full networking stack up and ready so PXE is I think the way to go. I don't know what is Jang saying in the book, but client definitely needs full networking stack ready for it to download necessary installation files.
    Kickstart file is just another text file and --baseurl part is where you give it the location of installation files, in my setup it is the address to my HTTP server and its document root's directory where I copied the entire CentOS7 DVD. Most of the Kickstart file I created via the GUI utility but can't see why it wouldn't be possible to simply edit anaconda-ks.cfg that is in root's home and adjust it to your needs/requirements.
    So for your setup to start working, you'd need to confirm connectivity to your servers and to serve the client the initial boot image off of which networking stack will be readied for transfer and execution of installation files.
  • varelgvarelg Objectives my friend! Banned Posts: 790
    Also on this:
    So Jang's book really isn't detailed about the install. So I'm going on what I'm finding online and my interaction here at techexams.net. For the client, all I'm doing is booting off of the RHEL install disc, press Tab and then enter the following:
    For a completely automated network install, without any user interaction whatsoever, those parameters are given in the file called "default" of the tftp server. Those would be the boot parameters when client picks up the boot image. It stops because client doesn't have boot image off of which to boot initrd and kernel (however rudimentary) capable enough to build up the networking stack.
  • brombulecbrombulec Senior Member Member Posts: 186 ■■■□□□□□□□
    @varelg
    If it's not available you can install it - just ask your proctor/trainer. It's available, because it's official pdf from RH.
    I passed over 10 exams and on each and every exam I had an access to documentation.
    But on the other hand, there was only one exam, for which I used documentation available on exam :)
  • JockVSJockJockVSJock Censorship is Un-American Member Posts: 1,118
    For the network, all guest are on static ip addresses. I'm guessing this isn't going to work for Kickstart.

    I've also found the DHCP setup under: File > Preferences > Network > Host-only Networks. All of my guests are in the 192.168.122 range. I'm guessing I could setup DHCP so it could server addresses in this range?
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • brombulecbrombulec Senior Member Member Posts: 186 ■■■□□□□□□□
    If you're trying boot system from DVD the system will try to acquire DHCP address unless you'll set IP with command-line parameters.
    If there is no DHCP server the client will not get IP address and there will be no possibility to connect to apache server and download the kickstart.
    But IMHO you should setup DHCP for the installation. And after the installation (or even on kickstart file) you can set static IP address.
  • kly630kly630 Member Member Posts: 72 ■■□□□□□□□□
    When I was first practicing kickstarts with centos6, I wound up having to feed in the entire network settings at boot time to get networking to work, ksdevice=eth0 ip= netmask= gateway= and so on to get networking to actually work.

    I've recently done a kickstart in rhel7 though at my workplace and we really don't need to feed these settings in for networking to get up and running correctly in the kickstart environment. I've always chalked it up to either weirdness in the virtualbox environment or weirdness between what centos and redhat do in the kickstart environment by default. I figure you might just try feeding in manual settings to see if it's an issue with how kickstart networking starts and if so go from there.
  • varelgvarelg Objectives my friend! Banned Posts: 790
    JockVSJock wrote: »
    For the network, all guest are on static ip addresses. I'm guessing this isn't going to work for Kickstart.

    I've also found the DHCP setup under: File > Preferences > Network > Host-only Networks. All of my guests are in the 192.168.122 range. I'm guessing I could setup DHCP so it could server addresses in this range?
    I don't remember having to touch DHCP settings of VirtualBox. However, you'll have to have an active DHCP server on your VM that you are using as a server from which to install the OS onto the client.
    The very first thing client does when you choose to have network boot at the top of the list of bootable devices is contact the DHCP on the network to get an IP from it. The dhcpd.conf file on the server is a convenient place to put further configuration details like the IP of the server that holds the pxe image and the location of that file on that PXE server.
    So, not all guests will have static addresses, just the guest that is going to be your DHCP and PXE server. And no NATed NICs.
  • varelgvarelg Objectives my friend! Banned Posts: 790
    kly630 wrote: »
    When I was first practicing kickstarts with centos6, I wound up having to feed in the entire network settings at boot time to get networking to work, ksdevice=eth0 ip= netmask= gateway= and so on to get networking to actually work.

    .
    Maybe you didn't have a DHCP server on the network that was used for remote install, you hard-code networking details into Kickstart anyway, like if the IP is to be doled out to the client by DHCP or is it manually set IP address, regarding network settings after client gets its OS installed.
  • JockVSJockJockVSJock Censorship is Un-American Member Posts: 1,118
    Still not getting this to work. I've tried what was recommended here. Its late and I will post more tomorrow on what I tried.
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • varelgvarelg Objectives my friend! Banned Posts: 790
    Any error messages that give out what the problem is?
  • hiddenknight821hiddenknight821 The whole Shebang! Member Posts: 1,209 ■■■■■■□□□□
    Any luck yet? After reading your thread, I already forgot how difficult it was to follow Jang's book until I revisited my notes. Admittedly, I had to go over Chapter 1 and 2 a few times they were not in order. Hence, the reason why I wrote up some notes a while ago so I can quickly revisit the steps, setting up VMs. I was using KVM at the time when I had CentOS as my main host OS, so the setup was quite different as I had to make sure I use 'vda' rather than 'sda'.

    You should use the 'NAT Network' mode rather than 'NAT' since that's not a network we can customize in VirtualBox. I am using the latest VirtualBox 5.0. Take a look at the link below:
    https://www.virtualbox.org/manual/ch06.html#networkingmodes

    I’ve decided to try a minimal setup of what you were doing using VirtualBox to see if this can be easily done, and I was able to set up Kickstart. Here’s what I did below. I hope this helps you and others visiting the site. It’s ideal to keep it simple, then build on top of that.

    For the FTP server -
    VirtualBox configuration:
    -NatNetwork (10.0.0.0/24) (default)
    -One Ethernet adapter (default)
    -1 hard drive (20 GB) (default)
    -512MB RAM (no GUI)
    -1 CD drive (containing CentOS 6.6 full image iso)
    -No guest addition required

    CentOS configuration:
    Modify the network config setting - set to static:
    vi /etc/sysconfig/network-scripts/ifcfg-eth0
    

    Lines to modify in ifcfg-eth0 script file: (first two lines are not required)
    ONBOOT=yes
    NM_CONTROLLED=no
    BOOTPROTO=none
    

    Lines to append:
    IPADDR=10.0.0.10
    NETMASK=255.255.255.0
    GATEWAY=10.0.0.1
    

    Set up nameserver, so you can perform yum update:
    echo &#8216;nameserver 10.0.0.1&#8217; > /etc/resolv.conf
    

    Restart network:
    /etc/init.d/network restart
    

    Update yum and install vsftpd server:
    yum -y update && yum -y install vsftpd
    

    Start ftp server and run persistently:
    /etc/init.d/vsftpd start && chkconfig vsftpd on
    

    Copy the image to the FTP directory:
    mount /dev/dvd /media && cp -ar /media/. /var/ftp/pub/inst
    

    Copy the original kickstart file and rename it:
    cp /root/ks-anaconda.cfg /var/ftp/pub/inst && mv /var/ftp/pub/inst/ks-anaconda.cfg /var/ftp/pub/inst/ks.cfg
    

    Modify the kickstart:
    -vi /var/ftp/pub/inst/ks.cfg
    

    See below for my kickstart configuration file example. (I intentionally left out the hashed password. We'll create that in later step):
    # Kickstart file automatically generated by anaconda.
    #version=DEVEL
    install
    url --url ftp://10.0.0.10/pub/inst
    lang en_US.UTF-8
    keyboard us
    network --onboot yes --device eth0 --bootproto dhcp --noipv6
    rootpw  --iscrypted 
    firewall --service=ssh
    authconfig --enableshadow --passalgo=sha512
    selinux --enforcing
    timezone --utc America/New_York
    bootloader --location=mbr --driveorder=sda --append="crashkernel=auto rhgb quiet"
    # The following is the partition information you requested
    # Note that any partitions you deleted are not expressed
    # here so unless you clear all partitions first, this is
    # not guaranteed to work
    #clearpart --none
    zerombr
    clearpart --drives=sda --all --initlabel
    ignoredisk --only-use=sda
    part /boot --fstype=ext4 --size=512
    part pv.008002 --grow --size=1
    volgroup VolGroup --pesize=4096 pv.008002
    logvol / --fstype=ext4 --name=lv_root --vgname=VolGroup --grow --size=1024 --maxsize=51200
    logvol swap --name=lv_swap --vgname=VolGroup  --grow --size=819 --maxsize=819
    repo --name="CentOS"  --baseurl=ftp://10.0.0.10/pub/inst --cost=100
    reboot
    %packages --nobase
    @core
    %end
    

    Create root hashed password and store it to variable. Store absolute path of file to variable for ease:
    hash=$(grub-crypt --sha-512) && kspath=/var/ftp/pub/inst/ks.cfg
    

    Append the hashed password to the ‘rootpw’ directive line in kickstart file:
    awk -v passwd=&#8221;$hash&#8221; -v ksfile=&#8221;$kspath&#8221; &#8216;/rootpw/ {$0=$0&#8221; &#8220;passwd} {print > ksfile}&#8217; $kspath
    

    SELinux setting for FTP directory. You must run this each time a file or directory is added there or else you can’t access it while SELinux is in enforcing mode:
    chcon -R -t public_content_t /var/ftp
    

    Your FTP server is now all set. By default, you should not have an iptables config file, so the firewall is pretty much already disabled. Now we’ll create a second machine which we’ll kickstart. The actual disk size in the guest will be 8GB, and I've already thin-provisioned a 20 GB disk in VirtualBox for this set up.

    For the client VM -
    VirtualBox configuration:
    -NatNetwork (10.0.0.0/24) (default)
    -One Ethernet adapter (default)
    -1 hard drive (20 GB) (default)
    -512MB RAM (no GUI)
    -1 CD drive (containing CentOS 6.6 netinstall image. You can use the full image too.)
    -No guest addition required

    CentOS configuration:
    -None

    When booting up the machine, be sure to press tab at the GRUB screen. You should be editing the line at ‘Install or upgrade an existing system’. Append the following text at the end of ‘vmlinuz initrd=initrd.img ’ line:
    ks=ftp://10.0.0.10/pub/inst/ks.cfg
    

    And you’re all set. This is all you needed. Don’t forget to eject the disk from the VM afterward. For some reasons, if there is an error in my guide above, please let me know as I may have created a typo or left out a step.
  • JockVSJockJockVSJock Censorship is Un-American Member Posts: 1,118
    I got frustrated and took a break from it. I will post more later on what I tried.

    Also having issues with KVM, however that is probably a separate thread...
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • JockVSJockJockVSJock Censorship is Un-American Member Posts: 1,118
    I already forgot how difficult it was to follow Jang's book until I revisited my notes. Admittedly, I had to go over

    Right now, I'm thinking its a combination of not having the networking piece setup correctly in VirtualBox. I still don't understand what Bridged, Hosted and NAT mean, so alot of times it guess work on my part. I've read thru their documentation, however I would have to lab some sort of examples to really understand what it all means. I am running the latest and greatest, FYI.

    I agree with what your saying on Jang's book. It basically sounds like you run the following:
    ks=http://192.168.100.100/pub/ks.cfg 
    
    

    And away you go...

    Not really that simple. There is some prep work that has to take place to make it happen and unfortunately he doesn't have it all detailed out.
    ***Freedom of Speech, Just Watch What You Say*** Example, Beware of CompTIA Certs (Deleted From Google Cached)

    "Its easier to deceive the masses then to convince the masses that they have been deceived."
    -unknown
  • hiddenknight821hiddenknight821 The whole Shebang! Member Posts: 1,209 ■■■■■■□□□□
    As I'd love to write up a complete concise KVM version of Jang's lab setup here, I'd need to find free time to do that. I should've created a blog on this a while ago, so I can readily point you to the resource. By the way, which host OS are you using to run your labs? It'd probably explain why you're having problem if you are trying to run VirtualBox on your CentOS, which could be installed incorrectly.
Sign In or Register to comment.