BGP-Can't eBGP loopback
I can't ping R3 loopback from R1. All neighbors show established. I have the network in my routing table but fails. I can ping from R1 to R2 and from R2 to R3 but can't from R1 to R3
R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.255
interface Ethernet3/0
ip address 10.12.0.1 255.255.255.0
router bgp 12
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
ip route 2.2.2.2 255.255.255.255 10.12.0.2
R2:
interface Loopback0
ip address 2.2.2.2 255.255.255.255
interface Ethernet3/0
ip address 10.12.0.2 255.255.255.0
duplex half
!
interface Ethernet3/1
ip address 172.16.0.2 255.255.255.0
router bgp 12
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 3.3.3.3 remote-as 34
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
ip route 1.1.1.1 255.255.255.255 10.12.0.1
ip route 3.3.3.3 255.255.255.255 172.16.0.3
R3:
interface Loopback0
ip address 3.3.3.3 255.255.255.255
interface Ethernet3/0
ip address 172.16.0.3 255.255.255.0
router bgp 34
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
no auto-summary
ip route 2.2.2.2 255.255.255.255 172.16.0.2
R1 SH IP ROUTE
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
S 2.2.2.2 [1/0] via 10.12.0.2
3.0.0.0/32 is subnetted, 1 subnets
B 3.3.3.3 [200/0] via 2.2.2.2, 00:43:36
10.0.0.0/24 is subnetted, 1 subnets
C 10.12.0.0 is directly connected, Ethernet3/0
R1 SH IP BGP
BGP table version is 13, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete Network Next Hop Metric LocPrf Weight Path
*>i3.3.3.3/32 2.2.2.2 0 100 0 34 i
R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.255
interface Ethernet3/0
ip address 10.12.0.1 255.255.255.0
router bgp 12
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 update-source Loopback0
ip route 2.2.2.2 255.255.255.255 10.12.0.2
R2:
interface Loopback0
ip address 2.2.2.2 255.255.255.255
interface Ethernet3/0
ip address 10.12.0.2 255.255.255.0
duplex half
!
interface Ethernet3/1
ip address 172.16.0.2 255.255.255.0
router bgp 12
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 12
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 3.3.3.3 remote-as 34
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
ip route 1.1.1.1 255.255.255.255 10.12.0.1
ip route 3.3.3.3 255.255.255.255 172.16.0.3
R3:
interface Loopback0
ip address 3.3.3.3 255.255.255.255
interface Ethernet3/0
ip address 172.16.0.3 255.255.255.0
router bgp 34
no synchronization
bgp log-neighbor-changes
network 3.3.3.3 mask 255.255.255.255
neighbor 2.2.2.2 remote-as 12
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
no auto-summary
ip route 2.2.2.2 255.255.255.255 172.16.0.2
R1 SH IP ROUTE
1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
S 2.2.2.2 [1/0] via 10.12.0.2
3.0.0.0/32 is subnetted, 1 subnets
B 3.3.3.3 [200/0] via 2.2.2.2, 00:43:36
10.0.0.0/24 is subnetted, 1 subnets
C 10.12.0.0 is directly connected, Ethernet3/0
R1 SH IP BGP
BGP table version is 13, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete Network Next Hop Metric LocPrf Weight Path
*>i3.3.3.3/32 2.2.2.2 0 100 0 34 i
Comments
-
pevangel Member Posts: 342When you're doing pings, think about what the packet looks like. What's the source address and destination address of the echo request? Does the originating router and any router in transit have a route to your destination?
Then, think about return traffic. What's the source address and destination address of the echo reply? Does that router and any router in transit have a route to make it back? -
mallyg27 Member Posts: 139Thank you. Once I added to network command on router R2 that solved the problem.
I added :
network 172.16.0.0 mask 255.255.255.0
network 10.12.0.0 mask 255.255.255.0 -
joetest Member Posts: 99 ■■□□□□□□□□I remember this line from a user's signature on this forum:
Check both the destination and return path when a route fails
It's quite simple yet incredibly useful to remember at times like these. -
d4nz1g Member Posts: 464use the "ping x.x.x.x source int/ip" command.
It is likely that your routers didn't know each other transit interfaces. -
pevangel Member Posts: 342Thank you. Once I added to network command on router R2 that solved the problem.
I added :
network 172.16.0.0 mask 255.255.255.0
network 10.12.0.0 mask 255.255.255.0
Which network statement allowed you to ping R3's loopback from R1 and why?