IPv6 named EIGRP help

hurricane1091hurricane1091 Member Posts: 918 ■■■■□□□□□□
Hello all,

I was working on IPv6 EIGRP today and learned a little bit, but I am confused about the named EIGRP aspect. Under IPv4 named format, you still use the network command it seems to enable interfaces for that EIGRP instance, but you do it under address-family configuration.

Under classic configuration, I understand that you enable EIGRP under the interface. However, how do you do it under the named configuration? The book essentially seems to not explain, and I am struggling to find the answer online. Please advise :)

Comments

  • theodoxatheodoxa Member Posts: 1,340 ■■■■□□□□□□
    If I remember correctly, EIGRP for IPv6 is active on all interfaces where IPv6 in enabled unless you manually override it in AF Interface Submode. You just have to enable the IPv6 Address Family.
    interface GigabitEthernet 0/0
      ipv6 enable
      exit
    
    interface GigabitEthernet 0/1
      ipv6 enable
      exit
    
    router eigrp SomeName
      address-family ipv6 unicast autonomous-system 10
        af-interface GigabitEthernet 0/0
          shutdown
    

    or
    interface GigabitEthernet 0/0
       ipv6 enable
       exit
    
    interface GigabitEthernet 0/1
       ipv6 enable
       exit
    
    router eigrp SomeName
      address-family ipv6 unicast autonomous-system 10
        af-interface default
          shutdown
          exit-af-interface
        af-interface GigabitEthernet 0/1
          no shutdown
    
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
  • hurricane1091hurricane1091 Member Posts: 918 ■■■■□□□□□□
    Thank you for the reply. I am going to try this!
  • theodoxatheodoxa Member Posts: 1,340 ■■■■□□□□□□
    R1#show ipv6 interface brief
    GigabitEthernet1       [up/up]
        unassigned
    GigabitEthernet1.13    [up/up]
        FE80::20C:29FF:FEDB:C2A1
        2001:155:1:13::1
    GigabitEthernet1.100   [up/up]
        FE80::20C:29FF:FEDB:C2A1
        2001:169:254:100::1
    GigabitEthernet1.146   [up/up]
        FE80::20C:29FF:FEDB:C2A1
        2001:155:1:146::1
    GigabitEthernet2       [administratively down/down]
        unassigned
    GigabitEthernet3       [administratively down/down]
        unassigned
    Loopback0              [up/up]
        FE80::21E:F6FF:FEA1:4600
        2001:150:1:1::1
    Tunnel0                [up/up]
        unassigned
    R1#
    R1#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    R1(config)#router eigrp MyEIGRP
    R1(config-router)#address-family ipv6 unicast autonomous-system 10
    R1(config-router-af)#exit-address-family
    R1(config-router)#end
    R1#
    %SYS-5-CONFIG_I: Configured from console by console
    R1#
    R1#show ipv6 protocols
    IPv6 Routing Protocol is "connected"
    IPv6 Routing Protocol is "application"
    IPv6 Routing Protocol is "ND"
    IPv6 Routing Protocol is "eigrp 10"
    EIGRP-IPv6 VR(MyEIGRP) Address-Family Protocol for AS(10)
      Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
      Metric rib-scale 128
      Metric version 64bit
      Soft SIA disabled
      NSF-aware route hold timer is 240
      EIGRP NSF disabled
         NSF signal timer is 20s
         NSF converge timer is 120s
      Router-ID: 150.1.1.1
      Topology : 0 (base)
        Active Timer: 3 min
        Distance: internal 90 external 170
        Maximum path: 16
        Maximum hopcount 100
        Maximum metric variance 1
        Total Prefix Count: 8
        Total Redist Count: 0
    
     [B] Interfaces:
        GigabitEthernet1.13
        GigabitEthernet1.100
        GigabitEthernet1.146
        Loopback0[/B]
      Redistribution:
        None
    R1#
    R1#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    R1(config)#router eigrp MyEIGRP
    R1(config-router)#address-family ipv6 unicast autonomous-system 10
    R1(config-router-af)#[B]af-interface GigabitEthernet 1.100[/B]
    R1(config-router-af-interface)#[B]shutdown[/B]
    R1(config-router-af-interface)#
    [B]%DUAL-5-NBRCHANGE: EIGRP-IPv6 10: Neighbor FE80::20C:29FF:FE12:C7B7 (GigabitEthernet1.100) is down: interface down[/B]
    R1(config-router-af-interface)#exit-af-interface
    R1(config-router-af)#exit-address-family
    R1(config-router)#end
    R1#
    
    R4#show ipv6 interface brief
    GigabitEthernet1       [up/up]
        unassigned
    GigabitEthernet1.45    [up/up]
        FE80::20C:29FF:FE12:C7B7
        2001:155:1:45::4
    GigabitEthernet1.100   [up/up]
        FE80::20C:29FF:FE12:C7B7
        2001:169:254:100::4
    GigabitEthernet1.146   [administratively down/down]
        FE80::20C:29FF:FE12:C7B7
        2001:155:1:146::4
    GigabitEthernet2       [administratively down/down]
        unassigned
    GigabitEthernet3       [administratively down/down]
        unassigned
    Loopback0              [up/up]
        FE80::21E:F6FF:FEB7:9E00
        2001:150:4:4::4
    Tunnel0                [up/up]
        unassigned
    R4#
    R4#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    R4(config)#router eigrp MyEIGRP
    R4(config-router)#address-family ipv6 unicast autonomous-system 10
    R4(config-router-af)#
    [B]%DUAL-5-NBRCHANGE: EIGRP-IPv6 10: Neighbor FE80::20C:29FF:FEDB:C2A1 (GigabitEthernet1.100) is up: new adjacency
    [/B]R4(config-router-af)#exit-address-family
    R4(config-router)#end
    R4#
    %SYS-5-CONFIG_I: Configured from console by console
    R4#
    R4#show ipv6 protocols
    IPv6 Routing Protocol is "connected"
    IPv6 Routing Protocol is "application"
    IPv6 Routing Protocol is "ND"
    IPv6 Routing Protocol is "eigrp 10"
    EIGRP-IPv6 VR(MyEIGRP) Address-Family Protocol for AS(10)
      Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
      Metric rib-scale 128
      Metric version 64bit
      Soft SIA disabled
      NSF-aware route hold timer is 240
      EIGRP NSF disabled
         NSF signal timer is 20s
         NSF converge timer is 120s
      Router-ID: 150.1.4.4
      Topology : 0 (base)
        Active Timer: 3 min
        Distance: internal 90 external 170
        Maximum path: 16
        Maximum hopcount 100
        Maximum metric variance 1
        Total Prefix Count: 8
        Total Redist Count: 0
    
    [B]  Interfaces:
        GigabitEthernet1.45
        GigabitEthernet1.100
        Loopback0[/B]
      Redistribution:
        None
    R4#
    R4#
    [B]%DUAL-5-NBRCHANGE: EIGRP-IPv6 10: Neighbor FE80::20C:29FF:FEDB:C2A1 (GigabitEthernet1.100) is down: Interface PEER-TERMINATION received[/B]
    R4#
    
    R6#show ipv6 interface brief
    GigabitEthernet1       [up/up]
        unassigned
    GigabitEthernet1.67    [up/up]
        FE80::20C:29FF:FEC7:6914
        2001:155:1:67::6
    GigabitEthernet1.146   [up/up]
        FE80::20C:29FF:FEC7:6914
        2001:155:1:146::6
    GigabitEthernet2       [administratively down/down]
        unassigned
    GigabitEthernet3       [administratively down/down]
        unassigned
    Loopback0              [up/up]
        FE80::21E:E5FF:FE14:8F00
        2001:150:6:6::6
    R6#
    R6#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    R6(config)#router eigrp MyEIGRP
    R6(config-router)#address-family ipv6 unicast autonomous-system 10
    R6(config-router-af)#
    [B]%DUAL-5-NBRCHANGE: EIGRP-IPv6 10: Neighbor FE80::20C:29FF:FEDB:C2A1 (GigabitEthernet1.146) is up: new adjacency
    [/B]R6(config-router-af)#exit-address-family
    R6(config-router)#end
    R6#
    %SYS-5-CONFIG_I: Configured from console by console
    R6#
    R6#show ipv6 protocols
    IPv6 Routing Protocol is "connected"
    IPv6 Routing Protocol is "application"
    IPv6 Routing Protocol is "ND"
    IPv6 Routing Protocol is "eigrp 10"
    EIGRP-IPv6 VR(MyEIGRP) Address-Family Protocol for AS(10)
      Metric weight K1=1, K2=0, K3=1, K4=0, K5=0 K6=0
      Metric rib-scale 128
      Metric version 64bit
      Soft SIA disabled
      NSF-aware route hold timer is 240
      EIGRP NSF disabled
         NSF signal timer is 20s
         NSF converge timer is 120s
      Router-ID: 150.1.6.6
      Topology : 0 (base)
        Active Timer: 3 min
        Distance: internal 90 external 170
        Maximum path: 16
        Maximum hopcount 100
        Maximum metric variance 1
        Total Prefix Count: 8
        Total Redist Count: 0
    [B]
      Interfaces:
        GigabitEthernet1.67
        GigabitEthernet1.146
        Loopback0[/B]
      Redistribution:
        None
    R6#
    
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
  • hurricane1091hurricane1091 Member Posts: 918 ■■■■□□□□□□
    Interesting that it works that way.
Sign In or Register to comment.