Download ASDM from ASAv

AMD4EVERAMD4EVER Member Posts: 64 ■■□□□□□□□□
I created a VM which is running ASAv hoping to practice with ASDM. I configured G0/0 with an IP of and Management0/0 with My laptop has virtual NICs of and

I am able to ping from my laptop to both of the ASAv NICs successfully and also from the ASAv to my laptop. Connectivity doesn't appear to be an issue.

I uploaded the ASDM bin file to my ASAv into flash. I ran the command "asdm image" and pointed to the bin file in flash.

It was my impression that after doing all of this that I'd be able to HTTPS either into the G0/0 or Management NIC and be able to download the ASDM there. However, when I browse to either of those NICs I get a page timed out error. I tried running a Telnet command over port 443 to both NICs and neither responded.

Can someone please help be diagnose this issue?


  • IristheangelIristheangel Mod Posts: 4,133 Mod
    You have to enable HTTP, how you login, and say where you will allow the requests from:
    http server enable <- enables the use of HTTP
    http <subnet> <mask> <nameif> <- This will say what subnets will be allowed to connect to this device and from what interface. So an example would be "http 0 0 inside." This means every subnet coming in from the inside interface can assess the http page
    aaa authentication http console LOCAL<- this basically states that you can login to HTTP with local login (make sure you have a username/password configured)
    And you might have to issue the crypto key generate rsa modulus 1024 command. Not sure off the top of my head
    BS, MS, and CCIE #50931
  • AMD4EVERAMD4EVER Member Posts: 64 ■■□□□□□□□□
    Thanks Iris. That did help but now I'm getting the following error when I try to browse to either interface using HTTPS.

    404 Not Found
    The requested URL /admin/public/index.html was not found on this server.
  • AMD4EVERAMD4EVER Member Posts: 64 ■■□□□□□□□□
    Ah, nevermind. I ran a "sh run" and searching through it I saw that asdm image wasn't pointing to the proper location. Fixed that and now the page loads! Woohoo!
  • IristheangelIristheangel Mod Posts: 4,133 Mod
    Good job :) Have fun with it
    BS, MS, and CCIE #50931
Sign In or Register to comment.