Can't ping VLAN Interface
mallyg27
Member Posts: 139
in CCNA & CCENT
I'm using GNS3. Using layer three switches. I have PC1 connected to SW2 and SW2 connected to SW1. From SW2 I can ping SW1 management VLAN interface, but from PC1 I can't anything. I assure you that all vlans have been added to the database. Any suggestions.
hostname PC1
!
ip source-route
no ip routing
!
!
no ip domain lookup
interface FastEthernet0/0
ip address 10.1.66.50 255.255.254.0
no ip route-cache
duplex full
!
!
ip default-gateway 10.1.66.1
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
transport input all
!
end
hostname NL-B1-SW2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$9YJp$46Z8PZxgVn8qEQrYIajOc/
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip icmp rate-limit unreachable
no ip cef
!
!
!
!
no ip domain lookup
ip domain name testlabs.com
ip name-server 4.2.2.2
ip name-server 4.2.2.3
!
multilink bundle-name authenticated
!
!
macro name add_vlan
end
vlan database
vlan $v
exit
macro name del_vlan
end
vlan database
no vlan $v
exit
!
vtp file nvram:vlan.dat
username admin secret 5 $1$8KpO$.zaSRNL8uxemMQBCMNMKR1
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Port-channel1
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
!
interface FastEthernet1/0
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet1/1
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet1/2
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/3
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/4
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/5
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/6
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/7
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/8
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/9
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/10
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/11
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/12
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/13
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/14
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/15
switchport trunk allowed vlan 1,66,69,1002-1005
switchport mode trunk
duplex full
speed 100
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan71
ip address 10.1.71.2 255.255.255.0
!
ip default-gateway 10.1.71.1
hostname NL-B1-SW1
!
no ip domain lookup
ip domain name testlabs.com
ip name-server 4.2.2.2
ip name-server 4.2.2.3
!
macro name add_vlan
end
vlan database
vlan $v
exit
macro name del_vlan
end
vlan database
no vlan $v
exit
!
vtp file nvram:vlan.dat
username admin secret 5 $1$bI/l$74x7dpNuxMw1pSqIoy2xc/
archive
log config
hidekeys
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
interface Port-channel1
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
!
interface Port-channel2
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
!
interface FastEthernet1/0
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet1/1
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet1/2
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
duplex full
speed 100
channel-group 2 mode on
!
interface FastEthernet1/3
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
duplex full
speed 100
channel-group 2 mode on
!
interface FastEthernet1/4
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/5
duplex full
speed 100
!
interface FastEthernet1/6
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/7
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/8
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/9
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/10
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/11
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/12
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/13
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/14
switchport access vlan 70
duplex full
speed 100
!
interface FastEthernet1/15
no switchport
ip address 10.1.254.1 255.255.255.252
duplex full
speed 100
!
interface Vlan1
no ip address
shutdown
!
interface Vlan64
ip address 10.1.64.1 255.255.254.0
!
interface Vlan66
ip address 10.1.66.1 255.255.254.0
!
interface Vlan68
ip address 10.1.68.1 255.255.255.0
!
interface Vlan69
ip address 10.1.69.1 255.255.255.0
!
interface Vlan70
ip address 10.1.70.1 255.255.255.0
!
interface Vlan71
ip address 10.1.71.1 255.255.255.0
hostname PC1
!
ip source-route
no ip routing
!
!
no ip domain lookup
interface FastEthernet0/0
ip address 10.1.66.50 255.255.254.0
no ip route-cache
duplex full
!
!
ip default-gateway 10.1.66.1
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
transport input all
!
end
hostname NL-B1-SW2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$9YJp$46Z8PZxgVn8qEQrYIajOc/
!
no aaa new-model
memory-size iomem 5
no ip routing
no ip icmp rate-limit unreachable
no ip cef
!
!
!
!
no ip domain lookup
ip domain name testlabs.com
ip name-server 4.2.2.2
ip name-server 4.2.2.3
!
multilink bundle-name authenticated
!
!
macro name add_vlan
end
vlan database
vlan $v
exit
macro name del_vlan
end
vlan database
no vlan $v
exit
!
vtp file nvram:vlan.dat
username admin secret 5 $1$8KpO$.zaSRNL8uxemMQBCMNMKR1
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Port-channel1
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
!
interface FastEthernet1/0
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet1/1
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet1/2
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/3
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/4
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/5
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/6
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/7
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/8
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/9
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/10
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/11
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/12
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/13
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/14
switchport access vlan 66
switchport voice vlan 64
duplex full
speed 100
spanning-tree portfast
!
interface FastEthernet1/15
switchport trunk allowed vlan 1,66,69,1002-1005
switchport mode trunk
duplex full
speed 100
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan71
ip address 10.1.71.2 255.255.255.0
!
ip default-gateway 10.1.71.1
hostname NL-B1-SW1
!
no ip domain lookup
ip domain name testlabs.com
ip name-server 4.2.2.2
ip name-server 4.2.2.3
!
macro name add_vlan
end
vlan database
vlan $v
exit
macro name del_vlan
end
vlan database
no vlan $v
exit
!
vtp file nvram:vlan.dat
username admin secret 5 $1$bI/l$74x7dpNuxMw1pSqIoy2xc/
archive
log config
hidekeys
!
!
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
interface Port-channel1
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
!
interface Port-channel2
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
!
interface FastEthernet1/0
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet1/1
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet1/2
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
duplex full
speed 100
channel-group 2 mode on
!
interface FastEthernet1/3
switchport trunk allowed vlan 1,64,66,69,71,1002-1005
switchport mode trunk
duplex full
speed 100
channel-group 2 mode on
!
interface FastEthernet1/4
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/5
duplex full
speed 100
!
interface FastEthernet1/6
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/7
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/8
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/9
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/10
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/11
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/12
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/13
switchport access vlan 68
duplex full
speed 100
!
interface FastEthernet1/14
switchport access vlan 70
duplex full
speed 100
!
interface FastEthernet1/15
no switchport
ip address 10.1.254.1 255.255.255.252
duplex full
speed 100
!
interface Vlan1
no ip address
shutdown
!
interface Vlan64
ip address 10.1.64.1 255.255.254.0
!
interface Vlan66
ip address 10.1.66.1 255.255.254.0
!
interface Vlan68
ip address 10.1.68.1 255.255.255.0
!
interface Vlan69
ip address 10.1.69.1 255.255.255.0
!
interface Vlan70
ip address 10.1.70.1 255.255.255.0
!
interface Vlan71
ip address 10.1.71.1 255.255.255.0
Comments
-
theodoxa Member Posts: 1,340 ■■■■□□□□□□How is everything connected together. What port on SW2 is PC1 connected and what ports are connected between SW2 and SW1 (F1/0 and F1/1)? Am I correct in presuming you are trying to PING the VLAN 66 SVI on SW1?R&S: CCENT → CCNA → CCNP → CCIE [ ]
Security: CCNA [ ]
Virtualization: VCA-DCV [ ] -
mallyg27 Member Posts: 139How is everything connected together. What port on SW2 is PC1 connected and what ports are connected between SW2 and SW1 (F1/0 and F1/1)? Am I correct in presuming you are trying to PING the VLAN 66 SVI on SW1?
PC1 is connected to FE1/2 on SW2 and SW2 is connected to SW1 via etherchannel FE1/0-FE1/1. Yes I'm trying to ping VLAN 66. I do have a Server connected to SW1 on port FE1/4 and the server can ping all VLAN interfaces. That server is in VLAN 68. -
theodoxa Member Posts: 1,340 ■■■■□□□□□□OK...I just dumped a slightly modified (to work with my 3560s) version of your configs onto 3 x 3560 L3 Switches and first thing I noticed is that the port on PC1 is not configured as a L3 Port. I assume that you are in fact using 3 Routers with Etherswitch modules rather than actual L3 switches, so this would not be a problem as you were using F0/N, which is a router port rather than F1/N which would be an Etherswitch port.
PC1 (F0/1) to (F0/3) SW2 (F0/1-2) to (F0/1-2) SW1
PING fails as described.PC1#ping 10.1.66.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 10.1.66.1, timeout is 2 seconds: ..... Success rate is 0 percent (0/5)
The interface on PC1 and on SW2 appear to be Up/UpPC1#show ip interface brief | include 0\/1 FastEthernet0/1 10.1.66.50 YES manual up up NL-B1-SW2#show ip interface brief | include 0\/3 FastEthernet0/3 unassigned YES unset up up
VLAN 66 is allowed on the trunk on the SW2 side, but we see a problem immediately on SW1. VLAN 66 is allowed, but not Active.NL-B1-SW2#show interface trunk Port Mode Encapsulation Status Native vlan Po1 on 802.1q trunking 1 Port Vlans allowed on trunk Po1 1,64,66,69,71,1002-1005 Port Vlans allowed and active in management domain Po1 1,64,66 Port Vlans in spanning tree forwarding state and not pruned Po1 1,64,66 NL-B1-SW1#show interface trunk Port Mode Encapsulation Status Native vlan Po1 on 802.1q trunking 1 Port Vlans allowed on trunk Po1 1,64,66,69,71,1002-1005 Port Vlans allowed and active in management domain Po1 1 Port Vlans in spanning tree forwarding state and not pruned Po1 1
I simply configured VLAN 66 on SW1NL-B1-SW1#config t Enter configuration commands, one per line. End with CNTL/Z. NL-B1-SW1(config)#vlan 66 NL-B1-SW1(config-vlan)#end
andNL-B1-SW1# *Mar 1 00:19:25.555: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan66, changed state to upshow interface trunk Port Mode Encapsulation Status Native vlan Po1 on 802.1q trunking 1 Port Vlans allowed on trunk Po1 1,64,66,69,71,1002-1005 Port Vlans allowed and active in management domain Po1 1,66 Port Vlans in spanning tree forwarding state and not pruned Po1 1,66
as I suspected, VLAN 66 is now Allowed, Forwarding, and Not Pruned.PC1#ping 10.1.66.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 10.1.66.1, timeout is 2 seconds: .!!!! Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/9 ms
Try configuring VLAN 66 on SW1 and see if it works.
[EDIT] Only thing is you should not have been able to PING VLAN 66 from SW2 either.R&S: CCENT → CCNA → CCNP → CCIE [ ]
Security: CCNA [ ]
Virtualization: VCA-DCV [ ] -
theodoxa Member Posts: 1,340 ■■■■□□□□□□If that doesn't work, please post the output of (Note \/ is a backslash and a forward slash NOT a V) --
SW2show interface trunk show vlan | include 66 show ip interface brief | include [ol]1|1\/2 show spanning-tree vlan 66 | include [ol]1\ |1\/2
SW1show interface trunk show vlan | include 66 show ip interface brief | include [ol]1 show spanning-tree vlan 66 | include Po1|channel1
PC1show ip interface brief | include 0\/0
R&S: CCENT → CCNA → CCNP → CCIE [ ]
Security: CCNA [ ]
Virtualization: VCA-DCV [ ] -
mallyg27 Member Posts: 139I am using routers with ether modules in them. The following was already my output on switch1 and switch2. Also SW2 can PING VLAN 66.
NL-B1-SW1#sh int trunk
Port Mode Encapsulation Status Native vlan
Po1 on 802.1q trunking 1
Po2 on 802.1q trunking 1
Port Vlans allowed on trunk
Po1 1,64,66,69,71,1002-1005
Po2 1,64,66,69,71,1002-1005
Port Vlans allowed and active in management domain
Po1 1,64,66,69,71
Po2 1,64,66,69,71
Port Vlans in spanning tree forwarding state and not pruned
Po1 1,64,66,69,71
Po2 1,64,66,69,71
NL-B1-SW2#sh int trunk
Port Mode Encapsulation Status Native vlan
Po1 on 802.1q trunking 1
Port Vlans allowed on trunk
Po1 1,64,66,69,71,1002-1005
Port Vlans allowed and active in management domain
Po1 1,64,66,69,71
Port Vlans in spanning tree forwarding state and not pruned
Po1 1,64,66,69,71
NL-B1-SW2#sh ip int brief | in 1\/2
FastEthernet1/2 unassigned YES unset up up
NL-B1-SW1#show vlan-sw | in 66
66 Client Data active
66 enet 100066 1500 - - - - - 0 0
NL-B1-SW2#show vlan-sw | in 66
66 Client Data active Fa1/2, Fa1/3, Fa1/4, Fa1/5
66 enet 100066 1500 - - - - - 0 0
NL-B1-SW1#show spanning-tree vlan 66 | include Po1|channel1
from Port-channel1
Port 321 (Port-channel1) of VLAN66 is forwarding
NL-B1-SW2#show spanning-tree vlan 66 | include [ol]1\ |1\/2
Port 43 (FastEthernet1/2) of VLAN66 is forwarding
NL-B1-SW2#show ip interface brief | include [ol]1|1\/2
FastEthernet1/2 unassigned YES unset up up
Port-channel1 unassigned YES unset up up
PC1#sh ip int brief | include 0\/0
FastEthernet0/0 10.1.66.50 YES manual up up -
Hondabuff Member Posts: 667 ■■■□□□□□□□Try going back to GNS3 0.8.7. I was having a lot of issues with the switches and switch modules in the newer GNS3.
or try adding the no autostate on the VLAN.
CORP-R1(config)#int vlan 55
CORP-R1(config-if)#no autostate“The problem with quotes on the Internet is that you can’t always be sure of their authenticity.” ~Abraham Lincoln -
Priston Member Posts: 999 ■■■■□□□□□□Is vlan 66 in the vlan database on both switches?A.A.S. in Networking Technologies
A+, Network+, CCNA -
mallyg27 Member Posts: 139Try going back to GNS3 0.8.7. I was having a lot of issues with the switches and switch modules in the newer GNS3.
or try adding the no autostate on the VLAN.
CORP-R1(config)#int vlan 55
CORP-R1(config-if)#no autostate
Tried that command but still having the same issue. I have a feeling the issue may be with GNS3. I swear GNS3 sucks. Every time I have a problem It's always suggested to go back or up a version. -
theodoxa Member Posts: 1,340 ■■■■□□□□□□Is vlan 66 in the vlan database on both switches?
It appears so from the output of the commands he posted (VLAN 66 is present and active on both switches and allowed across the Trunk with all interfaces Up/Up). I cannot see any reason it shouldn't be working. It works on my 3560s and all I changed from the posted configs is the port numbers (3560 uses F0/[1-24], while the Etherswitch modules use F1/[0-??]) and added the "switchport trunk encapsulation dot1q" (required on switches that support Cisco's proprietary ISL Trunking) command before the command to make an interface a trunk. All I can figure is its a GNS3 issue as suggested by another poster.R&S: CCENT → CCNA → CCNP → CCIE [ ]
Security: CCNA [ ]
Virtualization: VCA-DCV [ ] -
DPG Member Posts: 780 ■■■■■□□□□□Does it work if you remove the etherchannel between the routers and use a single link? Dynamips has always had issues with port aggregation.
-
Hondabuff Member Posts: 667 ■■■□□□□□□□I tried building the lab in 0.8.7 and it doesn't work. I think it's a limitation with the L2 switching with the switch modules. You can ping from switch to switch, PC to switch but not PC through switch 2. Tried with a pair of 3850's and it works fine.“The problem with quotes on the Internet is that you can’t always be sure of their authenticity.” ~Abraham Lincoln