Why cant the machine join the domain....powershell?

Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
Hi, i'm having trouble getting this computer on the left of the picture to join the domain on the right. I think I have entered everything correctly with all the right OU paths and domain names etc... When the credentials window pops up I enter the password in and always get the same error in powershell?

<<*Update* I corrected the DNS server config that my router reset on DHCP renewal and now this is the new error i'm getting. I changed the DC directory because the domain controller is named sith.marvel.com, I don't know if that's a problem or not but even with dc=marvel,dc=com it still doesn't work.


  • netsysllcnetsysllc Member Posts: 479 ■■■■□□□□□□
    say invalid domain, your DNS on the workstation is likely pointing somewhere other than your AD server. Do no use any DNS servers other than your AD DNS servers or you will have issues
  • Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
    Sorry if the pictures aren't very clear, th first picture error says "the specified domain either does not exist or cant be contacted" and the second updated picture says "incorrect parameter". I'll post the pictures again
  • Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
    Here is hopefully a more clear and updated error, I have set the WORKGROUP machines (on the left) DNS server to be the domain controllers one on the right. The error is incorrect parameters.

    *Update* I have fixed the issue, amazingly it was a comma -OUPath ",(<<<<here)ou=shielddesktops". That stopped it from working. I took it out and ran it for a laugh expecting it not to work again and it did......typical
    new.jpg 35.5K
  • DojiscalperDojiscalper Member Posts: 266 ■■■□□□□□□□
    I'm looking at the image on a 32" monitor and can't begin to read the commands. Don't allow what ever your doing to get us the image to compress and/or resize it.

    TIP, make sure your subnet, IP, and DNS addresses are all correct and test that your addresses and A records are being resolved via PING and NSLOOKUP for sure. PING both the IP and the A record to make sure your talking. Next make sure your add-computer command syntax is correct and that you have a -credential that is a domain admin.

    I've had fresh installs give me fits joining the domain and I've had others set everything correct by default and all I had to do was add-computer.
  • koksmenkoksmen Member Posts: 9 ■□□□□□□□□□
    I would assume that -oupath should NOT start with "," that's it. also when computer have DNS specif. in NIC you do not need to spec domain. : ) or you have like 2 in there : )
Sign In or Register to comment.