Options

EIGRP over Hub and Spoke Frame Relay - Goodbye packets when opening LAN interfaces?

ande0255ande0255 Banned Posts: 1,178
I finally overcome getting interfaces all pinging, EIGRP routes propagating over a hub and spoke Frame Relay network (Chris Bryant setup), and I turned off the LAN ports so routes would not be learned over that to force feed FR to myself and make this work.

(Edit: Topology shows Area 100, meant to be AS 100)

So I got the spokes passing routes from the hub via sub-interfaces on the hub, summarized a route, everything is pinging - Great! Then I opened the LAN Fa0/0 ports on the two spokes which are connected via a 3560 to simulate the LAN and get the following notifications:

R1#
R1#
R1#
*Mar 1 07:45:23.432: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.6 (Serial0/0.13) is down: Interface Goodbye received
R1#
*Mar 1 07:45:25.403: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.2 (Serial0/0.12) is down: Interface Goodbye received
R1#
*Mar 1 07:45:27.306: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.2 (Serial0/0.12) is up: new adjacency
*Mar 1 07:45:28.147: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.6 (Serial0/0.13) is up: new adjacency
R1#
*Mar 1 07:46:47.610: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.6 (Serial0/0.13) is down: Interface Goodbye received
*Mar 1 07:46:48.611: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.6 (Serial0/0.13) is up: new adjacency
R1#
*Mar 1 07:48:08.182: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.6 (Serial0/0.13) is down: Interface Goodbye received
R1#
*Mar 1 07:48:11.487: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.6 (Serial0/0.13) is up: new adjacency




It seems to freak both sub-interfaces out, then continue to pick on the sub-int going to R3, so I went there and I am getting this output at the same intervals:



ASR#3
[Resuming connection 3 to r3 ... ]

*Mar 1 10:55:10.985: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
R3(config-if)#
*Mar 1 10:55:13.498: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
R3(config-if)#
*Mar 1 11:03:40.144: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.5 (Serial0/2) is down: retry limit exceeded
R3(config-if)#
*Mar 1 11:03:44.034: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.5 (Serial0/2) is up: new adjacency


If I shut down the LAN interfaces the messages stop, but I've configured this before and have not seen that before, is it possibly the 3560 that has some default behavior? All I did for it was assign a mgmt IP to Vlan1 and no shut it, no routing has been enabled / disabled or anything.


Below is the running configs of all 4 devices and a crude topology for reference, any ideas on where I'm tripping up would be greatly appreciated!




R1



R1#show run
Building configuration...

Current configuration : 2032 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$iIpC$9.MGkiLeuNnMnWwOSSZgV.
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
!
interface Loopback101
ip address 100.1.0.1 255.255.0.0
!
interface Loopback102
ip address 100.2.0.1 255.255.0.0
!
interface Loopback103
ip address 100.3.0.1 255.255.0.0
!
interface Loopback104
ip address 100.4.0.1 255.255.0.0
!
interface Loopback105
ip address 100.5.0.1 255.255.0.0
!
interface Loopback106
ip address 100.6.0.1 255.255.0.0
!
interface Loopback107
ip address 100.7.0.1 255.255.0.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay
no frame-relay inverse-arp
!
interface Serial0/0.12 point-to-point
ip address 172.12.123.1 255.255.255.252
ip summary-address eigrp 100 100.0.0.0 255.248.0.0 5
frame-relay interface-dlci 122
!
interface Serial0/0.13 point-to-point
ip address 172.12.123.5 255.255.255.252
ip summary-address eigrp 100 100.0.0.0 255.248.0.0 5
frame-relay interface-dlci 123
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router eigrp 100
network 1.1.1.1 0.0.0.0
network 100.1.0.0 0.0.255.255
network 100.2.0.0 0.0.255.255
network 100.3.0.0 0.0.255.255
network 100.4.0.0 0.0.255.255
network 100.5.0.0 0.0.255.255
network 100.6.0.0 0.0.255.255
network 100.7.0.0 0.0.255.255
network 172.12.123.0 0.0.0.255
no auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
password CCNP
logging synchronous
login
!
!
end

R1#





R2



R2#show run
Building configuration...

Current configuration : 1277 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$cRe6$FY0TO/l1.y.4.96ipWECt0
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback2
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 172.12.23.2 255.255.255.0
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 172.12.123.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.12.123.3 221
frame-relay map ip 172.12.123.1 221 broadcast
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router eigrp 100
network 2.2.2.2 0.0.0.0
network 172.12.23.0 0.0.0.255
network 172.12.123.0 0.0.0.255
no auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password CCNP
logging synchronous
login
!
!
end

R2#





R3




R3#show run
Building configuration...

Current configuration : 1369 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$9ppO$.Gpcpol/dOjLHJEKqMCHF1
!
no aaa new-model
!
resource policy
!
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
controller T1 0/0
framing sf
linecode ami
!
controller T1 0/1
framing sf
linecode ami
!
!
!
!
!
!
interface Loopback3
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 172.12.23.3 255.255.255.0
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/2
ip address 172.12.123.6 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.12.123.5 321 broadcast
frame-relay map ip 172.12.123.2 321
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Serial0/3
no ip address
shutdown
!
router eigrp 100
network 3.3.3.3 0.0.0.0
network 172.12.23.0 0.0.0.255
network 172.12.123.0 0.0.0.255
no auto-summary
!
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password CCNP
logging synchronous
login
!
!
end

R3#





SW1




SW1#show run
Building configuration...

Current configuration : 1434 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW1
!
enable secret 5 $1$9VI0$dSkRzCH75.XJFi7Y98.Ea1
!
no aaa new-model
ip subnet-zero
no ip domain-lookup
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 172.12.23.1 255.255.255.0
!
ip classless
ip http server
!
!
control-plane
!
!
line con 0
logging synchronous
line vty 0 3
password CCNP
login
line vty 4
password CCNP
logging synchronous
login
line vty 5 14
password CCNP
logging synchronous
login
line vty 15
no login
!
!
end

SW1#

Comments

  • Options
    ande0255ande0255 Banned Posts: 1,178
    Sure enough, I replaced the 3560 with a 2950 as the LAN switch in the topology, and no flapping links, anyone have an idea of default behaviors of the 3560 would cause the issue above?

    EDIT:

    Upon watching the behavior on all routers, I found that R2 is actually flapping the Fa0/0 link pretty quickly, but EIGRP is staying steady:


    [Resuming connection 2 to r2 ... ]

    *Mar 1 04:44:50.244: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    R2#
    *Mar 1 04:45:00.244: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
    R2#
    R2#
    R2#show ip int bri
    Interface IP-Address OK? Method Status Protocol
    FastEthernet0/0 172.12.23.2 YES NVRAM up down
    Serial0/0 172.12.123.2 YES NVRAM up up
    FastEthernet0/1 unassigned YES NVRAM administratively down down
    Serial0/1 unassigned YES NVRAM administratively down down
    Loopback2 2.2.2.2 YES NVRAM up up
    R2#
    *Mar 1 04:53:50.265: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    R2#
    *Mar 1 04:54:00.266: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
    R2#
    *Mar 1 04:54:10.266: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    R2#
    *Mar 1 04:54:20.266: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
    R2#
    *Mar 1 04:54:30.267: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    R2#
    *Mar 1 04:54:40.267: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
    R2#
    *Mar 1 04:54:50.268: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
  • Options
    stephanostephano Member Posts: 6 ■□□□□□□□□□
    3560 is L3 switch. Can you check that there is no ip route​ command on startup config?
  • Options
    stephanostephano Member Posts: 6 ■□□□□□□□□□
    stephano wrote: »
    3560 is L3 switch. Can you check that there is no ip route​ command on startup config?

    ​Proper command to find: ip routing
  • Options
    stephanostephano Member Posts: 6 ■□□□□□□□□□
    (Where the heck is edit button?)

    Found that one.

    On R2:

    interface FastEthernet0/0
    ip address 172.12.23.2 255.255.255.0
    shutdown
    duplex auto
    speed auto

    router eigrp 100
    network 2.2.2.2 0.0.0.0
    network 172.12.23.0 0.0.0.255
    network 172.12.123.0 0.0.0.255
    no auto-summary

    You can try with passive-interface fa0/0 eigrp router command on R2.
  • Options
    ande0255ande0255 Banned Posts: 1,178
    Funny enough, I just watched the next video in the series which was about Passive interfaces, and different methods to turning off unnecessary Hellos on the network, and looked at this thread and I believe you are correct.

    I haven't sat down in front of the lab yet, but I'll try this with both the 2950 and the 3560 and let you know if you called it - Thanks for the input :) + Rep!!
  • Options
    ande0255ande0255 Banned Posts: 1,178
    Sorry for the delayed response, and the following huge lump of text. I still have just a 2950 in place on the LAN, I applied "passive-interface fa0/0" on each of the spokes advertising the network into AS 100, and still every 10 seconds it goes up and comes back down:


    R2(config-router)#passive-interface fa 0/0
    R2(config-router)#
    *Mar 1 04:42:40.131: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    R2(config-router)#
    *Mar 1 04:42:50.131: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
    R2(config-router)#exit
    R2(config)#
    *Mar 1 04:43:00.131: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    R2(config)#exit
    R2#deb
    *Mar 1 04:43:10.132: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down




    So I did a debug eigrp packet, and here is a sample of the output, in none of this can I find a clear message of what is causing the flapping:


    *Mar 1 04:43:50.133: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    *Mar 1 04:43:50.153: EIGRP: Enqueueing QUERY on Serial0/0 iidbQ un/rely 0/1 serno 38-38
    *Mar 1 04:43:50.157: EIGRP: Enqueueing QUERY on Serial0/0 nbr 172.12.123.1 iidbQ un/rely 0/0 peerQ un/rely 0/0 serno 38-38
    *Mar 1 04:43:50.157: EIGRP: Sending QUERY on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:50.157: AS 100, Flags 0x0, Seq 34/50 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 38-38
    *Mar 1 04:43:50.165: EIGRP: Received HELLO on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:50.169: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
    *Mar 1 04:43:50.202: EIGRP: Received ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:50.202: AS 100, Flags 0x0, Seq 0/34 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
    *Mar 1 04:43:50.206: EIGRP: Serial0/0 multicast flow blocking cleared
    R2#r 1 04:43:50.226: EIGRP: Received REPLY on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:50.226: AS 100, Flags 0x0, Seq 51/34 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    *Mar 1 04:43:50.230: EIGRP: Enqueueing ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:50.230: Ack seq 51 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:43:50.234: EIGRP: Sending ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:50.234: AS 100, Flags 0x0, Seq 0/51 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:43:50.242: EIGRP: Enqueueing UPDATE on Serial0/0 iidbQ un/rely 0/1 serno 39-39
    *Mar 1 04:43:50.246: EIGRP: Enqueueing UPDATE on Serial0/0 nbr 172.12.123.1 iidbQ un/rely 0/0 peerQ un/rely 0/0 serno 39-39
    *Mar 1 04:43:50.246: EIGRP: Sending UPDATE on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:50.246: AS 100, Flags 0x0, Seq 35/51 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 39-39
    *Mar 1 04:43:50.290: EIGRP: Received ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:50.290: AS 100, Flags 0x0, Seq 0/35 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
    *Mar 1 04:43:50.294: EIGRP: Serial0/0 multicast flow blocking cleared
    *Mar 1 04:43:50.310: EIGRP: Received UPDATE on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:50.310: AS 100, Flags 0x0, Seq 52/35 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    *Mar 1 04:43:50.314: EIGRP: Enqueueing ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:50.314: Ack seq 52 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:43:50.318: EIGRP: Sending ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:50.318: AS 100, Flags 0x0, Seq 0/52 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 1/0R2#
    R2#
    *Mar 1 04:43:52.605: EIGRP: Sending HELLO on Loopback2
    *Mar 1 04:43:52.605: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 04:43:52.605: EIGRP: Received HELLO on Loopback2 nbr 2.2.2.2
    *Mar 1 04:43:52.609: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
    *Mar 1 04:43:52.609: EIGRP: Packet from ourselves ignored
    R2#
    *Mar 1 04:43:54.973: EIGRP: Received HELLO on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:54.977: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    R2#
    *Mar 1 04:43:57.157: EIGRP: Sending HELLO on Loopback2
    *Mar 1 04:43:57.157: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 04:43:57.157: EIGRP: Received HELLO on Loopback2 nbr 2.2.2.2
    *Mar 1 04:43:57.161: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
    *Mar 1 04:43:57.161: EIGRP: Packet from ourselves ignored
    R2#
    *Mar 1 04:43:59.280: EIGRP: Received HELLO on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:43:59.284: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    *Mar 1 04:44:00.134: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
    *Mar 1 04:44:00.150: EIGRP: Enqueueing QUERY on Serial0/0 iidbQ un/rely 0/1 serno 40-40
    *Mar 1 04:44:00.154: EIGRP: Enqueueing QUERY on Serial0/0 nbr 172.12.123.1 iidbQ un/rely 0/0 peerQ un/rely 0/0 serno 40-40
    *Mar 1 04:44:00.154: EIGRP: Sending QUERY on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:00.154: AS 100, Flags 0x0, Seq 36/52 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 40-40
    *Mar 1 04:44:00.198: EIGRP: Received ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:00.198: AS 100, Flags 0x0, Seq 0/36 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
    *Mar 1 04:44:00.202: EIGRP: Serial0/0 multicast flow blocking cleared
    *Mar 1 04:44:00.230: EIGRP: Received REPLY on Serial0/0 nbr 172.12.123.
    R2#1
    *Mar 1 04:44:00.230: AS 100, Flags 0x0, Seq 54/36 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    *Mar 1 04:44:00.230: EIGRP: Enqueueing ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:00.234: Ack seq 54 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:44:00.234: EIGRP: Sending ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:00.234: AS 100, Flags 0x0, Seq 0/54 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:44:00.246: EIGRP: Enqueueing UPDATE on Serial0/0 iidbQ un/rely 0/1 serno 41-41
    *Mar 1 04:44:00.250: EIGRP: Enqueueing UPDATE on Serial0/0 nbr 172.12.123.1 iidbQ un/rely 0/0 peerQ un/rely 0/0 serno 41-41
    *Mar 1 04:44:00.250: EIGRP: Serial0/0 multicast flow blocking cleared
    *Mar 1 04:44:00.278: EIGRP: Received UPDATE on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:00.278: AS 100, Flags 0x0, Seq 56/36 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    *Mar 1 04:44:00.282: EIGRP: Enqueueing ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:00.282: Ack seq 56 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:44:00.286: EIGRP: Sending ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:00.286: AS 100, Flags 0x0, Seq 0/56 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:44:01.600: EIGRP: Sending HELLO on Loopback2
    *Mar 1 04:44:01.600: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 04:44:01.600: EIGRP: Received HELLO on Loopback2 nbr 2.2.2.2
    *Mar 1 04:44:01.604: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
    *Mar 1 04:44:01.604: EIGRP: Packet from ourselves ignored
    R2#
    R2#
    *Mar 1 04:44:03.788: EIGRP: Received HELLO on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:03.792: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    R2#
    *Mar 1 04:44:06.316: EIGRP: Sending HELLO on Loopback2
    *Mar 1 04:44:06.316: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 04:44:06.316: EIGRP: Received HELLO on Loopback2 nbr 2.2.2.2
    *Mar 1 04:44:06.320: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
    *Mar 1 04:44:06.320: EIGRP: Packet from ourselves ignored
    R2#
    *Mar 1 04:44:08.596: EIGRP: Received HELLO on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:08.600: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    R2#
    *Mar 1 04:44:10.134: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
    *Mar 1 04:44:10.154: EIGRP: Enqueueing QUERY on Serial0/0 iidbQ un/rely 0/1 serno 42-42
    *Mar 1 04:44:10.158: EIGRP: Enqueueing QUERY on Serial0/0 nbr 172.12.123.1 iidbQ un/rely 0/0 peerQ un/rely 0/0 serno 42-42
    *Mar 1 04:44:10.158: EIGRP: Sending QUERY on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:10.158: AS 100, Flags 0x0, Seq 38/56 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 42-42
    *Mar 1 04:44:10.202: EIGRP: Received ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:10.202: AS 100, Flags 0x0, Seq 0/38 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
    *Mar 1 04:44:10.206: EIGRP: Serial0/0 multicast flow blocking cleared
    *Mar 1 04:44:10.226: EIGRP: Received REPLY on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:10.226: AS 100, Flags 0x0, Seq 57/38 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    *Mar 1 04:44:10.230: EIGRP: Enqueueing ACK on Serial0/0 nbr 172.12.123.
    R2#1
    *Mar 1 04:44:10.230: Ack seq 57 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:44:10.234: EIGRP: Sending ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:10.234: AS 100, Flags 0x0, Seq 0/57 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:44:10.242: EIGRP: Enqueueing UPDATE on Serial0/0 iidbQ un/rely 0/1 serno 43-43
    *Mar 1 04:44:10.246: EIGRP: Enqueueing UPDATE on Serial0/0 nbr 172.12.123.1 iidbQ un/rely 0/0 peerQ un/rely 0/0 serno 43-43
    *Mar 1 04:44:10.246: EIGRP: Sending UPDATE on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:10.246: AS 100, Flags 0x0, Seq 39/57 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 43-43
    *Mar 1 04:44:10.290: EIGRP: Received ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:10.290: AS 100, Flags 0x0, Seq 0/39 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
    *Mar 1 04:44:10.294: EIGRP: Serial0/0 multicast flow blocking cleared
    *Mar 1 04:44:10.310: EIGRP: Received UPDATE on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:10.314: AS 100, Flags 0x0, Seq 58/39 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    *Mar 1 04:44:10.314: EIGRP: Enqueueing ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:10.314: Ack seq 58 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:44:10.318: EIGRP: Sending ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:10.318: AS 100, Flags 0x0, Seq 0/58 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:44:11.252: EIGRP: Sending HELLO on Loopback2
    *Mar 1 04:44:11.252: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 04:44:11.252: EIGRP: Received HELLO on Loopback2 nbr 2.2.2.2
    *Mar 1 04:44:11.256: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
    *Mar 1 04:44:11.256: EIGRP: Packet from ourselves ignored
    R2#
    R2#
    *Mar 1 04:44:13.504: EIGRP: Received HELLO on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:13.508: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    R2#
    *Mar 1 04:44:15.964: EIGRP: Sending HELLO on Loopback2
    *Mar 1 04:44:15.964: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 04:44:15.964: EIGRP: Received HELLO on Loopback2 nbr 2.2.2.2
    *Mar 1 04:44:15.968: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
    *Mar 1 04:44:15.968: EIGRP: Packet from ourselves ignored
    R2#
    *Mar 1 04:44:18.111: EIGRP: Received HELLO on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:18.115: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    R2#
    *Mar 1 04:44:20.135: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down
    *Mar 1 04:44:20.151: EIGRP: Enqueueing QUERY on Serial0/0 iidbQ un/rely 0/1 serno 44-44
    *Mar 1 04:44:20.155: EIGRP: Enqueueing QUERY on Serial0/0 nbr 172.12.123.1 iidbQ un/rely 0/0 peerQ un/rely 0/0 serno 44-44
    *Mar 1 04:44:20.155: EIGRP: Sending QUERY on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:20.155: AS 100, Flags 0x0, Seq 40/58 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1 serno 44-44
    *Mar 1 04:44:20.199: EIGRP: Received ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:20.199: AS 100, Flags 0x0, Seq 0/40 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/1
    *Mar 1 04:44:20.203: EIGRP: Serial0/0 multicast flow blocking cleared
    *Mar 1 04:44:20.231: EIGRP: Received REPLY on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:20.231: AS 100, Flags 0x0, Seq 60/40 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    *Mar 1 04:44:20.235: EIGRP: Enqueueing ACK on Serial0/0 nbr 172.12.12
    R2#3.1
    *Mar 1 04:44:20.235: Ack seq 60 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:44:20.235: EIGRP: Sending ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:20.239: AS 100, Flags 0x0, Seq 0/60 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:44:20.247: EIGRP: Enqueueing UPDATE on Serial0/0 iidbQ un/rely 0/1 serno 45-45
    *Mar 1 04:44:20.251: EIGRP: Enqueueing UPDATE on Serial0/0 nbr 172.12.123.1 iidbQ un/rely 0/0 peerQ un/rely 0/0 serno 45-45
    *Mar 1 04:44:20.251: EIGRP: Serial0/0 multicast flow blocking cleared
    *Mar 1 04:44:20.279: EIGRP: Received UPDATE on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:20.279: AS 100, Flags 0x0, Seq 62/40 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    *Mar 1 04:44:20.283: EIGRP: Enqueueing ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:20.283: Ack seq 62 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:44:20.287: EIGRP: Sending ACK on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:20.287: AS 100, Flags 0x0, Seq 0/62 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 1/0
    *Mar 1 04:44:20.595: EIGRP: Sending HELLO on Loopback2
    *Mar 1 04:44:20.595: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 04:44:20.595: EIGRP: Received HELLO on Loopback2 nbr 2.2.2.2
    *Mar 1 04:44:20.599: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
    *Mar 1 04:44:20.599: EIGRP: Packet from ourselves ignored
    R2#
    R2#
    *Mar 1 04:44:22.919: EIGRP: Received HELLO on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:22.923: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    R2#
    *Mar 1 04:44:25.015: EIGRP: Sending HELLO on Loopback2
    *Mar 1 04:44:25.015: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 04:44:25.015: EIGRP: Received HELLO on Loopback2 nbr 2.2.2.2
    *Mar 1 04:44:25.019: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
    *Mar 1 04:44:25.019: EIGRP: Packet from ourselves ignored
    *Mar 1 04:44:25.804: EIGRP: Sending HELLO on Serial0/0
    *Mar 1 04:44:25.804: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    R2#
    *Mar 1 04:44:27.715: EIGRP: Received HELLO on Serial0/0 nbr 172.12.123.1
    *Mar 1 04:44:27.719: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
    R2#
    *Mar 1 04:44:29.951: EIGRP: Sending HELLO on Loopback2
    *Mar 1 04:44:29.951: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
    *Mar 1 04:44:29.951: EIGRP: Received HELLO on Loopback2 nbr 2.2.2.2
    *Mar 1 04:44:29.955: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0
    *Mar 1 04:44:29.955: EIGRP: Packet from ourselves ignored







    Sorry for that wall of text, does anyone see in there what could be causing the issue? Both sides LAN interface is passive, so it is something about the HUB that seems to be causing this chaos but I cannot see what message between drops are pointing to anything, going back over my interface a protocol configs now to see if I goofed somewhere.

    Any input or theories appreciated!
  • Options
    ande0255ande0255 Banned Posts: 1,178
    After tearing my hair out looking at K weights and timers and networks and such, I finally looked down at the physical rack itself and noticed three lights on the Fa0/0 port were blinking together every 3-5 seconds, which to me blinking lights means a bad port / card. So switched the configuration over to Fa0/1 along with moving cables and:

    R2#
    *Mar 1 05:17:43.471: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.23.3 (FastEthernet0/1) is up: new adjacency
    R2#
    *Mar 1 05:18:44.975: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.1 (Serial0/0) is down: retry limit exceeded
    *Mar 1 05:18:45.088: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 100: Neighbor 172.12.123.1 (Serial0/0) is up: new adjacency


    Oddly the serial link dropped approx 60 seconds after the Fa0/1 interface finally formed an Adjacency, which is the Serials Hello time, but never dropped and came back up again. No interfaces are currently passive, going to make my rounds to R1 and R3 and see if I sprung any more leaks anywhere else in the EIGRP network.

    However, this may in fact have all been caused by a bad interface card / port, and that is why I love physical labbing :)


    GAH!

    So the R1 (Hub) started freaking out with the S0/0.13 interface again, so I put passive-interface on both spoke routers on their LAN interface segments, and this seemed to do the trick.

    I was so caught up in those two becoming neighbors and forming an adjacency over the LAN, I forgot I am working with a Hub and Spoke network where all communication should go through R1 (The hub) and not over the LAN even if that may be faster.

    At least, for now...
Sign In or Register to comment.