DHCP not working on WDS?

Robbo777Robbo777 Member Posts: 331 ■■■□□□□□□□
My WDS client is not getting a DHCP address from my 192.168.0.0 /24 scope i have on my DHCP server. Everything is configured fine as far as WDS and DHCP is concerned. I cant see the reason as to why its not working. The WDS client is a Hyper-V machine and is configured to obtain an address via DHCP through the legacy adapter (like i said, everything is set up fine).

Every machine is on the same subnet whether its domain joined or non domain joined and the DHCP works because it has 2 leases at the moment which are 2 non domain joined phones in my house as. So it works, but the hyper-v machine that i'm trying to configure as a PXE client is still not picking up anything from the DHCP server. I'm not sure now why it is doing this. It just hangs on the DHCP part, on my DHCP server though it seems to give out a lease to the Hyper-V machine because when i refresh the lease screen the MAC address is on the leases and has an address but it still hangs on the DHCP screen and doesn't do anything else.
Very confusing and frustrating.

I have screenshot of a wireshark capture from the interface as seen in the attached picture, it seems to get an address from the DHCP server on the domain controller (192.168.0.150) which is configured as one but the DHCP that's automatic on my router (192.168.0.1)seems to be sending one as well, something is making it conflicted by the looks of it, i cant seem to spot the problem? Would it be worth disabling the DHCP on the router?


Comments

  • DojiscalperDojiscalper Member Posts: 266 ■■□□□□□□□□
    Normally you should only have one DHCP server handing out addresses, etc. You can have a several, but you have to configure it properly. For the sake of your learning I'd disable DHCP on any routers, modems you have at your place and use your 2012 server to simplify everything. I got WDS working awhile back, but it was a little tricky getting everything configured, there's a few check boxes hidden in the DHCP set up that must be set correctly.
Sign In or Register to comment.