Options

OSPF / EIGRP Redistribute Question

nigelchargernigelcharger Member Posts: 5 ■□□□□□□□□□
Hello all. I am working on a Lab and need some help.

c5cc68_c58a6bbe1bf54400a5d66687b935c09a~mv1.png

R3 has fully functional OSPF behind it.
R4 has fully functional EIGRP behind it
Connected to each other on S0/0/0. Network 10.0.0.0/30

According to the lab, I have the following constraints:
R3 S0/0/0 must not use OSPF
R4 S0/0/0 must not use EIGRP
R3 and R4 notify each other of networks behind them (not manually).

Admittedly I do not know much about OSPF or EIGRP redistribution.

=====R3=====
router ospf 1 router-id 3.3.3.3
log-adjacency-changes
area 3 authentication message-digest
network 192.168.23.0 0.0.0.3 area 3
default-information originate

=====R4=====

router eigrp 1
passive-interface default
no passive-interface Serial0/0/0
no passive-interface Serial0/0/1
no passive-interface Serial0/1/0
network 10.0.0.0 0.0.0.3
network 192.168.120.0 0.0.0.3
network 192.168.230.0 0.0.0.3
network 209.165.200.224 0.0.0.3
network 192.168.200.0
no auto-summary


Any help you can provide would be greatly appreciated.

Comments

  • Options
    theodoxatheodoxa Member Posts: 1,340 ■■■■□□□□□□
    It looks like they are asking you to use another protocol (e.g. BGP or RIP) between R3 and R4. You could redistribute both EIGRP and OSPF into this 3rd protocol and then redistribute from that protocol into EIGRP and OSPF. Since there appears to be only one connection between the two domains (EIGRP and OSPF), it is simply a matter of implementing a different routing protocol on the connection between R3 and R4 and then configuring the redistribute commands with appropriate options (e.g. OSPF needs the subnets option and EIGRP requires a metric to be specified) on R3 and R4.

    For example, using RIP between R3 and R4...

    R3 -- Redistribute OSPF into RIP (redistribute ospf 1 metric 1 subnets), Redistribute RIP into OSPF (redistribute rip metric 1)
    R4 -- Redistribute EIGRP into RIP (redistribute eigrp 10 metric 1), Redistribute RIP into EIGRP (redistribute rip metric 1544 100 255 1 1500)
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
  • Options
    DCDDCD Member Posts: 473 ■■■■□□□□□□
    Either add eigrp to router 3 or ospf to router 4 then redistribute into the protocol of choice.
  • Options
    nigelchargernigelcharger Member Posts: 5 ■□□□□□□□□□
    theodoxa wrote: »
    It looks like they are asking you to use another protocol (e.g. BGP or RIP) between R3 and R4.

    That is something I did not even think about. But it certainly would work and be within the parameters that were given. I will give it a try and see what happens.

    Just to make sure I understand how the redistribute works. R3 would have OSPF and RIP. OSPF is on s0/0/1 and RIP on s0/0/0. R3 will then "redistribute" OSPF info to RIP, and RIP info into OSPF. Therefore all the other OSPF routers (R1 and R2) will also learn about the networks on the other side of the RIP.

    Is that correct? Like I said, I'm going to give it a go now. Just want to make sure I understand correctly. Thanks for the help.
  • Options
    nigelchargernigelcharger Member Posts: 5 ■□□□□□□□□□
    So. I configured the way recommended by theodoxa. Now RIP is working between R3 and R4. RIP has learned about the OSPF networks but not the EIGRP networks. Also, it appears that OSPF nor EIGRP has learned about the RIP network.

    =====R3=====
    router ospf 1
    router-id 3.3.3.3
    log-adjacency-changes
    area 3 authentication message-digest
    redistribute rip metric 1
    passive-interface default
    no passive-interface Serial0/0/1
    network 192.168.23.0 0.0.0.3 area 3
    network 192.168.5.0 0.0.0.255 area 3
    network 192.168.4.0 0.0.0.255 area 3
    default-information originate
    !
    router rip
    version 2
    redistribute ospf 1 metric 1
    passive-interface default
    no passive-interface Serial0/0/0
    network 10.0.0.0
    no auto-summary

    =====R4=====

    router eigrp 1
    redistribute rip metric 1544 10 255 1 1500
    passive-interface default
    no passive-interface Serial0/0/1
    no passive-interface Serial0/1/0
    network 192.168.120.0 0.0.0.3
    network 192.168.230.0 0.0.0.3
    network 209.165.200.224 0.0.0.3
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 10 metric 1
    passive-interface default
    no passive-interface Serial0/0/0
    network 10.0.0.0
    no auto-summary
  • Options
    nigelchargernigelcharger Member Posts: 5 ■□□□□□□□□□
    I found an error in my commands. I changed R4 to "redistribute eigrp 1 metric 1" now RIP is learning about EIGRP. OSPF and EIGRP still not learning about RIP network.
  • Options
    nigelchargernigelcharger Member Posts: 5 ■□□□□□□□□□
    So, everything is working. What I mean by that is that everything is pinging across the RIP network. So my initial questions have been answered. Thank you again theodoxa.

    Now I'm left with another question though. Why is the routing table for RIP populating with EIGRP and OSPF networks, but not the other way around? Is this by design, or is my configuration still not quite right, even though it is functional?
  • Options
    DCDDCD Member Posts: 473 ■■■■□□□□□□
    My Bad I missed this
    According to the lab, I have the following constraints:
    R3 S0/0/0 must not use OSPF
    R4 S0/0/0 must not use EIGRP


    theodoxa is correct add another protocol between R3 and R4.
  • Options
    mistabrumley89mistabrumley89 Member Posts: 356 ■■■□□□□□□□
    I would have guessed default static routes icon_confused.gif:
    I think redistribution between routing protocols is outside of the scope of CCNA? Meh, to each his own.
    Goals: WGU BS: IT-Sec (DONE) | CCIE Written: In Progress
    LinkedIn: www.linkedin.com/in/charlesbrumley
  • Options
    theodoxatheodoxa Member Posts: 1,340 ■■■■□□□□□□
    =====R3=====
    router ospf 1
    router-id 3.3.3.3
    log-adjacency-changes
    area 3 authentication message-digest
    redistribute rip metric 1
    passive-interface default
    no passive-interface Serial0/0/1
    network 192.168.23.0 0.0.0.3 area 3
    network 192.168.5.0 0.0.0.255 area 3
    network 192.168.4.0 0.0.0.255 area 3
    default-information originate
    !
    router rip
    version 2
    redistribute ospf 1 metric 1 subnets
    passive-interface default
    no passive-interface Serial0/0/0
    network 10.0.0.0
    no auto-summary

    =====R4=====

    router eigrp 1
    redistribute rip metric 1544 10 255 1 1500
    passive-interface default
    no passive-interface Serial0/0/1
    no passive-interface Serial0/1/0
    network 192.168.120.0 0.0.0.3
    network 192.168.230.0 0.0.0.3
    network 209.165.200.224 0.0.0.3
    no auto-summary
    !
    router rip
    version 2
    redistribute eigrp 1 metric 1
    passive-interface default
    no passive-interface Serial0/0/0
    network 10.0.0.0
    no auto-summary
    R&S: CCENT CCNA CCNP CCIE [ ]
    Security: CCNA [ ]
    Virtualization: VCA-DCV [ ]
  • Options
    james43026james43026 Member Posts: 303 ■■□□□□□□□□
    So, everything is working. What I mean by that is that everything is pinging across the RIP network. So my initial questions have been answered. Thank you again theodoxa.

    Now I'm left with another question though. Why is the routing table for RIP populating with EIGRP and OSPF networks, but not the other way around? Is this by design, or is my configuration still not quite right, even though it is functional?

    You aren't going to see the global RIB on router R3 show anything from EIGRP and vice versa for R4, because routes are only being redistributed into them from RIP.
Sign In or Register to comment.