cisco CF card issue

azaghulazaghul Member Posts: 569 ■■■■□□□□□□
Weird problem...just purchased 4 x 512MB cisco branded CF cards and managed to "almost brick" 2 x 2801's

Boot with the old flash/ios...fine...change the flash and the system drops to rommon and corrupts the EEPROM 'cookie' that holds the MAC, model, PCB serial, chassis serial, the 2801 boots to rommon with no way out

After a LOT of digging for info, finally recovered 1 system with a LOT of hex editing the 'cookie'

Format the flash under windows, copy an IOS to it, try again...same problem...corrupted 'cookie', same problem with a second CF card

First time I've ever had this happen, anybody run into similar? Best way to low level format & test the CF card or just **** them and cut my losses?


  • FritzGFritzG Member Posts: 29 ■□□□□□□□□□
    I would **** them and run.

    While my 28xx routers did not eat their cookies (thank goodness), I did have the same issue you had with a bunch of cards I purchased off of Amazon. I needed the extra memory to run IPv6 as the devices I bought came with minimal memory.

    I made sure to format to the correct type within Windows. Did all manner of formatting on multiple Cisco devices I had access to but in the end, none of that worked. I just "borrowed" some cards that worked in those other routers and used those instead.

    I was working on my CCNA at the time so I just assumed I was the problem. Apparently, I was not the problem. If you don't have the option of an alternate source for known working cards, you'll just have to keep trying different cards until you find ones that work. At this point it sounds like you are comfortable HEX editing your way back into functionality so only your time will be wasted.

    Finding usable CF cards on the open market seems to be a crap shoot at best so if I buy anything again, I would try to anticipate my needs and spec to that so I know it works when I get it (or I send the whole thing back). Good luck!
  • PristonPriston Member Posts: 999 ■■■■□□□□□□
    I wouldn't format flash with windows, I would format flash with the router.

    boot image via tftp or usb, format flash:, copy image via tftp or usb to flash:
    A.A.S. in Networking Technologies
    A+, Network+, CCNA
  • Legacy UserLegacy User Unregistered / Not Logged In Posts: 0 ■□□□□□□□□□
    I 2nd what Priston said. Formatting CF tends to be very device specific so its always best to format it within the machine you are working on.
  • FritzGFritzG Member Posts: 29 ■□□□□□□□□□
    That's what I believed to be true as well.

    Class B or C format made no difference (yes, tried the supposed correct Class format first and then the wrong one just in case). They just happen to be bad cards. It happens. icon_smile.gif
  • azaghulazaghul Member Posts: 569 ■■■■□□□□□□
    Unfortunately inserting the card is what causes the cookie to become corrupt and forces the device to rommon...and theres no option to format flash from rommon (that i can see)

    Have not tried booting from TFTP/USB with the suspect CF card installed and doing a format...thats the last option before cutting my least I can take a HEX **** of the cookie before starting as a fail-safe...I'm running SanDisk flash mostly on other devices without issue, so i'll stick with them...was not what I was expecting when doing a rack rebuild
  • Legacy UserLegacy User Unregistered / Not Logged In Posts: 0 ■□□□□□□□□□
    Took another look at your OP. So you boot off of the old CF and it works and once you insert the other one it crashed to Rommon? Yea the CF cards you just bought are probably bad. I personally like to use SanDisk CF never had any issues.
  • clarsonclarson Member Posts: 903 ■■■■□□□□□□
    from rommon tftp the ios to cf. it works good when using a 1841.
Sign In or Register to comment.