IPV6 on team interface

BodanelBodanel Posts: 214Member ■■■□□□□□□□
Hi guys

I'm having quite a bump here. I have set up networking and ipv4 works without issues. However if I set up ipv6 on the team interface ping works but I'm having 50-60% packet loss. Has anybody any ideea what I'm doing wrong ?

Comments

  • VeritiesVerities Posts: 1,162Member
    I'll bite...let's do the process of elimination:

    check the state of the team:

    Teamdctl myteam0 state

    ensure all interfaces are up on the team:

    nmcli con show

    If you'd like to post your output into the forums, it would probably make it easier for me to assist.

    Side note: I've experienced packet loss when having duplex and speed mismatch with a server to a switch connected to it, so you can try using ethtool on your team to see if your settings match up with the network equipment. This is under the assumption you're doing this in production.
  • BodanelBodanel Posts: 214Member ■■■□□□□□□□
    Actually was in my lab. Team was configured as activebackup but I didnt checked to see if both interfaces were up (but I think it should not matter since it was configured as activebackup). I'll post tomorrow the output since it's 11 pm here and I just got back from a football match.
  • BodanelBodanel Posts: 214Member ■■■□□□□□□□
    This morning every was fine. Same config, I've booted up the VM and ping was working. I'e tried with 1 slave disabled and it was working, like I suspected. I really dont know what happened.
  • VeritiesVerities Posts: 1,162Member
    Not sure what to tell you if you can't duplicate the issue. Next time you have the issue you can always try a tcpdump.
  • VeritiesVerities Posts: 1,162Member
    I did this lab for the RHCE a few times today and was thinking about what you mentioned. I don't think one of your team ports was up; they do have to both be brought up (regardless of team state) and the team has to be brought up or else you lose functionality.

    You most likely saw the team work without issues after you powered the VM back on since Network Manager brought up both ports and the team interface up on boot.

    Just a theory since you didn't share your full setup, but to me it makes sense.
  • BodanelBodanel Posts: 214Member ■■■□□□□□□□
    I use Fedora 24 as a desktop and virt-manager. INterfaces were the same time, same virtual network

    I've found the issue today but didnt had time to write. It seems the culprit is described very well at the link below - IPV6 dad.

    https://www.lisenet.com/2016/configure-aggregated-network-links-on-rhel-7-bonding-and-teaming/
  • VeritiesVerities Posts: 1,162Member
    Thanks, that's an interesting tidbit I have not ran into thus far. Modifying kernel parameters is something I don't like to do unless its for security purposes, but I'll keep this in mind if I run into it on the exam.
  • BodanelBodanel Posts: 214Member ■■■□□□□□□□
    This is why I think that labbing is the best method for learning.
  • varelgvarelg Posts: 790Banned
    I am with Verities on editing kernel parameters. I don't think the default DAD setting was assigned by chance.
    I am posioning the forums.
Sign In or Register to comment.