Switchport mode does not work
redgunner
Member Posts: 42 ■■□□□□□□□□
in CCNA & CCENT
Hello,
When I type switchport mode access into an interface on my L3 switch it does not add the line to the config?
Below is my config - Can any1 help me?
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
no ip routing
no ip domain-lookup
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
switchport mode access
!
interface FastEthernet0/1
switchport mode access
!
interface FastEthernet0/2
switchport mode access
!
interface FastEthernet0/3
switchport mode access
!
interface FastEthernet0/4
switchport mode access
!
interface FastEthernet0/5
switchport mode access
!
interface FastEthernet0/6
switchport mode access
!
interface FastEthernet0/7
switchport mode access
!
interface FastEthernet0/8
switchport mode access
!
interface FastEthernet0/9
switchport mode access
!
interface FastEthernet0/10
switchport mode access
!
interface FastEthernet0/11
switchport mode access
!
interface FastEthernet0/12
switchport mode access
!
interface FastEthernet0/13
switchport mode access
!
interface FastEthernet0/14
switchport mode access
!
interface FastEthernet0/15
switchport mode access
!
interface Vlan1
no ip address
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
banner exec $
***************************************************************
To create vlans use the command "vlan database" in exec mode
After creating all desired vlans use "exit" to apply the config
To view existing vlans use the command "show vlan-switch brief"
***************************************************************
$
!
!
!
end
When I type switchport mode access into an interface on my L3 switch it does not add the line to the config?
Below is my config - Can any1 help me?
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
no ip routing
no ip domain-lookup
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
switchport mode access
!
interface FastEthernet0/1
switchport mode access
!
interface FastEthernet0/2
switchport mode access
!
interface FastEthernet0/3
switchport mode access
!
interface FastEthernet0/4
switchport mode access
!
interface FastEthernet0/5
switchport mode access
!
interface FastEthernet0/6
switchport mode access
!
interface FastEthernet0/7
switchport mode access
!
interface FastEthernet0/8
switchport mode access
!
interface FastEthernet0/9
switchport mode access
!
interface FastEthernet0/10
switchport mode access
!
interface FastEthernet0/11
switchport mode access
!
interface FastEthernet0/12
switchport mode access
!
interface FastEthernet0/13
switchport mode access
!
interface FastEthernet0/14
switchport mode access
!
interface FastEthernet0/15
switchport mode access
!
interface Vlan1
no ip address
!
ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
banner exec $
***************************************************************
To create vlans use the command "vlan database" in exec mode
After creating all desired vlans use "exit" to apply the config
To view existing vlans use the command "show vlan-switch brief"
***************************************************************
$
!
!
!
end
Comments
-
OctalDump Member Posts: 1,722That conf looks fine. Every port is an access port.
What is the error (if any) you get?2017 Goals - Something Cisco, Something Linux, Agile PM -
rolando3321 Member Posts: 36 ■■□□□□□□□□Could you clarify what you are trying to accomplish?
Right now you have it so that the ports will only act as an access port. If you want a specific vlan to work for that port you need to add something like:
switchport access vlan 10 -
dontstop Member Posts: 579 ■■■■□□□□□□On which interface are you trying to apply this configuration?
-
redgunner Member Posts: 42 ■■□□□□□□□□Hi,
The above is my startup configuration and when I show running-config it shows
interface FastEthernet0/0
!
each interface is missing the switchport line -
networker050184 Mod Posts: 11,962 ModIts the default so doesn't show in the running config. This also doesn't look like an L3 switch. It looks like a router with an ethernet switching module installed.An expert is a man who has made all the mistakes which can be made.
-
redgunner Member Posts: 42 ■■□□□□□□□□I think you're right - I am trying to get a switch for GNS3 but I need to find a L3 Switch - I'll probably just delete this image and try find something else, it's proving to be a config nightmare