First Cisco Lab Setup

PPP123PPP123 Member Posts: 25 ■■□□□□□□□□
Setup my first Lab consisting of-

1x1841 Router
2x3550 Switches
2xPC

I have established a LAN and can ping each device from one another, but I cannot connect to WAN.

My Router is directly connected to the ISP modem.

When typing "sh ip route" it gives me the message Gateway of Last resort not set.

I have set the default gateway on both computers and on the router.

Fastethernet 0/1 has IP address 192.168.1.1 and is connect to one of the switches
Fastethernet 0/0 has no IP address and is connected to the modem.

Do I need to set another IP address for the Fastethernet 0/0?

Comments

  • MAC_AddyMAC_Addy Member Posts: 1,740 ■■■■□□□□□□
    Have you setup NAT on the router?
    2017 Certification Goals:
    CCNP R/S
  • clarsonclarson Member Posts: 903 ■■■■□□□□□□
    http://www.techexams.net/forums/ccnp/121327-replace-home-router-cisco-device.html
    this will get you started

    lots of threads about this, so do some searching.

    there are youtube videos also, so do some googling
  • PPP123PPP123 Member Posts: 25 ■■□□□□□□□□
    I thought NAT would be automatic.

    Thanks for pointing me in the right direction, I've been googling in the wrong direction :)
  • PPP123PPP123 Member Posts: 25 ■■□□□□□□□□
    Can't configure DHCP on My ISP side interface. IP address shows as unassigned, method is showing DHCP when I "sh ip int brief"
    I've checked the cable with a cable certifier and everything is ok, no shorts etc
    Any ideas what's wrong?
  • HondabuffHondabuff Member Posts: 667 ■■■□□□□□□□
    PPP123 wrote: »
    Setup my first Lab consisting of-

    1x1841 Router
    2x3550 Switches
    2xPC

    I have established a LAN and can ping each device from one another, but I cannot connect to WAN.

    My Router is directly connected to the ISP modem.

    When typing "sh ip route" it gives me the message Gateway of Last resort not set.

    I have set the default gateway on both computers and on the router.

    Fastethernet 0/1 has IP address 192.168.1.1 and is connect to one of the switches
    Fastethernet 0/0 has no IP address and is connected to the modem.

    Do I need to set another IP address for the Fastethernet 0/0?


    It would be easy to just tell you how to fix it but then you will never learn. Time for some CBT Nuggets or CCNA OCG book. If you have to plan to certify or get into networking then I can whip up a quick config for you. Gateway of last resort is just the next hop that your 1841 is pointing to if the route is not in he routing table.
    “The problem with quotes on the Internet is that you can’t always be sure of their authenticity.” ~Abraham Lincoln
  • PPP123PPP123 Member Posts: 25 ■■□□□□□□□□
    I've looked at CBT nuggets video on NAT overload.

    The reason I put ISP side to DHCP was because I wasnt getting anywhere putting them in manually.

    *******Following Jeremy from CBT Nuggets he assigns 200.1.1.1/24 to fastethernet 0/1 ISP router side. What is this address?*****


    He then configures 200.1.1.32/24 (router ISP gateway) as the last resort.

    When I go down this road with my config I show to have 82.x.x.x (my public) in a different subnet from 192.168.1.1 on the interface through "sh ip route config"

    I believe the problem is the line I have highlighted above.
  • HondabuffHondabuff Member Posts: 667 ■■■□□□□□□□
    Something like this would be basic enough to get you going.

    Router#sho run Building configuration...


    Current configuration : 847 bytes
    !
    version 12.4
    no service timestamps log datetime msec
    no service timestamps debug datetime msec
    no service password-encryption
    !
    hostname Router
    !
    !
    !
    !
    !
    !
    !
    !
    ip cef
    no ipv6 cef
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    spanning-tree mode pvst
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
    description LAN INTERFACE FOR LAB
    ip address 10.0.0.1 255.255.255.0
    ip nat inside
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description WAN INTERFACE TO ISP MODEM
    ip address 192.168.1.254 255.255.255.0
    ip nat outside
    duplex auto
    speed auto
    !
    interface Vlan1
    no ip address
    shutdown
    !
    ip nat inside source list NAT interface FastEthernet0/1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    ip flow-export version 9
    !
    !
    ip access-list extended NAT
    permit ip 10.0.0.0 0.0.0.255 any
    !
    !
    !
    !
    !
    line con 0
    !
    line aux 0
    !
    line vty 0 4
    login
    !
    “The problem with quotes on the Internet is that you can’t always be sure of their authenticity.” ~Abraham Lincoln
  • PPP123PPP123 Member Posts: 25 ■■□□□□□□□□
    Thanks for the input, I have tried this config but it doesn't work for me unfortunately.

    Should the WAN interface not be your Public IP address given by the ISP?

    Mines is 82.30.x.x
    Default gateway 82.30.x.1
    Subnet mask 255.255.255.0 ???? /24 thought point to point was /30?


    So

    fastethernet 0/1 82.30.x.x 255.255.255.0 (outside)

    Fastethernet 0/0 192.168.1.1 255.255.255.0 (inside)

    Computer A IP A-192.168.1.51 SM 255.255.255.0 GW 192.168.1.1
    Computer B IP A-192.168.1.52. 255.255.255. 0 GW 192.168.1.1

    It's the WAN side I'm struggling with.
  • MAC_AddyMAC_Addy Member Posts: 1,740 ■■■■□□□□□□
    Not always. I typically set my outside interface (for my home network) for DHCP. Because that's typically what my consumer grade router would grab. Though, if you're being provided a static IP, then you can input it there.
    2017 Certification Goals:
    CCNP R/S
  • p@r0tuXusp@r0tuXus Member Posts: 532 ■■■■□□□□□□
    You need to apply DHCP to the port for your WAN link so that the Modem/Router from your ISP can designate an address to your router. Additionally, since it's only one link to your Modem/Router, you'll have to enable NAT Overload (PAT) so that your multiple links on the router can "Route" back to the Modem/Router from your ISP through the same port without conflict. Once you enable the NAT Overload and set your default routes on the router, you should be good to go... providing you don't have mis-assigned IPs/subnets for your ports dedicated to switches/PCs.
    Completed: ITIL-F, A+, S+, CCENT, CCNA R|S
    In Progress: Linux+/LPIC-1, Python, Bash
    Upcoming: eJPT, C|EH, CSA+, CCNA-Sec, PA-ACE
  • clarsonclarson Member Posts: 903 ■■■■□□□□□□
    Do you have a network diagram of what you are trying to do?
  • DCDDCD Member Posts: 473 ■■■■□□□□□□
    Do a "Show IP interface brief" also show the LAN configuration of the ISP modem. Also can you ping the DNS of you ISP from your router?
  • HondabuffHondabuff Member Posts: 667 ■■■□□□□□□□
    PPP123 wrote: »
    Thanks for the input, I have tried this config but it doesn't work for me unfortunately.

    Should the WAN interface not be your Public IP address given by the ISP?

    Mines is 82.30.x.x
    Default gateway 82.30.x.1
    Subnet mask 255.255.255.0 ???? /24 thought point to point was /30?


    So

    fastethernet 0/1 82.30.x.x 255.255.255.0 (outside)

    Fastethernet 0/0 192.168.1.1 255.255.255.0 (inside)

    Computer A IP A-192.168.1.51 SM 255.255.255.0 GW 192.168.1.1
    Computer B IP A-192.168.1.52. 255.255.255. 0 GW 192.168.1.1

    It's the WAN side I'm struggling with.

    You can set Fa0/1 to "ip address dhcp" and then default route 0.0.0.0 0.0.0.0 82.30.x.1
    Most residential ISP's will not allow static ip assignment on the wan. Might work for a few days until the lease expires. You can call your isp to confirm if you have a static ip or not. If you do have a static IP then the modem will need to be put into bridged mode and the 82.30 address assigned to Fa0/1 instead of dhcp.
    “The problem with quotes on the Internet is that you can’t always be sure of their authenticity.” ~Abraham Lincoln
  • p@r0tuXusp@r0tuXus Member Posts: 532 ■■■■□□□□□□
    Hondabuff wrote: »
    You can set Fa0/1 to "ip address dhcp" and then default route 0.0.0.0 0.0.0.0 82.30.x.1
    Most residential ISP's will not allow static ip assignment on the wan. Might work for a few days until the lease expires. You can call your isp to confirm if you have a static ip or not. If you do have a static IP then the modem will need to be put into bridged mode and the 82.30 address assigned to Fa0/1 instead of dhcp.

    Yes. Agreed. Most if not all ISPs will charge you extra for a static IP address, so you would probably know if you had a static IP or not.
    Completed: ITIL-F, A+, S+, CCENT, CCNA R|S
    In Progress: Linux+/LPIC-1, Python, Bash
    Upcoming: eJPT, C|EH, CSA+, CCNA-Sec, PA-ACE
  • PPP123PPP123 Member Posts: 25 ■■□□□□□□□□
    Yes that's correct it was a dynamic address, my mistake.

    I had mutiple devices configured with that address for sometime leading me to think it was static- although reason for this was it was given out by the same home router.

    This never fixed the problem however, DHCP still would'nt work.

    Eventually after exhausting all options turns out a simple reset on the modem got things up and running smoothly, I am now connected to the internet.

    I over complicated things and wasted hours of time icon_rolleyes.gif lol
  • Node ManNode Man Member Posts: 668 ■■■□□□□□□□
    One thing I wish i did earlier in my lab was buy a bunch of cheap Linksys routers and reflash them with OpenWRt or DDWRT. I have 3 of them now and I like to place them at different spots in my topology and set them up as nodes or simulate customer circuits across the network.

    A $5 Linksys with Open WRT router makes a very good end user node icon_smile.gif
Sign In or Register to comment.