RDS grace period problem

joeswfcjoeswfc Posts: 118Member ■■■□□□□□□□
Hi Everyone,

Strange issue with RDS grace period, wondered if anyone else has had this issue or can advise what to do...

We have an RDS server running windows server 2012 R2, it has been licenced and everything seems to work fine.
We had an issue with the grace period where we had to delete a registry key (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\RCM\GracePeriod) and then reboot the server. This fixed the issue.
120 days later, we had the same issue, this was resolved in the same way.

We have a few other RDS servers and they seem to work fine and don't get this issue.

Why does this keep happening although the server is licenced? And how can I resolve it permanently?

Thanks
Joe

Comments

  • poolmanjimpoolmanjim MCSE, MCSA: 2016, MCSA: 2012 KC, KS, USAPosts: 285Member ■■■□□□□□□□
    Full disclosure: My experience with RDS is limited.

    RDS is issuing licenses and has available licenses to issue? I would suggest that you may consider rebuilding the RDS database.
    2019 Goals: Security+
    2020 Goals: 70-744, Azure
    Completed: MCSA 2012 (01/2016), MCSE: Cloud Platform and Infrastructure (07/2017), MCSA 2017 (09/2017)
    Future Goals: CISSP, CCENT
  • joeswfcjoeswfc Posts: 118Member ■■■□□□□□□□
    thanks for your reply.

    Its a strange one, we also have the same issue in our DR environment that was recently built, but our UAT works fine.

    The only difference is that UAT has internet connectivity, but live and DR don't. So live and DR were activated over the phone, UAT was activated the usual way over the internet.

    Apart from that I can't see any other reason for this issue.
Sign In or Register to comment.