Installing SQL Server 2012 on Server 2012 R2 Info

AvgITGeekAvgITGeek 70-410, 70-411Member Posts: 342 ■■■■□□□□□□
As you all should know, .NET Framework 3.5.1 is required for SQL Server 2012. In Server 2012 R2 (I don't know about 2012) SQL Server will pass all of the requirement checks for .NET 3.5.1 because version 4 or 4.5 is installed by default on Server 2012 R2. Even though you get all green check marks, the SQL Server installation will crap out complaining that 3.5.1 can't be enabled.

To install 3.5.1 on Server 2012 R2 (This assumes you have your Server 2012 R2 installation media mounted as d)
The easiest way: open PowerShell as admin and type the following - dism /online /enable-feature /featurename:netfx3 /all /source:d:\sources\sxs

Or you could go through Add Roles and Features wizard, select the .NET 3.5 feature and then supply d:\sources\sxs as the source if it complains.

Just a heads up. Being that MS revised this exam to include SQL Server 2014 material, they may ask about installing SQL 2012 on Server 2012 and 2012 R2. I wouldn't put it past them.

Comments

  • greg9891greg9891 Member Posts: 1,183 ■■■■■■■□□□
    Thanks for the update! might come in handy.
    Certs Gained 2020: CCNA
    Upcoming:

    Proverbs 6:6-11Go to the ant, you sluggard! Consider her ways and be wise, Which, having no captain, Overseer or ruler, Provides her supplies in the summer, And gathers her food in the harvest. How long will you slumber, O sluggard?
    When will you rise from your sleep? A little sleep, a little slumber, A little folding of the hands to sleep, So shall your poverty come on you like a prowler And your need like an armed man.
  • ektorakosektorakos Member Posts: 47 ■■□□□□□□□□
    how do you run powershell from the command prompt if you are in core ?
  • AvgITGeekAvgITGeek 70-410, 70-411 Member Posts: 342 ■■■■□□□□□□
    By default it should run as administrator being you log in as administrator. In windows core, type powershell and hit enter. you should enter PS
  • ektorakosektorakos Member Posts: 47 ■■□□□□□□□□
    i cannot enter as administrator . only option is kim_akers or other.

    I succeeded the powershell command so now i am in
    PS C:\users\kim_akers\> and i type

    PS C:\users\kim_akers\> dism /online /enable-feature /featurename:netfx3 /all /source:d:\sources\sxs

    and of course i get error that the command is wrong or the path is incorrect.
    the cd is mounted in d.

    nothing works for me. i guess i am too nube for this
  • ektorakosektorakos Member Posts: 47 ■■□□□□□□□□
    oh wait it worked now that i tried again.

    i wander if this space before every slash is required " /" , or i was just spelling it wrongly before
  • AvgITGeekAvgITGeek 70-410, 70-411 Member Posts: 342 ■■■■□□□□□□
    Yes. The spaces are required as it separates the switches. You can run command prompt in powershell but you can't run powershell cmdlets in the command prompt. While in powershell "ipconfig" will still work.
  • AvgITGeekAvgITGeek 70-410, 70-411 Member Posts: 342 ■■■■□□□□□□
    Cool trick if you don't know. If you add your remote servers to server manager, you can install Roles and Features on those remote servers without touching them.

    And you will probably need to follow this when installing SQL Server 2014 on Server 2012 R2 as well. I haven't gotten to installing SQL Server 2014 yet.

    Oh ektorakos, we all started out as noobs. Don't give up, it can be frustrating but do not give up! :)
Sign In or Register to comment.