PPPoE configuration tip

wseyllerwseyller Posts: 44Member ■■■□□□□□□□
Thought I would share my experience this in case anyone else ran into this.

I was doing a PPPoE configuration lab.

I was first using GNS3 with two routers. I connected a cable between them initially on the fast ethernet ports before I did the configuration.

After doing the configuration the pppoe session would not show in the UP state. I did not receive an ip address on the client side.

I have some real equipment so I decided to do the configuration on two Cisco 1841 routers. The patch cable I had between the fast ethernet ports was a straight through type which normally works fine using auto-mdix.

After configuration it still didn't work for me and I noticed the line protocol was down and there were no lights on the ports. So I decided to make a crossover cable which did the trick.

I went back to my GNS3 config and what I had to do was delete the cable and re-add it. I'm guessing when I first added a cable it auto detected to use a straight through cable???

It seems PPPoE configuration on the real equipment requires a crossover cable even with newer equipment that has auto-mdix.

And in GNS3 possibly when you delete and re-add the cable it then detects that you need a crossover cable because of the PPPoE configuration???

Comments

  • alfred06alfred06 Posts: 96Member ■■□□□□□□□□
    strange. never had this issue with GNS3. I always do the cables first as well before turning them on and doing the configuration. never really paid attention to straight-cross over on GNS3 lab it always just work. is it just on the PPPoE configuration or on all the labs you do?
  • WastedHatWastedHat Posts: 132Member ■■■□□□□□□□
    wseyller wrote: »
    It seems PPPoE configuration on the real equipment requires a crossover cable even with newer equipment that has auto-mdix.

    Are you referring to GNS or physical here? I came accross this same problem when I was studying, I was certian my 1841's had auto-mdix from previous lab work and spent a while trying to pin point the issue. Eventually I made a cross-over cable and it worked.

    While I was searching I seen mixed feedback but the consensus of my results seemed to say that 1841's did not have auto-mdix.

    After the cable issue did your labs work as expected? I had a lot of temperaments with my PPPoE labs, sometimes they worked and sometimes they didn't with the exact same commands, done them over and over trying to figure out why. I think it had something to do with trying to configure CHAP authentication on an up/up interface but I'm still not entirely sure.
  • wseyllerwseyller Posts: 44Member ■■■□□□□□□□
    Once I made the crossover cables it works fine. It is only the PPPoE that barks about the cable.

    I then found in one of my study books that it explicitly mentions to make sure you use a crossover cable for the PPPoE lab.
  • ebohlmanebohlman Posts: 25Member ■□□□□□□□□□
    What likely happened here is that you were connecting a a desktop or laptop to your 1841. Auto-MDIX only requires one side of the connection to support it, and most desktop/laptop network interfaces built in the last 12 or so years do.

    AFAIK, 1841 FE ports don't support it, so you'll need crossover cables if you're connecting them together.
Sign In or Register to comment.