cant ping between SVI's on a Layer 3 switch

Welly_59Welly_59 Posts: 431Member
Using IOU image i have 4 hosts connected to the l3 switch, 2 in vlan10 and 2 in vlan20. I can ping between all hosts with no issues and the routes are in table etc so all seems correct.

What i cant do is ping between SVI's on the switch using extended pings. Also i cant ping the hosts from the switch. Am i being dumb here?
IOU1#sh runBuilding configuration...


Current configuration : 2080 bytes
!
! Last configuration change at 19:42:47 UTC Fri Apr 14 2017
!
version 15.6
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname IOU1
!
boot-start-marker
boot-end-marker
!
!
logging discriminator EXCESS severity drops 6 msg-body drops EXCESSCOLL
logging buffered 50000
logging console discriminator EXCESS
!
no aaa new-model
!
!
!
no ip icmp rate-limit unreachable
!
!
!
!
!
!
!
!
!
!
!




!
!
!
ip audit notify log
ip audit po max-events 100


no ip domain lookup
ip cef
no ipv6 cef
!
!
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip tcp synwait-time 5
!
!
!
!
interface Ethernet0/0
 switchport
 switchport access vlan 10
 duplex auto
!
interface Ethernet0/1
 switchport
 switchport access vlan 10
 duplex auto
!
interface Ethernet0/2
 switchport
 switchport access vlan 20
 duplex auto
!
interface Ethernet0/3
 switchport
 switchport access vlan 20
 duplex auto
!
interface Ethernet1/0
 switchport
 duplex auto
!
interface Ethernet1/1
 no ip address
 duplex auto
!
interface Ethernet1/2
 no ip address
 duplex auto
!
interface Ethernet1/3
 no ip address
 duplex auto
!
interface Ethernet2/0
 no ip address
 duplex auto
!
interface Ethernet2/1
 no ip address
 duplex auto
!
interface Ethernet2/2
 no ip address
 duplex auto
!
interface Ethernet2/3
 no ip address
 duplex auto
!
interface Ethernet3/0
 no ip address
 duplex auto
!
interface Ethernet3/1
 no ip address
 duplex auto
!
interface Ethernet3/2
 no ip address
 duplex auto
!
interface Ethernet3/3
 no ip address
 duplex auto
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
end



So pinging between vlans from the host devices works fine. Its just pinging from the switch that is not working in any direction - cant ping svi from svi, cant ping hosts from switch etc

EDIT:
Actually i can ping any devices on the default vlan - vlan 1 - but i cant ping other vlans from the switch

Comments

  • DCDDCD Posts: 449Member
    Did you enable IP routing? Didn't see it in the config.
  • Welly_59Welly_59 Posts: 431Member
    yes its enabled, otherwise i wouldnt have been able to ping between hosts on different vlans :)

    i think its gns3 being glitchy, as i have restarted and now i can ping all devices from the switch itself, but still cant ping the svi's from the switch itself.

    Should i be able to ping the svi's from the switch?
  • DCDDCD Posts: 449Member
    Yes you can. Can you do a Show IP interface brief and Show VLan.
  • Welly_59Welly_59 Posts: 431Member
    Also tried this in packet tracer with the same result - cant ping an svi from the switch itself
    IOU1#sh ip int br
    Interface              IP-Address      OK? Method Status                Protocol
    Ethernet0/0            unassigned      YES unset  up                    up
    Ethernet0/1            unassigned      YES unset  up                    up
    Ethernet0/2            unassigned      YES unset  up                    up
    Ethernet0/3            unassigned      YES unset  up                    up
    Ethernet1/0            unassigned      YES unset  up                    up
    Ethernet1/1            unassigned      YES unset  up                    up
    Ethernet1/2            unassigned      YES NVRAM  up                    up
    Ethernet1/3            unassigned      YES NVRAM  up                    up
    Ethernet2/0            unassigned      YES NVRAM  up                    up
    Ethernet2/1            unassigned      YES NVRAM  up                    up
    Ethernet2/2            unassigned      YES NVRAM  up                    up
    Ethernet2/3            unassigned      YES NVRAM  up                    up
    Ethernet3/0            unassigned      YES NVRAM  up                    up
    Ethernet3/1            unassigned      YES NVRAM  up                    up
    Ethernet3/2            unassigned      YES NVRAM  up                    up
    Ethernet3/3            unassigned      YES NVRAM  up                    up
    Vlan1                  192.168.1.1     YES NVRAM  up                    up
    Vlan10                 192.168.10.1    YES NVRAM  up                    up
    Vlan20                 192.168.20.1    YES NVRAM  up                    up
    
    VLAN Name                             Status    Ports
    ---- -------------------------------- --------- -------------------------------
    1    default                          active    Et1/0
    10   VLAN0010                         active    Et0/0, Et0/1
    20   VLAN0020                         active    Et0/2, Et0/3
    1002 fddi-default                     act/unsup
    1003 token-ring-default               act/unsup
    1004 fddinet-default                  act/unsup
    1005 trnet-default                    act/unsup
    
    
    VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
    ---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
    1    enet  100001     1500  -      -      -        -    -        0      0
    10   enet  100010     1500  -      -      -        -    -        0      0
    20   enet  100020     1500  -      -      -        -    -        0      0
    1002 fddi  101002     1500  -      -      -        -    -        0      0
    1003 tr    101003     1500  -      -      -        -    -        0      0
    1004 fdnet 101004     1500  -      -      -        ieee -        0      0
    1005 trnet 101005     1500  -      -      -        ibm  -        0      0
    
    
    Primary Secondary Type              Ports
    ------- --------- ----------------- ------------------------------------------
    
    
    
  • clarsonclarson Posts: 897Member ■■■■□□□□□□
    back to your basics.
    where does a network interface send network traffic.
    a) if it is on the same network it sends it to the other mac address.
    b) if it isn't on the same network it sends it to the default gateway.

    what do you have the default gateway set?
  • Welly_59Welly_59 Posts: 431Member
    Clarson it's a L3 switch with up routing enabled. Forgive me if I'm wrong but default-gateway is not used.
  • DCDDCD Posts: 449Member
    It maybe just a issue with IOU and packet tracer does have it issues. But I still would input the IP routing command in or high light it in the config because it missing in the original post. Which switch image are you using?
  • Welly_59Welly_59 Posts: 431Member
    DCD if IP routing wasnt working i wouldnt be able to ping between host devices in different vlans, so i know thats not the issue. I am using i86bi-linux-l2-adventerprisek9-15.6.0.9S

    Also what is weird is that from the switch i can ping the devices on the vlan but not the SVI IP itself
  • Welly_59Welly_59 Posts: 431Member
    ok its an IOU bug. If i do the same with i86bi-linux-l2-adventerprisek9-15.1a it works as expected - i can ping the svi ip from itself
Sign In or Register to comment.