subinterface question

RUN-DMCRUN-DMC Posts: 35Member ■■□□□□□□□□
Could someone explain or give a quick scenerio on how and when a subinterface should or could be implemented?

thanks1
«1

Comments

  • EdTheLadEdTheLad Posts: 2,112Member ■■■■□□□□□□
    OK, quick scenario for you!
    You have 3 routers connected in a hub and spoke environment.
    RouterB is the hub i.e. RouteA and RouterC are connected to RouterB but not to each other.
    The layer 2 protocol between your routers is FR and you need RIP to exchange routing updates.Without the subinterface RouterB cannot forward RouterAs updates to RouterC due to the split horizon rule.You could disable Split horizon on the int of RouterC but this could lead to problems with routing loops.The best implementation is to create 2 ptp subinterfaces on RouterC each with its own subnet.
    Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
  • lwwarnerlwwarner Posts: 147Member ■■■□□□□□□□
    The other use for subinterfaces in CCNA-land is, of course, inter-vlan routing (aka router-on-a-stick). More generally, you use subinterfaces anytime you want multiple logical interfaces on a single physical interface.
  • JNekoJNeko Posts: 32Member ■■□□□□□□□□
    OK, quick scenario for you!
    You have 3 routers connected in a hub and spoke environment.
    RouterB is the hub i.e. RouteA and RouterC are connected to RouterB but not to each other.
    The layer 2 protocol between your routers is FR and you need RIP to exchange routing updates.Without the subinterface RouterB cannot forward RouterAs updates to RouterC due to the split horizon rule.You could disable Split horizon on the int of RouterC but this could lead to problems with routing loops.The best implementation is to create 2 ptp subinterfaces on RouterC each with its own subnet.

    Old post sorry! Using Split horizon with frame relay seems to be something i can get right on a test, know the text definition, but I just can't explain, I am not 100% clear on this one.

    Okay, so you got three routers with one acting as a hub

    RouterA ---- RouterB ---- RouterC
    Without the subinterface RouterB cannot forward RouterAs updates to RouterC due to the split horizon rule

    Split horizon does not allow re-advertising of a route back through the interface which it was received on, yes? So, why would B not be able to forward A's updates to C? Router A will simply be sending an update through one interface of B and out a different exit interface of B, and not doing any back-tracking, so I would think split-horizon is not an issue here.

    Please tell me where I am misunderstanding, I really don't know why this is not clicking.

    Thanks
    A common type of network bridge, in which the host stations are unaware of their existence in the network.
  • mikej412mikej412 Posts: 10,090Member
    JNeko wrote:
    Okay, so you got three routers with one acting as a hub

    RouterA ---- RouterB ---- RouterC
    Without the subinterface RouterB cannot forward RouterAs updates to RouterC due to the split horizon rule

    Split horizon does not allow re-advertising of a route back through the interface which it was received on, yes? So, why would B not be able to forward A's updates to C? Router A will simply be sending an update through one interface of B and out a different exit interface of B, and not doing any back-tracking, so I would think split-horizon is not an issue here.
    With frame relay it will depend on how you configured the interfaces -- and you have lots of options. If you use sub-interfaces and point-to-connections -- then it works as you say.

    But a Hub and Spoke -- if the Hub is using the physical interface (which is multipoint) -- then the diagram should look like the picture in this thread http://www.techexams.net/forums/viewtopic.php?t=22962

    R1 is the hub -- and that's the single physical interface going into the frame-relay cloud. If an update comes in the physical interface from R2 -- it would be the same physical interface going out to R3. That's where split horizon could cause problems if its enabled.

    This makes a lot more sense when you work through some lab scenarios and work with the different interface types.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • markzabmarkzab Posts: 619Member
    mikej412 wrote:
    JNeko wrote:
    Okay, so you got three routers with one acting as a hub

    RouterA ---- RouterB ---- RouterC
    Without the subinterface RouterB cannot forward RouterAs updates to RouterC due to the split horizon rule

    Split horizon does not allow re-advertising of a route back through the interface which it was received on, yes? So, why would B not be able to forward A's updates to C? Router A will simply be sending an update through one interface of B and out a different exit interface of B, and not doing any back-tracking, so I would think split-horizon is not an issue here.
    With frame relay it will depend on how you configured the interfaces -- and you have lots of options. If you use sub-interfaces and point-to-connections -- then it works as you say.

    But a Hub and Spoke -- if the Hub is using the physical interface (which is multipoint) -- then the diagram should look like the picture in this thread http://www.techexams.net/forums/viewtopic.php?t=22962

    R1 is the hub -- and that's the single physical interface going into the frame-relay cloud. If an update comes in the physical interface from R2 -- it would be the same physical interface going out to R3. That's where split horizon could cause problems if its enabled.

    This makes a lot more sense when you work through some lab scenarios and work with the different interface types.

    Question: If my hub router has 2 serial interfaces and I connect one spoke to s0 and the other spoke to s1, then I won't have the issues you guys are discussing, right? I would be able to keep split horizon enabled because the hub is using 2 seperate interfaces?

    EDIT: And another question. How could I physically recreate the image in the other thread. What I mean is lets say I just want to use one interface to go out to both spokes and use subinterfaces. What type of cable would I use or in other words, how am I creating that frame cloud?

    EDIT 2: Scratch the 2nd question. I think I just answered it in my own head. Darby is sending me a 2521 4 serial frame switch. Would I use that switch to act as my cloud? Like would I have a 2610 act as a hub which only had 1 serial interface and connect that to the fr switch, and then my 2509 and 2612 to the other serial ports on the 2521?
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • mikej412mikej412 Posts: 10,090Member
    markzab wrote:
    Question: If my hub router has 2 serial interfaces and I connect one spoke to s0 and the other spoke to s1, then I won't have the issues you guys are discussing, right? I would be able to keep split horizon enabled because the hub is using 2 seperate interfaces?
    Then it isn't hub and spoke. Its just 2 separate frame relay clouds (even if its just one 4 or 10 serial port 252x router acting as a frame relay switch.
    markzab wrote:
    EDIT: And another question. How could I physically recreate the image in the other thread. What I mean is lets say I just want to use one interface to go out to both spokes and use subinterfaces. What type of cable would I use or in other words, how am I creating that frame cloud?

    Usually your frame cloud is a 4 or 10 port 252x router configured for frame-relay switching.
    I usually set the clock rate on the router acting as the frame relay switch... and you can use the same serial cables you use for your PPP connections -- the back-to-back serial cable with the DCE end attached to the "frame switch."

    There is a sample frame relay switch config in this thread http://www.techexams.net/forums/viewtopic.php?t=15568

    Its usually easier to configure the frame switch for for full mesh -- and you'd disable inverse arp when you configure your routers so that you can try hub and spoke and partial mesh configurations.
    :mike: Cisco Certifications -- Collect the Entire Set!
  • markzabmarkzab Posts: 619Member
    Thanks Mike.

    I got my 2nd router in the mail today so I just now decided to try and connect the 2. I didn't look at any labs or anything and just went off the top of my head. Obviously they aren't seeing each other. icon_lol.gif

    Here are the important pieces of what I configured. I think I'm forgetting something in regards to frame relay (DLCI issue?).

    2509 Router:

    interface Serial0
    ip address 192.168.30.2 255.255.255.252
    no ip directed-broadcast
    encapsulation frame-relay
    clockrate 64000
    frame-relay interface-dlci 32

    router rip
    version 2
    network 192.168.30.0

    2612 Router:

    interface Serial0/0
    ip address 192.168.30.1 255.255.255.252
    encapsulation frame-relay
    frame-relay interface-dlci 31

    router rip
    version 2
    network 192.168.10.0
    network 192.168.20.0
    network 192.168.30.0

    Ok, so what did I forget?
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • JNekoJNeko Posts: 32Member ■■□□□□□□□□
    Thanks myke for your quick reply. I do indeed think this would not be a problem if I had some gear with me for testing.
    R1 is the hub -- and that's the single physical interface going into the frame-relay cloud. If an update comes in the physical interface from R2 -- it would be the same physical interface going out to R3. That's where split horizon could cause problems if its enabled.

    This is referring to the image in http://www.techexams.net/forums/viewtopic.php?t=22962, correct? I just stared at this for like an hour...><, ok I think I just got it, let me see, for R1 to forward R2's update to R3, it's got to send it back out the way it came (it's own physical interface), causing split horizon problems, this FR cloud is like acting like a logical hub, whereas this problem would not be occuring with the topology I provided in my previous post (because of the two interfaces of RouterB are directly connected to A and C)

    Lets talk about what interfaces exactly to configure with subinterfaces, in the post http://www.techexams.net/forums/viewtopic.php?t=22962 R3 was only configured with subinterfaces right? I don't really understand the reasoning for this. R1 is the hub, correct? So all updates will be sent through it, so why would the subinterfaces be configured on R3 and not on R1? If R1 has pvcs to 2 and 3 it would be like a logical version of the the topology i presented in the previous post, and split horizon would not be a factor. what am i missing?

    thanks
    A common type of network bridge, in which the host stations are unaware of their existence in the network.
  • mikej412mikej412 Posts: 10,090Member
    With frame-relay "back-to-back without a frame relay switch" -- you don't have LMI... so disable it with the "no keepalive" command on the serial interfaces.

    And the other "back-to-back without a frame relay switch" trick to know -- use the same DLCI on both ends.

    Make sure the DCE end of the cable is on 2509 (based on your clocking)

    And then there is everyones favorite trick -- the "no shutdown" to enable the interface.

    Serial connections default to HDLC -- so you could just toss an IP Address on and see if you can ping..... Then you can do the "no shut" to enable the interface and ping again.

    Once you've got the basic connection working.... then you could try PPP or the "back-to-back without a frame relay switch"
    :mike: Cisco Certifications -- Collect the Entire Set!
  • markzabmarkzab Posts: 619Member
    Thanks guys. I didn't set the no keepalive command so I'll do that now.

    In regards to the matching DLCI's...do they HAVE TO be the same on back to back connections in FR?

    I could have done simple HDLC but it's not like I was doing a lab or anything, just having fun with FR. :)

    Lemme go see if I can get this working...
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • markzabmarkzab Posts: 619Member
    2509:

    interface Serial0
    ip address 192.168.30.2 255.255.255.252
    no ip directed-broadcast
    encapsulation frame-relay
    no keepalive
    clockrate 64000
    frame-relay interface-dlci 30

    2612:

    interface Serial0/0
    ip address 192.168.30.1 255.255.255.252
    encapsulation frame-relay
    no keepalive
    frame-relay interface-dlci 30


    Ok, weird. From the 2612 I can now ping 30.2 (2509) but I can't ping my own serial interface of 30.1. icon_confused.gif

    EDIT: WTF...same thing on the 2509. I can ping the other router but not it's own serial interface.
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • mikej412mikej412 Posts: 10,090Member
    markzab wrote:
    Ok, weird. From the 2612 I can now ping 30.2 (2509) but I can't ping my own serial interface of 30.1. icon_confused.gif

    EDIT: WTF...same thing on the 2509. I can ping the other router but not it's own serial interface.
    Wasn't there just another thead in the last couple of days about this (or including this)?

    I think Darby has it in the "extra credit config" at the end - "the twist"
    :mike: Cisco Certifications -- Collect the Entire Set!
  • markzabmarkzab Posts: 619Member
    mikej412 wrote:
    markzab wrote:
    Ok, weird. From the 2612 I can now ping 30.2 (2509) but I can't ping my own serial interface of 30.1. icon_confused.gif

    EDIT: WTF...same thing on the 2509. I can ping the other router but not it's own serial interface.
    Wasn't there just another thead in the last couple of days about this (or including this)?

    I think Darby has it in the "extra credit config" at the end - "the twist"

    Are you referring to the mappings?

    EDIT: His first config example doesn't have the mappings in it.
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • markzabmarkzab Posts: 619Member
    So you're saying I MUST map in frame relay? I know I don't know jack about frame at this point in my studies (so bear with me), but if I had to map every damn thing when using frame relay what the hell would be the point? I figured there would be some dynamics involved. Why the hell can't it just find everything for me? I'd have to map every damn route? Or am I mixing things up?

    In regards to pinging my own IP, I know there's no use to it but I'm just curious as to why I cant.

    I enabled CDP, or at least I think I did. I could have sworn the command was what you wrote but on my machines the enabling command is "cdp run".

    EDIT: show cdp ne gives me a blank table so my machines are pinging eachother...but not seeing eachother???
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • mikej412mikej412 Posts: 10,090Member
    JNeko wrote:
    what am i missing?
    Well - if you do it right, lots of sleep. icon_lol.gif

    I'm not sure where you're at in your study, or what you've done "hands on" -- with real hardware, Dynagen/Dynamips, or a Simulator (like Boson).

    Usually you'll start out with the full mesh frame relay and automatic layer 2 to layer 3 address resolution with inverse arp.

    In real life, that gets expensive -- so on to the hub and spoke configurations while you're learning frame relay.

    The various scenarios you'll go through learning Frame Relay at the CCNA, and then more advanced at the CCNP level, will be using the physical interface vs the sub-interfaces, broadcast support (or lack of broadcast support), mapping the layer 2 address to layer 3 address (automatic or manual), assigning DLCIs to interfaces or sub-interfaces when you don't need to map.... the multipoint vs point-to-point interfaces/issues etc.

    And then you need to work with the commands to verify and debug configurations.

    Then toss in the routing protocols and you get the DR/BDR OSPF issues, the Distance Vector Split-Horizon issues (and non-issues), etc.

    The CCNA books usually don't torture you as much as they could with frame-relay -- but they do want you know more then just one easy way to do it.

    That's where you spend some late nights getting some hands on practice with what your book is showing you -- and probably miss some sleep. :D
    :mike: Cisco Certifications -- Collect the Entire Set!
  • markzabmarkzab Posts: 619Member
    Mozel Tov! There we go...

    Miami-2612R#show cdp ne
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
    S - Switch, H - Host, I - IGMP, r - Repeater

    Device ID Local Intrfce Holdtme Capability Platform Port ID
    Miami-2509R Ser 0/0 160 R 2509 Ser 0
    Miami-2612R#

    :D

    I'm still pissed off that I can't ping my own interface. SO let me get this straight. Right now I have inverse ARP on which is doing the dlci30 to dlci30 dynamic mappings for me. With this happening it wont map my own interface hense me not being able to ping it. If I were to turn off inverse arp and map everything myself I would then be able to ping my own interface?

    And just wondering, mapping or not, I'd think that a machine with an ip on one of its interfaces would be able to ping it no matter what. I mean, its right there inside of it afterall.
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • markzabmarkzab Posts: 619Member
    Homework assignment:

    What protocols does CDP use?

    What are all the options associated with CDP?

    What are the security risks associated with CDP?

    Why does the ODR routing protocol rely on CDP?


    ====================================

    Hey you started, now I want answers...

    And "cdp en" IS exactly and explicitly what I meant - under the interface...

    Get those fingers to tapping - I need output to keep me awake...

    You remember I told you how back in the day (2000'ish) I used to work in the NOC at Unisys? Well CDP was my best friend there. I used to use it all the time because we were watching over so many different networks in the beginning CDP basically gave me everything I needed to know about where the hell everything was. Completely forgot about the interface enabling though.
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • markzabmarkzab Posts: 619Member
    Wait...problem...

    Miami-2509R#show cdp ne
    Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
    S - Switch, H - Host, I - IGMP, r - Repeater

    Device ID Local Intrfce Holdtme Capability Platform Port ID
    Miami-2612R Ser 0 134 R 2612 Ser 0/0

    I can also see the 2612 from the 2509 and I can ping the serial of the 2612 from the 2509, but I can't ping any of the other interfaces on the 2612 from the 2509.

    Eh, it's late. I guess this is what happens when you start playing with topics from the back of the book before you even start with the ones from the beginning. icon_lol.gif

    I've gotta get to sleep though. Gotta run to the office in the morning for a bit. I'm gonna leave everything the way it is right now and then hit it again tomorrow. I'll leave you with my full configs on both machines...

    2509:

    Current configuration:
    !
    version 12.0
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname Miami-2509R
    !
    enable secret 5 $1$oA.y$euDTXeLbtfPPHNUgHEn771
    enable password cisco
    !
    ip subnet-zero
    !
    !
    !
    interface Ethernet0
    no ip address
    no ip directed-broadcast
    shutdown
    !
    interface Serial0
    ip address 192.168.30.2 255.255.255.252
    no ip directed-broadcast
    encapsulation frame-relay
    no keepalive
    clockrate 64000
    cdp enable
    frame-relay interface-dlci 30
    !
    interface Serial1
    no ip address
    no ip directed-broadcast
    shutdown
    !
    router rip
    version 2
    network 192.168.30.0
    !
    ip classless
    !
    !
    line con 0
    exec-timeout 0 0
    password cisco
    logging synchronous
    login
    transport input none
    line 1 8
    password cisco
    login
    line aux 0
    password cisco
    login
    line vty 0 4
    password cisco
    login
    !
    end

    2612:

    Current configuration : 1104 bytes
    !
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Miami-2612R
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$1ZSH$RHj/bnQCSrcS0NdbudZOV/
    enable password cisco
    !
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    interface Ethernet0/0
    description LAN link to Sales
    ip address 192.168.10.1 255.255.255.0
    half-duplex
    !
    interface Serial0/0
    description WAN link to Miami2509
    ip address 192.168.30.1 255.255.255.252
    encapsulation frame-relay
    no keepalive
    cdp enable
    frame-relay interface-dlci 30
    !
    interface TokenRing0/0
    description TR LAN link to Hell
    ip address 192.168.20.1 255.255.255.252
    shutdown
    ring-speed 4
    !
    router rip
    version 2
    network 192.168.10.0
    network 192.168.20.0
    network 192.168.30.0
    !
    ip http server
    ip classless
    !
    !
    banner login ^C Welcome to Miami-2612R ^C
    banner motd ^C I'd rather be fishing. ^C icon_lol.gif
    !
    line con 0
    exec-timeout 0 0
    password cisco
    logging synchronous
    login
    line aux 0
    password cisco
    login
    line vty 0 4
    password cisco
    login
    line vty 5 15
    password cisco
    login
    !
    !
    end
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • markzabmarkzab Posts: 619Member
    Nah, I shut that one down because I'd keep getting those damn TR init/lobe/fail messages. That's not it though because I can't ping 10.1 ethernet either.

    Man, I need to sleep. Ok, for sure though, I'm done now. icon_lol.gif
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • markzabmarkzab Posts: 619Member
    Miami-2509R#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
    i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
    U - per-user static route, o - ODR

    Gateway of last resort is not set

    192.168.30.0/30 is subnetted, 1 subnets
    C 192.168.30.0 is directly connected, Serial0



    2509 is not seeing the ethernet or TR on the 2612.

    Man, we gotta start these things earlier on in the night for now on.
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • markzabmarkzab Posts: 619Member
    Ok, for real though this time, gotta hit the sack...

    I'm turning...the computer...off...




    I'm serious...



    No really...



    Going to bed...



    Right now...



    icon_lol.gif
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • JNekoJNeko Posts: 32Member ■■□□□□□□□□
    mikej412 wrote:
    JNeko wrote:
    what am i missing?
    Well - if you do it right, lots of sleep. icon_lol.gif

    I'm not sure where you're at in your study, or what you've done "hands on" -- with real hardware, Dynagen/Dynamips, or a Simulator (like Boson).
    Hi Mike,

    Hee hee, I can't deny it, I went to bed last night thinking only of FR and split horizon. I don't mind beating my head against the wall, I have already done so many times throughout the studies, but when you finally get it at the end of the day it just feels that much better. Plus I enjoy this! As far as my studies go, I am still a novice at best, have not studied for three months, but I have read a Cybex book through twice and feel like i have a good base. I also took a few practice CCNA tests and did surprisingly well on them. I am no position to work with equipment yet (not until next Fall) but I practice command string input on a sim. It's just sometimes a process won't make too much logical sense in my head for some reason or another and I have to ask questions to make it right.

    Excuse me for me being persistant, but could you please explain the reasoning behind choosing R3 for having subinterfaces instead of the other routers in the diagram found in http://www.techexams.net/forums/viewtopic.php?t=22962 ? Is there a reason?

    Thanks so much for being patient with me. ><
    A common type of network bridge, in which the host stations are unaware of their existence in the network.
  • mikej412mikej412 Posts: 10,090Member
    JNeko wrote:
    Excuse me for me being persistant, but could you please explain the reasoning behind choosing R3 for having subinterfaces instead of the other routers in the diagram found in http://www.techexams.net/forums/viewtopic.php?t=22962 ? Is there a reason?

    icon_lol.gif
    ignign0kt wrote:
    He said that he configured th R3 serial interface as a point-to-point interface for the sake of showing how to configure it...

    When you're learning, people suggest things to do -- usually so that you hit a problem and then learn something when you fix it, or to get you to learn another way of doing things and learn some specific points -- like the ones Darby mentioned.

    Since this doesn't look like a "real world problem" -- the real answer probably is "because the teacher said so"
    :mike: Cisco Certifications -- Collect the Entire Set!
  • markzabmarkzab Posts: 619Member
    mikej412 wrote:
    JNeko wrote:
    Excuse me for me being persistant, but could you please explain the reasoning behind choosing R3 for having subinterfaces instead of the other routers in the diagram found in http://www.techexams.net/forums/viewtopic.php?t=22962 ? Is there a reason?

    icon_lol.gif
    ignign0kt wrote:
    He said that he configured th R3 serial interface as a point-to-point interface for the sake of showing how to configure it...

    When you're learning, people suggest things to do -- usually so that you hit a problem and then learn something when you fix it, or to get you to learn another way of doing things and learn some specific points -- like the ones Darby mentioned.

    Since this doesn't look like a "real world problem" -- the real answer probably is "because the teacher said so"

    Quoted fror truth.

    Hell, I didn't expect to have a homework assignment to do today...

    "The Origins of CDP" an essay by Mark Z.

    I'll be done by the end of the day Professor Weaver. icon_lol.gif
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • iprouteiproute Posts: 269Member
    markzab wrote:
    mikej412 wrote:
    JNeko wrote:
    Excuse me for me being persistant, but could you please explain the reasoning behind choosing R3 for having subinterfaces instead of the other routers in the diagram found in http://www.techexams.net/forums/viewtopic.php?t=22962 ? Is there a reason?

    icon_lol.gif
    ignign0kt wrote:
    He said that he configured th R3 serial interface as a point-to-point interface for the sake of showing how to configure it...

    When you're learning, people suggest things to do -- usually so that you hit a problem and then learn something when you fix it, or to get you to learn another way of doing things and learn some specific points -- like the ones Darby mentioned.

    Since this doesn't look like a "real world problem" -- the real answer probably is "because the teacher said so"

    Quoted fror truth.

    Hell, I didn't expect to have a homework assignment to do today...

    "The Origins of CDP" an essay by Mark Z.

    I'll be done by the end of the day Professor Weaver. icon_lol.gif
    Dude, let's submit the same paper and see if Professor W even notices. You can email it to me icon_wink.gif
    CCNP Progress
    ROUTE [X] :: SWITCH [X] :: TSHOOT [X]
  • markzabmarkzab Posts: 619Member
    iproute wrote:
    markzab wrote:
    mikej412 wrote:
    JNeko wrote:
    Excuse me for me being persistant, but could you please explain the reasoning behind choosing R3 for having subinterfaces instead of the other routers in the diagram found in http://www.techexams.net/forums/viewtopic.php?t=22962 ? Is there a reason?

    icon_lol.gif
    ignign0kt wrote:
    He said that he configured th R3 serial interface as a point-to-point interface for the sake of showing how to configure it...

    When you're learning, people suggest things to do -- usually so that you hit a problem and then learn something when you fix it, or to get you to learn another way of doing things and learn some specific points -- like the ones Darby mentioned.

    Since this doesn't look like a "real world problem" -- the real answer probably is "because the teacher said so"

    Quoted fror truth.

    Hell, I didn't expect to have a homework assignment to do today...

    "The Origins of CDP" an essay by Mark Z.

    I'll be done by the end of the day Professor Weaver. icon_lol.gif
    Dude, let's submit the same paper and see if Professor W even notices. You can email it to me icon_wink.gif

    Why am i doing all the work to send it to you?

    So you can hog all the glory? :P icon_lol.gif
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • markzabmarkzab Posts: 619Member
    Mark,

    Keep up the good work. It seems a few people may benefit, even if they did not have a home lab.

    So many things can happen when you are trying to learn and being sincere about it.

    Many have time staying motivated.

    Not when it is interactive like this.

    I'm still at the office and didn't want to bring my lab and install it here yet.

    Everything is still up and running at home. Where we left off it looks like a simple routing issue. Obviously RIP isn't advertising 2612's E0 and TR0 subnets to the 2509.
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • iprouteiproute Posts: 269Member
    markzab wrote:
    Why am i doing all the work to send it to you?

    So you can hog all the glory? :P icon_lol.gif
    That's the point icon_cool.gif
    CCNP Progress
    ROUTE [X] :: SWITCH [X] :: TSHOOT [X]
  • markzabmarkzab Posts: 619Member
    iproute wrote:
    markzab wrote:
    Why am i doing all the work to send it to you?

    So you can hog all the glory? :P icon_lol.gif
    That's the point icon_cool.gif

    icon_lol.gif
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
  • markzabmarkzab Posts: 619Member
    mikej412 wrote:
    With frame-relay "back-to-back without a frame relay switch" -- you don't have LMI... so disable it with the "no keepalive" command on the serial interfaces.

    (This will be lengthy...nah, my posts lengthy?) icon_lol.gif

    Sorry, had to bring this thread back up because I've been seeing the words "no keepalive" flashing through my mind since this post.

    I vaguely remembered using the no keepalive command in the past but could distinguish if I knew it from my NP studies 6 years ago or if it was something I needed to know in regards to the NA. I did a search through my NA ebook for the word keepalive and this is all the came up:

    (Lammle's NA book)

    "Router#sh int fa0/0
    FastEthernet0/0 is up, line protocol is up
    The first parameter refers to the Physical layer, and it’s up when it receives carrier detect. The
    second parameter refers to the Data Link layer, and it looks for keepalives from the connecting
    end. (Keepalives are used between devices to make sure connectivity has not dropped.) Here’s an example:

    Router#sh int s0/0
    Serial0/0 is up, line protocol is down
    If you see that the line is up but the protocol is down, as shown above, you’re experiencing
    a clocking (keepalive) or framing problem. Check the keepalives on both ends to make sure that they match, that the clock rate is set, if needed, and that the encapsulation type is the same on both ends. The output above would be considered a Data Link layer problem."


    Ok, now, this is all I got out of the frame relay section of the NA book (bear with me, I'm getting to a question):

    "LMI Local Management Interface: An enhancement to the original Frame Relay specification.
    Among the features it provides are a keepalive mechanism, a multicast mechanism, global addressing, and a status mechanism."

    Ok, so here are a few questions.

    1. Why did you say to turn off keepalives on the B2B link. I understand it's because I have no switch, but still, why would I shut down something that is watching over my link. And on top of that, why would it be a reason that my link wasn't coming up?

    2. Stemming from the first question, are keepalives seperate from LMI's or the same thing. I mean technically, not hypothetically. Like, if I shut off keepalives with the no keepalive command, am I also shutting off LMI? And if they ARE seperate entities, is the reason I'm shutting off keepalives because they are just doing work that LMI has already done or is doing?

    3. Is this above my NA paygrade? I'm confused as i said earlier because I remember this but seeing as how the above is all I found in the book, should I even be worrying about this before I pass the NA and move on?

    4. Should I just shut up, pass the NA, and move onto the NP where I'll learn all this anyway and not have to waste your time while making my fingers hurt from long ass posts like this? icon_lol.gif
    "You, me, or nobody is gonna hit as hard as life. But it ain't how hard you hit; it's about how hard you can get hit, and keep moving forward. How much you can take, and keep moving forward. That's how winning is done!" - Rocky
Sign In or Register to comment.