Question for Linux experts about boot

KrekenKreken Member Posts: 284
To preface this, I am not a linux expert and just know enough to be dangerous.

I would like to upload an image of Firepower Management Center (FMC) into AWS instead of using the one from the AWS market place. The problem is the downloaded image from Cisco site uses lilo and AWS accepts Linux VMs only with grub boot loader. I contacted Cisco support to help with the conversion and they basically told me to piss off as it's not a supported configuration. How is it unsupported if their image in AWS uses grub? But anyway..

Here is what I found out, correct me if I am wrong. The image uses ext4 volumes. Grub 1.0 is installed but it doesn't recognize ext4, only up to ext3. You need grub 2.0. The upgrade commands I looked up don't work because it is a stripped down version of Linux. From what I could determine, it is based on RHEL6/RED HAT 6 Linux. I even tried booting from an installation disc with RHEL 6 and to install grub from there but it didn't work. Probably due to my linux skills.

Is there a way to convert from ext4 to ext3 without loosing the data?
How can I upgrade to grub 2 if possible in this case?

If you need any extra info, I can start up the vm and run the commands for you.



  • paul78paul78 Member Posts: 3,016 ■■■■■■■■■■
    AWS Import/Export supports ext4 so you are all set there.

    Since it's a Redhat system - see if grub-install is already installed.

    find / -name grub-install

    will search the system

    if found then just run it.

    If not found - you may have to install it. I think this can work

    rpm -i grub
  • KrekenKreken Member Posts: 284
    Thank Paul. It doesn't find grub-install. When I do rpm -i grub I get this error:
    error: open of grub failed: No such file or directory

    Edit: Can I use Will that work and without screwing up the image?
  • paul78paul78 Member Posts: 3,016 ■■■■■■■■■■
    My bad - that's not how rpm works. You will have to find the rpm package for grub.

    I've never tried supergrubdisk - but you could try it. Just make a copy of the image first.

    BTW - it may actually be a Fedora image - you can find the rpm for grub here -

    And then you can run rpm -i <rpmfile>
  • KrekenKreken Member Posts: 284
    Thanks Paul. I tried installing and get the message I am missing eight dependencies.
    It has a folder in /etc/redhat-release so I assumed it was based on redhat even though uname says it is Linux firepower.

    Edit: I think I might skip on this idea and just use the pre-built image in AWS. I can't image going through this everytime I need to upgrade the software.
  • paul78paul78 Member Posts: 3,016 ■■■■■■■■■■
    Yeah - you would need to install the dependencies as well. Alternatively, you can setup RPM so it does the updates and dependencies from a repository. But since I'm not familiar with the Firepower image - that could mess it up.

    But if there is an AWS AMI already - that's probably your best best. Otherwise - if you have to do an upgrade - you would need to figure out the network repos to use and set it up.
Sign In or Register to comment.