help me figure out this ospf configuration

I drew this topology in Boson NetSim 6.
lab1.JPG
and the configuration as below.
What's weired is that I see on "router1" in "sh ip route" that network 192.168.20.160(the switch2 ethernet) is accessible via "192.168.20.161" instead of "10.1.1.6"! how come? can someone tell me what I did wrong?
Another problem: From pc1, I can only ping interfaces on router4, can't ping others. What's wrong?

router1:
!
interface Serial0
ip address 192.168.20.33 255.255.255.224
no ip directed-broadcast
clock rate 64000
!
interface Serial1
description to Router5
ip address 10.1.1.5 255.255.255.252
no ip directed-broadcast
clock rate 64000
!
interface Ethernet0
ip address 192.168.20.97 255.255.255.224
no ip directed-broadcast
ip ospf priority 0
!
interface Ethernet1
ip address 192.168.20.65 255.255.255.224
no ip directed-broadcast
!
!
router ospf 3
network 10.1.1.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
!
ip classless
no ip http server
!

router2:
interface Serial0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet0
ip address 192.168.20.126 255.255.255.224
no ip directed-broadcast
!
interface Bri0
no ip address
no ip directed-broadcast
shutdown
!
!
router ospf 9
network 192.168.20.0 0.0.0.255 area 0
!
ip classless
no ip http server
!

router3:
interface Serial0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet0
ip address 192.168.20.94 255.255.255.224
no ip directed-broadcast
!
interface Bri0
no ip address
no ip directed-broadcast
shutdown
!
!
router ospf 400
network 192.168.20.0 0.0.0.255 area 0
!
ip classless
no ip http server
!

rouer4:
interface Serial0
ip address 192.168.20.62 255.255.255.224
no ip directed-broadcast
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet0
ip address 192.168.20.129 255.255.255.224
no ip directed-broadcast
!
interface Bri0
no ip address
no ip directed-broadcast
shutdown
!
!
router ospf 120
network 192.168.20.0 0.0.0.255 area 0
!
ip classless
no ip http server
!

router5:
interface Serial0
ip address 10.1.1.6 255.255.255.252
no ip directed-broadcast
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet0
ip address 192.168.20.161 255.255.255.224
no ip directed-broadcast
!
interface Bri0
no ip address
no ip directed-broadcast
shutdown
!
!
router ospf 8
network 10.1.1.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
!
ip classless
no ip http server
!

switch1:
hostname switch1
!
!
!
!
ip address 192.168.20.150 255.255.255.224
ip default-gateway 192.168.20.129
!
switch2:
hostname switch2
!
!
!
!
ip address 192.168.20.165 255.255.255.224
ip default-gateway 192.168.20.161
!

PC1:
interface Ethernet0
ip address 192.168.20.135 255.255.255.224
no ip directed-broadcast
!
!
ip classless
no ip http server
!
ip route 0.0.0.0 0.0.0.0 192.168.20.129
!

Comments

  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    madonion wrote:
    What's weired is that I see on "router1" in "sh ip route" that network 192.168.20.160(the switch2 ethernet) is accessible via "192.168.20.161" instead of "10.1.1.6"! how come? can someone tell me what I did wrong?
    router1#show ip route
    <stuff deleted>
    O 192.168.20.160/27 [110/65] via 10.1.1.6, 00:00:18, Serial1

    So -- to answer your 2 questions "how come" and "what did I do wrong" --
    To the first -- you used a simulator and expected it to work. If you save and reload the configs, it will probably work. I pasted your configs into NetSim and they worked for me.

    As to what you did wrong -- you used a simulator and expected it to work. Oh, same answer. When in doubt -- save your configs and then reload. The PC configs may not reload properly -- so individually reload or just manually reconfigure.
    madonion wrote:
    Another problem: From pc1, I can only ping interfaces on router4, can't ping others. What's wrong?

    Same answer as before -- You're using a simulator and are expecting it to work.... save and reload and reconfig the PC if necessary and then it may work.

    This is what I mean about "don't waste time" -- when you start out it may actually be your configuration that is wrong..... but eventually you realize that it could be the simulator just screwing with you..... (or not working as expected or as it should).

    The labs that come with NetSim usually work --- anything else you do might take some effort and still may never work.


    here's the some output ....


    router1#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
           U - per-user static route
    
    Gateway of last resort is not set
    C      192.168.20.96/27 is directly connected, Ethernet0
    C      192.168.20.64/27 is directly connected, Ethernet1
    C      192.168.20.32/27 is directly connected, Serial0
    O      192.168.20.128/27 [110/65] via 192.168.20.62, 00:00:47, Serial0
    C      10.1.1.4/30 is directly connected, Serial1
    O      192.168.20.160/27 [110/65] via 10.1.1.6, 00:00:18, Serial1
    
    
    router1#
    
    Welcome to the Boson NetSim!
    
    
    C:#ping 10.1.1.6
    Pinging 10.1.1.6 with 32 bytes of data:
    
    Reply from 10.1.1.6: bytes=32 time=60ms TTL=241
    Reply from 10.1.1.6: bytes=32 time=60ms TTL=241
    Reply from 10.1.1.6: bytes=32 time=60ms TTL=241
    Reply from 10.1.1.6: bytes=32 time=60ms TTL=241
    Reply from 10.1.1.6: bytes=32 time=60ms TTL=241
    
    Ping statistics for 10.1.1.6:     Packets: Sent = 5, Received = 5, Lost = 0 (0%
    loss),
    Approximate round trip times in milli-seconds:
         Minimum = 50ms, Maximum =  60ms, Average =  55ms
    
    
    C:#ping 192.168.20.126
    Pinging 192.168.20.126 with 32 bytes of data:
    
    Reply from 192.168.20.126: bytes=32 time=60ms TTL=241
    Reply from 192.168.20.126: bytes=32 time=60ms TTL=241
    Reply from 192.168.20.126: bytes=32 time=60ms TTL=241
    Reply from 192.168.20.126: bytes=32 time=60ms TTL=241
    Reply from 192.168.20.126: bytes=32 time=60ms TTL=241
    
    Ping statistics for 192.168.20.126:     Packets: Sent = 5, Received = 5, Lost =
    0 (0% loss),
    Approximate round trip times in milli-seconds:
         Minimum = 50ms, Maximum =  60ms, Average =  55ms
    
    
    
    :mike: Cisco Certifications -- Collect the Entire Set!
  • the_return_of_the_Ringthe_return_of_the_Ring Member Posts: 119
    thank you so much! I'll see what's gonna be after reload
  • the_return_of_the_Ringthe_return_of_the_Ring Member Posts: 119
    thank you, Mikej412! I saved and reloaded, 1 out of 3 tries the router1 shows correct routing table.
    So the simulator way is not really good for operating, is it?
  • mikej412mikej412 Member Posts: 10,086 ■■■■■■■■■■
    madonion wrote:
    I saved and reloaded, 1 out of 3 tries the router1 shows correct routing table.
    So the simulator way is not really good for operating, is it?
    If you try anything outside of the labs that ship with the product -- you could hit problems like inconsistant results, as you've seen.

    Once you know there are problems with using the simulator, you can try the save/reload work-around -- but yeah, it gets annoying after a while.

    If you want to go beyond the minimum required to pass the CCNA exam, then yeah, you may eventually have to give up on the simulators and use real hardware (buy it, rent it, borrow it, or use a work/school lab).

    Perhaps someday those darn simulators will work better (and deliver what they promise)
    :mike: Cisco Certifications -- Collect the Entire Set!
Sign In or Register to comment.