Options

VLAN DHCP Pool

Dale812Dale812 Member Posts: 15 ■□□□□□□□□□
I've just setup a VLAN on a L3 switch and now need to create the new DHCP pool on the router to assign IP's to the VLAN.

I have the L3 switch connected directly to the router in which all my DHCP pools are on but the PC's on the VLAN are not grabbing an IP from the pool.

Config below...

Switch:

ip routing
!
interface FastEthernet0/1
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
!
interface Vlan10
mac-address 000b.be31.d901
ip address 192.168.0.17 255.255.255.240
ip helper-address 192.168.1.1 (int IP of router holding the pools)

Router:

ip dhcp pool Corp
network 192.168.0.16 255.255.255.240
default-router 192.168.0.17
dns-server 172.16.0.6

Pool Corp:
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 14
Leased addresses : 0
Excluded addresses : 10
Pending event : none


1 subnet is currently in the pool
Current index IP address range Leased/Excluded/Total
192.168.0.17 192.168.0.17 - 192.168.0.30 0 / 10 / 14

Any ideas? Cheers!

Comments

  • Options
    DPGDPG Member Posts: 780 ■■■■■□□□□□
    Does your switch have a route to the helper-address?
  • Options
    Dale812Dale812 Member Posts: 15 ■□□□□□□□□□
    I've setup RIPv2 on both the switch and router but none of which seem to be picking up the routes. I've also tried setting up a static route but doesn't show the route in the table.

    Switch:

    router rip
    version 2
    network 192.168.0.0
    no auto-summary


    Gateway of last resort is not set


    192.168.0.0/28 is subnetted, 2 subnets
    C 192.168.0.16 is directly connected, Vlan10
    C 192.168.0.32 is directly connected, Vlan20

    Router:


    router rip
    version 2
    network 172.16.0.0
    network 192.168.0.0
    network 192.168.1.0
    no auto-summary


    Gateway of last resort is not set


    15.0.0.0/30 is subnetted, 1 subnets
    R 15.15.15.0 [120/1] via 172.16.0.2, 00:00:11, Serial0/0/0
    172.16.0.0/30 is subnetted, 2 subnets
    C 172.16.0.0 is directly connected, Serial0/0/0
    R 172.16.0.4 [120/1] via 172.16.0.2, 00:00:11, Serial0/0/0
    192.168.0.0/28 is subnetted, 1 subnets
    C 192.168.0.0 is directly connected, FastEthernet0/0
    192.168.1.0/29 is subnetted, 3 subnets
    C 192.168.1.0 is directly connected, FastEthernet0/1
    C 192.168.1.8 is directly connected, FastEthernet0/1.10
    C 192.168.1.16 is directly connected, FastEthernet0/1.20
    192.168.2.0/29 is subnetted, 3 subnets
    S 192.168.2.0 is directly connected, Serial0/0/0
    R 192.168.2.8 [120/1] via 172.16.0.2, 00:00:11, Serial0/0/0
    R 192.168.2.16 [120/1] via 172.16.0.2, 00:00:11, Serial0/0/0

    The PC's connected to the L3 switch could communicate with all the other PC's on the network before the VLAN's were created with new IP's.
  • Options
    DPGDPG Member Posts: 780 ■■■■■□□□□□
    What do your interface configurations look like between the switch and router?
  • Options
    IsmaeljrpIsmaeljrp Member Posts: 480 ■■■□□□□□□□
    I would say post the full configs as the information you have provided isn't enough. Also, either include a diagram or put descriptions on your physical interfaces.
Sign In or Register to comment.