please check what's wrong in this vlan practise
the_return_of_the_Ring
Member Posts: 119
in CCNA & CCENT
After configuring everything, I can only ping the hosts in the same vlan, along with the default gateway. Is there a mistake inside? I'm using NetSim 6 final beta.
Router1:
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
bandwidth 100000
!
interface FastEthernet0/0.1
encapsulation dot1q 2
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1q 3
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1q 4
ip address 192.168.30.1 255.255.255.0
!
Switch1:
!
interface FastEthernet0/1
switchport access vlan 2
!
interface FastEthernet0/2
switchport access vlan 2
!
interface FastEthernet0/3
switchport access vlan 3
!
interface FastEthernet0/4
switchport access vlan 3
!
interface FastEthernet0/5
switchport access vlan 4
!
interface FastEthernet0/6
switchport access vlan 4
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
switchport mode trunk
!
vtp domain bigdomain
!
interface Vlan 1
no ip address
no ip route-cache
!
interface Vlan0002
no ip address
no ip route-cache
!
vlan 2 name sales
vlan 3 name accountant
vlan 4 name tech
!
pc1: ip address is 192.168.10.2/24
pc2: ip address is 192.168.10.3/24
pc3: ip address is 192.168.20.2/24
pc4: ip address is 192.168.20.3/24
pc5: ip address is 192.168.30.2/24
pc6: ip address is 192.168.30.3/24
Router1:
!
interface FastEthernet0/0
no ip address
no ip directed-broadcast
bandwidth 100000
!
interface FastEthernet0/0.1
encapsulation dot1q 2
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.2
encapsulation dot1q 3
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1q 4
ip address 192.168.30.1 255.255.255.0
!
Switch1:
!
interface FastEthernet0/1
switchport access vlan 2
!
interface FastEthernet0/2
switchport access vlan 2
!
interface FastEthernet0/3
switchport access vlan 3
!
interface FastEthernet0/4
switchport access vlan 3
!
interface FastEthernet0/5
switchport access vlan 4
!
interface FastEthernet0/6
switchport access vlan 4
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
switchport mode trunk
!
vtp domain bigdomain
!
interface Vlan 1
no ip address
no ip route-cache
!
interface Vlan0002
no ip address
no ip route-cache
!
vlan 2 name sales
vlan 3 name accountant
vlan 4 name tech
!
pc1: ip address is 192.168.10.2/24
pc2: ip address is 192.168.10.3/24
pc3: ip address is 192.168.20.2/24
pc4: ip address is 192.168.20.3/24
pc5: ip address is 192.168.30.2/24
pc6: ip address is 192.168.30.3/24
Comments
-
chinaman Inactive Imported Users Posts: 167It seem's your configuration okay,what is the default gateway of each pc's can you list it to me.
-
mikej412 Member Posts: 10,086 ■■■■■■■■■■Test connectivity by pinging from the router....
Check the Router1 routing table -- 3 directly connected networks, right?
And with NetSim this was one of the issues -- did you try the save and restart and reload config trick? If the PCs didn't get configs reloaded properly, try the individual reload or reconfigure manually.:mike: Cisco Certifications -- Collect the Entire Set! -
EdTheLad Member Posts: 2,111 ■■■■□□□□□□Hey Mike,you have more patience than me , i couldnt be bothered answering questions regarding simulators anymore.Networking, sometimes i love it, mostly i hate it.Its all about the $$$$
-
the_return_of_the_Ring Member Posts: 119chinaman wrote:It seem's your configuration okay,what is the default gateway of each pc's can you list it to me.
pc1:
!
interface Ethernet0
ip address 192.168.10.2 255.255.255.0
no ip directed-broadcast
!
!
ip classless
no ip http server
!
ip route 0.0.0.0 0.0.0.0 192.168.10.1
!
pc2:
!
interface Ethernet0
ip address 192.168.10.3 255.255.255.0
no ip directed-broadcast
!
!
ip classless
no ip http server
!
ip route 0.0.0.0 0.0.0.0 192.168.10.1
!
pc3:
!
interface Ethernet0
ip address 192.168.20.2 255.255.255.0
no ip directed-broadcast
!
!
ip classless
no ip http server
!
ip route 0.0.0.0 0.0.0.0 192.168.20.1
!
pc4:
!
interface Ethernet0
ip address 192.168.20.3 255.255.255.0
no ip directed-broadcast
!
!
ip classless
no ip http server
!
ip route 0.0.0.0 0.0.0.0 192.168.20.1
!
pc5:
!
interface Ethernet0
ip address 192.168.30.2 255.255.255.0
no ip directed-broadcast
!
!
ip classless
no ip http server
!
ip route 0.0.0.0 0.0.0.0 192.168.30.1
!
pc6:
!
interface Ethernet0
ip address 192.168.30.3 255.255.255.0
no ip directed-broadcast
!
!
ip classless
no ip http server
!
ip route 0.0.0.0 0.0.0.0 192.168.30.1
! -
the_return_of_the_Ring Member Posts: 119mikej412 wrote:Test connectivity by pinging from the router....
Check the Router1 routing table -- 3 directly connected networks, right?
And with NetSim this was one of the issues -- did you try the save and restart and reload config trick? If the PCs didn't get configs reloaded properly, try the individual reload or reconfigure manually. -
mikej412 Member Posts: 10,086 ■■■■■■■■■■ed_the_lad wrote:Hey Mike,you have more patience than me , i couldnt be bothered answering questions regarding simulators anymore.
If the reload didn't work.... try pinging 7 or 8 times in a row from each PC.... if it randomly starts working from one PC... it may then work until the next change for all PCs...... Or it could be a configuration issue....
You don't have an admin VLAN IP Address -- shouldn't matter in real life -- but it may to NetSim
Directly connected networks on the router... default gateway on the PCs... IP routing enabled, but no routing protocol running.... should work, but you never know what those programmers were drinking or smoking when they were supposed to be programming NetSim.....:mike: Cisco Certifications -- Collect the Entire Set! -
SV Member Posts: 166Even I had a tough time with VLAN setup initially with Netsim. Later I found the work around. This was a different issue.
http://www.techexams.net/forums/viewtopic.php?p=59021#59021
Let me see if I can use my old netsim and replicate your scenario.Life is a journey... -
SV Member Posts: 166It worked fine with my netsim 5.31
I used your diagram but changed the router configuration a bit.
interface FastEthernet 0/0.1
encapsulation dot1q 1
ip address 192.168.0.1 255.255.255.0
interface FastEthernet 0/0.2
encapsulation dot1q 2
ip address 192.168.10.1 255.255.255.0
interface FastEthernet 0/0.3
encapsulation dot1q 3
ip address 192.168.20.1 255.255.255.0
interface FastEthernet 0/0.4
encapsulation dot1q 4
ip address 192.168.30.1 255.255.255.0
In the switch (int 0/12) I used the command:
switchport access vlan all
I am able to ping all the systems.
Regards,
ShijuLife is a journey...