#ip route
boxerboy1168
Member Posts: 395 ■■■□□□□□□□
in CCNA & CCENT
I've been trying to figure this out for a while now and I'm basically stuck it's not making sense and none of my material has an answer for me.
Here is my configuration...
SW1-
(#show ip int br)
Vlan2 10.0.0.2 YES manual up up
Vlan3 20.0.0.2 YES manual up up
Trunk configuration -
interface GigabitEthernet0/1
switchport trunk allowed vlan 2-3
switchport mode trunk
(#show run)
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 3
switchport mode access
interface GigabitEthernet0/1
switchport trunk allowed vlan 2-3
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
mac-address 00d0.ffcd.1b02
ip address 10.0.0.2 255.0.0.0
!
interface Vlan3
mac-address 00d0.ffcd.1b01
ip address 20.0.0.2 255.0.0.0
R1 -
(#show ip int br)
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES unset up up
GigabitEthernet0/0.2 10.0.0.3 YES manual up up
GigabitEthernet0/0.3 20.0.0.3 YES manual up up
GigabitEthernet0/1 unassigned YES unset up down
Vlan1 unassigned YES unset administratively down down
Host IP -
H1 -
10.0.0.10 255.0.0.0
H2-
20.0.0.20 255.0.0.0
On the router this is #show ip route output -
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/8 is directly connected, GigabitEthernet0/0.2
L 10.0.0.3/32 is directly connected, GigabitEthernet0/0.2
20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 20.0.0.0/8 is directly connected, GigabitEthernet0/0.3
L 20.0.0.3/32 is directly connected, GigabitEthernet0/0.3
Ok. So, I may not have the proper IP address scheme setup so that is 1 area I need more guidance apparently. When I configure the VLAN do I assign the vlan IP address the network address of 20.0.0.0 255.0.0.0 or do I assign the VLAN IP address a usable address such as 20.0.0.3 255.0.0.0??
When I assign the IP address to the sub interfaces obviously I am suppose to assign a usable IP address correct?
When I try to -
Router(config)#ip route 10.0.0.3 255.0.0.0 20.0.0.3
I get -
%Inconsistent address and mask
What does that mean?
Can someone help me out here?
Here is my configuration...
SW1-
(#show ip int br)
Vlan2 10.0.0.2 YES manual up up
Vlan3 20.0.0.2 YES manual up up
Trunk configuration -
interface GigabitEthernet0/1
switchport trunk allowed vlan 2-3
switchport mode trunk
(#show run)
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 3
switchport mode access
interface GigabitEthernet0/1
switchport trunk allowed vlan 2-3
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
mac-address 00d0.ffcd.1b02
ip address 10.0.0.2 255.0.0.0
!
interface Vlan3
mac-address 00d0.ffcd.1b01
ip address 20.0.0.2 255.0.0.0
R1 -
(#show ip int br)
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES unset up up
GigabitEthernet0/0.2 10.0.0.3 YES manual up up
GigabitEthernet0/0.3 20.0.0.3 YES manual up up
GigabitEthernet0/1 unassigned YES unset up down
Vlan1 unassigned YES unset administratively down down
Host IP -
H1 -
10.0.0.10 255.0.0.0
H2-
20.0.0.20 255.0.0.0
On the router this is #show ip route output -
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/8 is directly connected, GigabitEthernet0/0.2
L 10.0.0.3/32 is directly connected, GigabitEthernet0/0.2
20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 20.0.0.0/8 is directly connected, GigabitEthernet0/0.3
L 20.0.0.3/32 is directly connected, GigabitEthernet0/0.3
Ok. So, I may not have the proper IP address scheme setup so that is 1 area I need more guidance apparently. When I configure the VLAN do I assign the vlan IP address the network address of 20.0.0.0 255.0.0.0 or do I assign the VLAN IP address a usable address such as 20.0.0.3 255.0.0.0??
When I assign the IP address to the sub interfaces obviously I am suppose to assign a usable IP address correct?
When I try to -
Router(config)#ip route 10.0.0.3 255.0.0.0 20.0.0.3
I get -
%Inconsistent address and mask
What does that mean?
Can someone help me out here?
Currently enrolling into WGU's IT - Security Program. Working on LPIC (1,2,3) and CCNA (and S) as long term goals and preparing for the Security+ and A+ as short term goals.
Comments
-
TechGuru80 Member Posts: 1,539 ■■■■■■□□□□Well you are saying ip route 10.0.0.3 255.0.0.0...change it to 10.0.0.0 255.0.0.0.
You are giving a specific IP with a network where it should be a network. If you want that specific address, a subnet of 255.255.255.255 should work. -
boxerboy1168 Member Posts: 395 ■■■□□□□□□□Ok, so I essentially tell the router that anything coming in on 10.% network from interface % will go out network %?
Also, the interface that the sub interfaces are configured on, does that require an IP address?Currently enrolling into WGU's IT - Security Program. Working on LPIC (1,2,3) and CCNA (and S) as long term goals and preparing for the Security+ and A+ as short term goals. -
boxerboy1168 Member Posts: 395 ■■■□□□□□□□So I changed the IP routing IP address to the network rather than an IP specified within in the network and my output for
#do show ip route
is
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/8 is directly connected, GigabitEthernet0/0.2
L 10.0.0.100/32 is directly connected, GigabitEthernet0/0.2
20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 20.0.0.0/8 is directly connected, GigabitEthernet0/0.3
L 20.0.0.100/32 is directly connected, GigabitEthernet0/0.3
Should the change in route show up in the show ip route command?
Next I tried
Router(config)#ip route 20.0.0.0 255.0.0.0 gig
Router(config)#ip route 20.0.0.0 255.0.0.0 gigabitEthernet 0/0.2
%Default route without gateway, if not a point-to-point interface, may impact performance
And ^^^^^ was my output.
Really not sure what's going on here.Currently enrolling into WGU's IT - Security Program. Working on LPIC (1,2,3) and CCNA (and S) as long term goals and preparing for the Security+ and A+ as short term goals.