IPV6 HSRP, how?

ciscobeginnerneedhelpasapciscobeginnerneedhelpasap Member Posts: 14 ■□□□□□□□□□
I couldn't get it to work, I have full network connectivity without HSRP, I was able to ping every single interface from anywhere I wanted. But when I enabled HSRP and turned off R2 (that's the main router in my HSRP config), nothing worked. I put fe80::1 as the default gateway for PC2 (vlan 20) and PC3 (vlan 30), but nothing worked. I kept getting "destination net unreachable" when I closed the fa0/0 port on Router 2 or Router 3 whenever I tried to ping from PC2 or PC3 to PC1 and vice versa.

I have four vlans.
Vlan 10 = 2001:50:10::/64
Vlan 20 = 2001:50:20::/64
Vlan 30 = 2001:50:20::/64
Vlan 90 (native)

serial between r1 and r2 = 2001:20::/64
serial between r1 and r3 = 2001:21::/64
r1 to pc1 = 2001:10::/64

r1 configuration https://pastebin.com/raw/HrtEXVXv
r2 configuration https://pastebin.com/raw/BcX5pR4g
r3 configuration https://pastebin.com/raw/dL6cfer5
i forgot "ipv6 unicast-routing", but it's there on the routers and on all switches. The switches are all properly configured I think, because I could ping from PC2 or PC3 to PC1 and vice versa before trying to implement HSRP. When I turn off router 2 or router 3, I can't ping PC1 at all...

topology (PC1's IPv6 is 2001:11::5/64, hence ipv6 route ::/0 2001:11::5/64)

Please help me.


  • Welly_59Welly_59 Member Posts: 431
    What is the purpose of R1? Hsrp is a gateway redundancy protocol. R1 should be a switch, and R2/3 need to be providing gateway redundancy out of pc1's LAN
  • Welly_59Welly_59 Member Posts: 431
    Oh my bad sorry, it's back to front
  • ciscobeginnerneedhelpasapciscobeginnerneedhelpasap Member Posts: 14 ■□□□□□□□□□
    I'm treating the R1 as a modem to the ISP network, so the PC1 represents a random PC on a different network. I got HSRP working on IPv4... but not on IPv6. Not sure what I'm doing that's supposedly wrong, it says "destination net unreachable" which implies it doesn't know how to reach the PC1 network.. even though I've added a default route "ipv6 route ::/0 2001:10::5/64" and redistributed it with eigrp.

  • Welly_59Welly_59 Member Posts: 431
    The default route needs to point to the next hop, not the IP of the destination
  • ciscobeginnerneedhelpasapciscobeginnerneedhelpasap Member Posts: 14 ■□□□□□□□□□
    What would the next hop be in that topology? This one? 2001:10::1/64? I tried "ipv6 route ::/0 f0/0" (f0/0 is the interface that connects to pc1) and it also didn't work

  • Welly_59Welly_59 Member Posts: 431
    Do R2 and r3 have the default route in their routing table?
  • ciscobeginnerneedhelpasapciscobeginnerneedhelpasap Member Posts: 14 ■□□□□□□□□□
    I think so. I'm using EIGRP and it shows up as EX*
Sign In or Register to comment.